1.1b1 driver bugs

Discussion in 'MAC OS X Driver' started by Eugene Gavrilov, Sep 13, 2008.

  1. Eugene Gavrilov

    Eugene Gavrilov kX Project Lead Programmer and Coordinator

    Joined:
    Dec 7, 2002
    Messages:
    3,146
    Likes Received:
    9
    Trophy Points:
    48
    please report 1.1b1-specific issues and bugs here

    if you think the bug requires additional information or discussion, start a new topic and do only post a very brief description of the problem in this thread (as well as a link to your new topic)

    PLEASE do not post suggestions, ideas, 'thanks', 'how do I' questions here!

    E.
     
    Last edited: Sep 15, 2008
  2. themax

    themax New Member

    Joined:
    Oct 25, 2007
    Messages:
    23
    Likes Received:
    0
    Trophy Points:
    0
    All good in Audigy ZS, multichanel, etc...The nly problem is the sound is too "maximized" too high peaks.

    Multichanel is working, 1ms latency whiout cripies.
    Here a screen of Traktor smultichanel setup.
    [​IMG]

    Thanks for your work.
     
    Last edited: Sep 13, 2008
  3. shad0wca7

    shad0wca7 New Member

    Joined:
    Sep 10, 2008
    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    0
    Distortion on SB Live Value is still there but takes longer to come in now (about 10 minutes as opposed to 1)
     
  4. cjseriy

    cjseriy New Member

    Joined:
    Sep 11, 2008
    Messages:
    10
    Likes Received:
    0
    Trophy Points:
    0
    Delays and distortion still remains in SB Live. I changed Rate in Logic to 48 but it doesnt help. Also problem remains when playing Sound Effects in System Preferences -> Sound in Leopard.
     
    Last edited: Sep 14, 2008
  5. Insphire

    Insphire New Member

    Joined:
    Mar 31, 2003
    Messages:
    27
    Likes Received:
    0
    Trophy Points:
    0
    Kernel Panics with this beta...

    Hi there Eugene, for me, in terms of sound quality and features this version works exactly like b0, with the only one exception that when using this version I'm getting kernel panics in a random basis.
    I'm 100% sure that the problem is with the KX driver, because i rolled back to b0 and panics dissapeared, i also tried installing b1 again, and after some minutes the system crashes.

    If you need further info about my system, a memory dump or anything, just PM me.

    [​IMG]

    Leopard 10.5.4 / Quad Core Q6600 / 8GB RAM / geForce 7300GT / Audigy 2 Platinum
     
  6. djsubject

    djsubject New Member

    Joined:
    Aug 16, 2008
    Messages:
    63
    Likes Received:
    0
    Trophy Points:
    0
    FWIW, my 1820m is just the same with b1 as it was with b0, (so no bugs added)

    i know this update was a fix for users of the older cards, but i thought i would just report that all is well still here :)

    Subz
     
  7. xubloy

    xubloy New Member

    Joined:
    Sep 15, 2008
    Messages:
    5
    Likes Received:
    0
    Trophy Points:
    0
    HI,
    sb0380 just works well after installing this driver without reboot and I get kernel panic every time when the os is booting in default mode.
    os:iatkos v4i(10.5.4) and iatkos v1r2(10.5.1)
    Thank you for your try!
     
  8. igorexxa

    igorexxa New Member

    Joined:
    Aug 27, 2008
    Messages:
    9
    Likes Received:
    0
    Trophy Points:
    0
    Emu 0404 pci work, but I'm getting kernel panics when plays music in iTunes, but when working in Logic I dont have kernel panics and all good. sorry for my English.
    Emu 0404 pci ðàáîòàåò ñ ýòèìè äðàéâåðàìè, âûëåòàåò kernel panics êîãäà èãðàåò ìóçûêà â iTunes, íî êîãäà ÿ ðàáîòþ â Logic, kernel panics íåò âñå ðàáîòàåò óñòîé÷èâî.
     
  9. Eugene Gavrilov

    Eugene Gavrilov kX Project Lead Programmer and Coordinator

    Joined:
    Dec 7, 2002
    Messages:
    3,146
    Likes Received:
    9
    Trophy Points:
    48
    kernel panics:
    start a new thread in this forum with a detailed description of the panic - you will need to start OS X with '-v' flag (to track boot panics) or use flag 'debug=0x144' - in this case you won't get just a gray screen with a prompt to reboot, but more information on the place of the bug.

    E.
     
  10. themax

    themax New Member

    Joined:
    Oct 25, 2007
    Messages:
    23
    Likes Received:
    0
    Trophy Points:
    0
    Yes, firt time i installed 1.1b0 i get kernel panic also,the system dosn`t boot up, i needed restore a backup of me system.

    After restore i uninstalled previous version and installed 1.1b0 again, and all go fine, uninstalled and install 1.1b1 and go fine.

    Sorry but no description of the kernel panic is available.
     
  11. xubloy

    xubloy New Member

    Joined:
    Sep 15, 2008
    Messages:
    5
    Likes Received:
    0
    Trophy Points:
    0
    I made it,though i don't exactly know what the problem is. so i just note down steps.
    1.change multicanal to 7.1 which originally shows stereo
    2.cleared cache and repaired permission (maybe the key)
    I hope this would be useful for other peolpe with kernel panic
     
  12. Insphire

    Insphire New Member

    Joined:
    Mar 31, 2003
    Messages:
    27
    Likes Received:
    0
    Trophy Points:
    0
    Eugene, when i try to open a new thread as you suggested, it says that "i Don't have permission to create a new thread", anyway, i made it panic again several times (this is a new OS install btw), but somehow the crash dumps are not being saved into /Library/logs or /var/log ....
    So this is the best i can go for now:

    [​IMG]

    IOAudioFamily.
     
  13. neal123

    neal123 New Member

    Joined:
    Sep 17, 2008
    Messages:
    1
    Likes Received:
    0
    Trophy Points:
    0
    Delays and distortion still remains in SB Live Value(C500).My OsX is 10.4.11. Distortion after 1 M.
     
  14. DrunkenDonkey

    DrunkenDonkey New Member

    Joined:
    Aug 18, 2008
    Messages:
    5
    Likes Received:
    0
    Trophy Points:
    0
    Confirmed, same distortion on SB Live (0222). For the record kextstat:
    69 0 0x5a795000 0x3b000 0x3a000 com.kXProject.driver.kXAudioDriver (1.1b1) <60 17 12>
     
  15. catboy

    catboy New Member

    Joined:
    Aug 12, 2008
    Messages:
    6
    Likes Received:
    0
    Trophy Points:
    1
    Audigy 2 Zs

    OS: 10.5.4 Intel core2duo, use EFI and Apple kernel.

    Sound works great, 5.1 works. in Reason can connect all channels..

    but !! same times system freeze with sound looping.. then must press Reset.

    1.1 b0 no freezes..

    if exist any process to debug the freeze tell how.. and i do it..
     
  16. existation

    existation New Member

    Joined:
    Oct 13, 2007
    Messages:
    8
    Likes Received:
    0
    Trophy Points:
    0
    Kernel Panic. 1 or 2 times per day.
    Using
    System Software Overview:
    System Version: Mac OS X 10.5.4 (9E17) Kalyway10.5.2->10.5.3->10.5.4
    Kernel Version: Darwin 9.4.0
    Crative Audigy SB0090
     
  17. Misfire

    Misfire New Member

    Joined:
    Sep 20, 2008
    Messages:
    1
    Likes Received:
    0
    Trophy Points:
    0
    Hey

    the driver works great but the high frequencies are way too harsh and fatiguing.

    I have Audigy 2 ZS
     
  18. cjseriy

    cjseriy New Member

    Joined:
    Sep 11, 2008
    Messages:
    10
    Likes Received:
    0
    Trophy Points:
    0
    I installed Xcode, opened hallab, but i didnt find any Telemetry there, so I couldnt capture 'Telemetry' output during correct and distorted audio.
     
  19. Oxtie

    Oxtie Active Member

    Joined:
    May 14, 2008
    Messages:
    137
    Likes Received:
    0
    Trophy Points:
    26
    1. Kernel Panics (aka freeze) for Audigy & some Live series (using previous 1.1b0 fixes Audigy)
    2. Distortion for live series (Check out Hagar's workaround)
    3. Quality loss (SSSSsss noise) (aka high treble) (aka massive bass and distorted trebles) (aka Tinny) (aka high frequencies)
    4. Streaming Media not playable (aka Real Player Bird Twitter)
    5. Shutdown/StandBy Issues (some people report their systems no longer shuts down)
    6. Starting Logic = Kernal Panic (only on 1.1b1, b0=OK)
    7. Games with OpenAL not playable (eg Quake4) (openAL installed, 1.1b0 & 1.1b1 confirmed not working)
    8. CoreAudio Fails on VirtualBox (PC Emulator for osx virtualbox.org)
    9. Headphones play surrounded channel when AC3 or 5.1 media is played
    10. Sudden Volume increase with bass distortion when Audio crosses stable peak boundary (eg. intro music 30 sec stable and then drums crossing boundary of peak and bass distortion starts)
     
    Last edited: Oct 7, 2008
  20. iCrazy

    iCrazy New Member

    Joined:
    Aug 14, 2008
    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    0
    Creative Live! 5.1 PCI\VEN_1102&DEV_0002&SUBSYS_80611102&REV_07\4&1FAF5EA3&0&08F0
    Sound became distorting after attempt to play any sound in iTunes or VLC.
    When i playing system sounds, distortion not appear...
     

Share This Page

visited