3534 update - e2

Discussion in '3-D Audio' started by Eugene Gavrilov, Aug 13, 2003.

  1. Eugene Gavrilov

    Eugene Gavrilov kX Project Lead Programmer and Coordinator

    Joined:
    Dec 7, 2002
    Messages:
    3,146
    Likes Received:
    9
    Trophy Points:
    48
    hi there, 3-D people ;)

    after releasing a post-3534 update (e1), here's a second one -- 3534e2
    it might fix Doppler issues

    http://kx.maincore.nl/beta/kx3534e2.rar

    installation: copy to windows\system32\drivers, reboot

    /Eugene
     
  2. vampgirl

    vampgirl New Member

    Joined:
    May 24, 2003
    Messages:
    47
    Likes Received:
    0
    Trophy Points:
    0
    duh!

    I was waiting and checking for this promised update. But I was chaecking in the General Discussion.

    Thanx again Eugene :)
     
  3. HumanRes

    HumanRes New Member

    Joined:
    Mar 6, 2003
    Messages:
    26
    Likes Received:
    0
    Trophy Points:
    0
    Hi,

    tested e2, and found out the following in Unreal Tournament.

    ->1st Test:
    UseDirectSound=True
    Use3DHardware=False
    -> Sounds good! No Pitch-shift/disorted sounds. Normal sound volume.

    ->2nd Test:
    UseDirectSound=True
    Use3DHardware=True
    -> no main sounds missing anymore. I recognized that the sound is generally at lower volume. But the ambient gets still abnormal lound on some locations / movements, and then i get clicks. But no Pitch shift anymore.

    Log for both tests:
    Init: Galaxy is using DirectSound
    Init: EAX 1.x sound hardware found!
    Init: Galaxy initialized

    Furthermore, Rightmark 3dSound now reports EAX3 is enabled (with e1 it didn't). In 3dSound subjective test in all three hardware modes (hardware, eax2+3) i get some clicks when moving the sound source very fast with the mouse (angle+ xy-axis). In software mode, there are no clicks when i do the same. Maybe latency problem.

    RM3D CPU utilisation test: no more sounds missing, but in hardware modes still fast left/right switching and minor clicks. Still don't know how it should sound, don't have a reference.

    So i think, half the work is done. Thanks!
     
  4. Eugene Gavrilov

    Eugene Gavrilov kX Project Lead Programmer and Coordinator

    Joined:
    Dec 7, 2002
    Messages:
    3,146
    Likes Received:
    9
    Trophy Points:
    48
    thanks for your report!

    -----

    all the future messages related to 3-D audio will be posted to the '3-D Audio' forum

    >> Use3DHardware=False

    of course it should sound [more or less] good - it is emulated by Microsoft ;)

    >> Use3DHardware=True
    >> -> no main sounds missing anymore. I recognized that the sound is generally at lower volume.
    >> But the ambient gets still abnormal lound on some locations / movements,
    >> and then i get clicks.

    clicks are expected -- they are caused by present spatialization mechanism (in hardware) -- I will need to have a closer look at CL drivers to be enlightened on this topic :) btw, the same problem happens when tweaking some MIDI Controllers (kX Synth issue)

    but we should try to fix abnormal volume first!
    could you provide more details? when? why? how?..

    >> But no Pitch shift anymore

    this is good -- the main issue with Doppler is finally solved

    >> Rightmark 3dSound now reports EAX3 is enabled

    EAX stuff isn't currently functional at all -- we need to finish our Reverb engine first
    anyway, I've added some code to make the driver 'EAX1,2,3-capable' (at least to report such functionality)
    so, all three modes ('hardware', 'eax2', 'eax3') are (and should be) totally identical

    /Eugene
     
  5. kimi40

    kimi40 New Member

    Joined:
    Jun 29, 2003
    Messages:
    34
    Likes Received:
    0
    Trophy Points:
    0
    Does the eax3 wiil also be supported by sblive ? How about the number of voices thing ? You know the 3dmark2003 audio benchmark ? Can sblive user able to run the 64 voices thing ? How about openal API, do you guys think about this ? Thanks
     
  6. ArconX

    ArconX New Member

    Joined:
    Mar 11, 2003
    Messages:
    23
    Likes Received:
    0
    Trophy Points:
    0
    Beta Test e2 with BattleField 1942 (Map: Battle Of Britain).

    Ok, here is a update from BF1942:

    5.10.0.3534 -> Upgraded to e2 (copy of file).

    Started Sound Recorder
    Started Bf1942 (already enabled HW sound (31 voice auto selected by the program)).
    Loaded Map Single Player (with bots): Battle Of Britain
    Spawned in Hanger
    In the background you hear 2 bombers going up (sound is not very mutch distorted).
    I move around (you hear the change in sound position, you dont hear the foot steps).
    I shoot gun ... you dont hear it mutch
    I start in a airplain, and get of the ground (normal you need to hear engine sound). We are around 70 or 80 sec in the audio track.
    I start blasting with the guns & drop 1 bomp ( that sharps clicking you here is the sound, also, when i release my triger finger (not on audio track), the sound kept going for a few second more).

    Here is a audio file, to help you get a better idear how things sound & what might be the problem.
    http://www.dnh-clan.com/stuff/kx-e2.mp3


    Now i'm off to bed, if you want, i can use the same methode in a few hours on other game's to see what they sound like (100 sec limit, thats the limit of the program i'm using).
     
  7. HumanRes

    HumanRes New Member

    Joined:
    Mar 6, 2003
    Messages:
    26
    Likes Received:
    0
    Trophy Points:
    0
    Sound sample

    Ok, i recorded a sample too. You hear Unreal Tournament, how it sounds with UseDirectSound=True and Use3DHardware=False/True. I recorded about 40 secs for each test case. With Use3DHardware=True, it seems it didn't record some sounds but they were there during gameplay. Maybe this is because of UseSurround=True -Parameter, it seems the menu sounds and some of the 360 degree turn while the volume abnomality are not completely recorded.

    I included the debugview logs too, on the first sight the log amount is about 3 times bigger with 3DHardware. I didn't cut the silence at the beginning, so the log-time can compared with the recorded time.

    http://pms.voessing.de/home.nsf/0/5144af46e946951DC1256d82005989bd/$File/e2.rar

    All i done is moving around a bit in the same level. It's a small one and i went to the same places, except the start point was different.

    HR
     
  8. Eugene Gavrilov

    Eugene Gavrilov kX Project Lead Programmer and Coordinator

    Joined:
    Dec 7, 2002
    Messages:
    3,146
    Likes Received:
    9
    Trophy Points:
    48
    actually, stereo recordings won't help
    it is necessary to record front, rear & center channels separately

    anyway, I currently don't have any of the above-mentioned games installed, so I cannot reproduce the bug
    the preferred was is to use microsoft/creative test utilities -- I will upload them soon

    /E
     
  9. ArconX

    ArconX New Member

    Joined:
    Mar 11, 2003
    Messages:
    23
    Likes Received:
    0
    Trophy Points:
    0
  10. inteks

    inteks New Member

    Joined:
    Nov 28, 2002
    Messages:
    90
    Likes Received:
    0
    Trophy Points:
    0
  11. kode54

    kode54 New Member

    Joined:
    Oct 31, 2002
    Messages:
    30
    Likes Received:
    0
    Trophy Points:
    0
    Right at the edge of the audible range? Happens with Creative's drivers, too. Might be a bug in UT, but I haven't tested with any other DS3D sound cards. I'll check later with my YMF-724 card, when I happen to be using Windows 98SE again.
     
  12. Eugene Gavrilov

    Eugene Gavrilov kX Project Lead Programmer and Coordinator

    Joined:
    Dec 7, 2002
    Messages:
    3,146
    Likes Received:
    9
    Trophy Points:
    48
  13. ArconX

    ArconX New Member

    Joined:
    Mar 11, 2003
    Messages:
    23
    Likes Received:
    0
    Trophy Points:
    0
    Tested on a Audigy 2 with 3534 (no e version, just reinstalled my system).


    RightMark 3D:


    Well, i just tried RightMark 3D Loop ( DirectSound Hardware - 0/1 output ), and i noticed that the front sound is in reality the back sound & visa versa. Normal sound works right but Hardware Accelerated Sound isent swamped like it needs to. I also noticed that sound stops after playback for about a min or so ...

    DirectSound Software - 0/1: works.

    DirectSound + EAX2 - 0/1: works but same problem as Direct Sound Hardware.

    DirectSound Hardware - 4/5 - 6/7 - 8/9 output: No Hardware Support



    Play3DSound:


    Xp Notify Wave played. Same problem. Front & Back are swamped.


    Bf1942 Testing:

    Same as before. The tools make it look like it works perfect, but in the game it's a totaly differend ballgame ... i think you will need to d/l the game & test them, sinds the tool don't show anything :(

    ----------------------------------------------------
    kX Audio Driver, kX Mixer (Debug)
    Copyright © Eugene Gavrilov, 2001-2003.
    All Rights Reserved
    Version: 5, 10, 00, 3534 - debug
    Compiled: Aug 2 2003 22:10:32
    ----------------------------------------------------
    Current skin: Aqua Skin
    Skin Author: Eugene Gavrilov
    ----Hardware / Software configuration---------------
    Driver Name:kX Audio Driver (Debug)
    Driver Date: Aug 2 2003 22:07:58
    Driver Version: 5.10.00.3534 - debug
    DB Name:none
    SB0240 10k2 [c800]
    PCI Information:
    Device: 41102 Subsys: 10021102 ChipRev: 4
    Card is '10k2'
    Card has MPU device
    Card model is '5.1'
    Card is Audigy2-compatible
    Card HAS AC97 codec
    Codec name: SigmaTel STAC9721/23
    3D Extension: SigmaTel 3D Enhancement
    Codec is 2.0 compliant
    Capabilities[6940] :
    DAC resolutions : -16-bit- -18-bit-
    ADC resolutions : -16-bit- -18-bit-
    Ext Capabilities [200]: -slot/DAC mappings-
    Port: c800 Irq: 6
    Playback buffer: 20a0
    Record buffer: 4000
    Number of AC3 buffers: 4
    Tank memory: 256 kb
    GSIF buffer: 256 samples
    OS version: [2 5 1 Service Pack 1; 2 5 1 Service Pack 1; 156 148]
    ----------------------------------------------------
     
    Last edited: Aug 16, 2003
  14. inteks

    inteks New Member

    Joined:
    Nov 28, 2002
    Messages:
    90
    Likes Received:
    0
    Trophy Points:
    0
    i can burn and send you the demos by post if you like. pm me.

    /tom
     
  15. RIV@NVX

    RIV@NVX Freedom is a feature.

    Joined:
    Jul 10, 2002
    Messages:
    4,476
    Likes Received:
    2
    Trophy Points:
    0
    I have tested it using Diablo II. It works quite good actually :)
    This is what the game reports:
    16:06:59.078 Initializing sound engine...
    16:06:59.625 Driver: kX Wave SB0240o 10k2 [e400] 0/1
    16:06:59.625 Module: kx.sys
    16:06:59.640 DirectSound3D with EAX 2 initialized
    16:06:59.640 Hardware 3D buffers: 64
    16:06:59.640
    ----------------------------------------------

    ----Hardware / Software configuration---------------
    Ime Drivera:kX Audio Driver (Debug)
    Datum Drivera: Aug 10 2003 01:53:43
    Verzija Drivera: 5.10.00.3534 - debug
    Ime DB-a:none
    SB0240o 10k2 [e400]
    PCI Information:
    Device: 41102 Subsys: 10071102 ChipRev: 4
    Kartica je '10k2'
    Card has MPU device
    Model kartice je '5.1'
    Card is Audigy2-compatible
    Card HAS AC97 codec
    Codec name: SigmaTel STAC9721/23
    3D Extension: SigmaTel 3D Enhancement
    Codec is 2.0 compliant
    Capabilities[6940] :
    DAC resolutions : -16-bit- -18-bit-
    ADC resolutions : -16-bit- -18-bit-
    Ext Capabilities [200]: -slot/DAC mappings-
    Port: e400 Irq: a
    Playback buffer: 20a0
    Record buffer: 4000
    Number of AC3 buffers: 4
    Tank memory: 256 kb
    GSIF buffer: 256 samples
    OS version: [2 5 2 ; 2 5 2 ; 156 148]
    ----------------------------------------------------
     
  16. Blento

    Blento New Member

    Joined:
    Feb 28, 2003
    Messages:
    53
    Likes Received:
    0
    Trophy Points:
    0
    Audigy 1 problems

    Hi...I got myself an new computer, and i installed WIN XP and new 34 KX drivers....but then i got problems..

    In some programs midi SYNTH A & B..and sound fonts just doesnt work..and in some games i got really shity sound...most of the times i dont have any sound...?...why's that....it used to work very well?

    Blento
     
  17. Hellknight[FA]

    Hellknight[FA] New Member

    Joined:
    Jun 24, 2003
    Messages:
    12
    Likes Received:
    0
    Trophy Points:
    0
    Download doesn't work for me
    :(
     
  18. Eugene Gavrilov

    Eugene Gavrilov kX Project Lead Programmer and Coordinator

    Joined:
    Dec 7, 2002
    Messages:
    3,146
    Likes Received:
    9
    Trophy Points:
    48
    this is an outdated download
    use 3534f instead (the url can be found on our official site)

    /E
     
  19. Hellknight[FA]

    Hellknight[FA] New Member

    Joined:
    Jun 24, 2003
    Messages:
    12
    Likes Received:
    0
    Trophy Points:
    0
    Thx alot man, tried it and wondered that 3DMark03 now shows "Max Supported 3D Hardware Sounds 64" instead of 32.

    How is this possible? And in many games I can choose now "EAX 3". I thought these drivers were meant to make music? But this stuff seems to outperform the creative driver in nearly every situation.


    My thoughts as 1st time kx-project-user :D:

    + very nice playback-quality of midi-files (I use the 8MB one from creative :) ), better than with the hacked audigy 2 drivers or the standard sblive drivers (one year old :D).
    + Superb DVD-Playback on nvdvd 2.55 with subwoofer enabled - the orginal creative-drivers gave me some terrible probs (awful sound) when i stopped playback or exited the player.
    + Extended options like EAX3 in many games (GTA VC, Gothic 2 + Addon, Neverwinter Nights + Addon...)
    + Solved problems in diablo 2 with 3D-Sound (with hacked drivers the sound was awful)
    + now 64 hardware accelerated 3D Sounds (but only if it is not a bug ;) )
    + mighty kx-Mixer :drool: whose options are very impressive (at least I think so, coz i am an absolute n00b with professional drivers :D)
    + support for the LiveDrive 2 - IR :)


    - some slight probs in games with 3D-Sound enabled (but this is obvious, coz these drivers are meant to make music ;) )
    - the kx-mixer eats up 13 MB !!!


    OK - these were my first thoughts - keep on working on this awesome stuff so that creative let you manage the progamming of their drivers ....


    Greetings and Grats for this stuff


    Timo
     
  20. Eugene Gavrilov

    Eugene Gavrilov kX Project Lead Programmer and Coordinator

    Joined:
    Dec 7, 2002
    Messages:
    3,146
    Likes Received:
    9
    Trophy Points:
    48
    :)

    yes, kX Driver currently supports 64 hardware-accelerated voices
    (however, as soon as our DirectSound 3D support becomes more sophisticated, the number of voices might be cut)

    although the driver reports it is EAX2 and EAX3-capable, there's no actual EAX support at the moment -- we are working on it

    and, finally -- 13Mb issue :)
    have you ever tried to measure how much memory does the original software require? including 'cthelper.exe' and the other stuff -- it seems to be much more than 13Mb :)

    anyway, thanks for your message -- new releases are out quite often -- stay tuned! :cool:

    /E
     

Share This Page

visited