3535b and reinit dsp assertion failed

Discussion in 'Bug Reports' started by HumanRes, Sep 29, 2003.

  1. HumanRes

    HumanRes New Member

    Joined:
    Mar 6, 2003
    Messages:
    26
    Likes Received:
    0
    Trophy Points:
    0
    after installing 3535b over 3535, i called "Clear DSP" and then "Reinitialize DSP" in the DSP window-

    I got following error, after which the mixer shuts down completely:

    DEBUG ASSERTION FAILED
    Program: C:\WINDOWS\system32\kxmixer.exe
    File: f:\.projects\emu10k1\.my\kxmixer\kxcode.cpp
    Line: 180

    After reinstalling 3535, the DSP was almost clear, a reinit dsp-command restored the normal settings.

    I then tried to install 3535b again, but the same happend again (even if i did not explicitely called "Clear DSP"). So I'm back to 3535 again.

    What else can I do?

    ----Hardware / Software configuration---------------
    Driver Name:kX Audio Driver (Debug)
    Driver Date: Sep 14 2003 20:55:22
    Driver Version: 5.10.00.3535 - debug
    DB Name:non
    CT4832 10k1 [d400]
    PCI Information:
    Device: 21102 Subsys: 80271102 ChipRev: 8
    Card has MPU device
    Card HAS AC97 codec
    Codec name: Unknown AC97 codec [43525914
    3D Extension: Crystal Semi 3D Stereo Enhancement
    Codec is 2.0 compliant
    Capabilities[1990] : -headphone out-
    DAC resolutions : -16-bit- -20-bit-
    ADC resolutions : -16-bit- -18-bit-
    Ext Capabilities [200]: -slot/DAC mappings-
    Port: d400 Irq: 11
    Playback buffer: 20a0
    Record buffer: 4000
    Number of AC3 buffers: 4
    Tank memory: 256 kb
    GSIF buffer: 256 samples
    OS version: [2 5 1 Service Pack 1; 2 5 1 Service Pack 1; 156 148]
    ----------------------------------------------------
     
  2. Eugene Gavrilov

    Eugene Gavrilov kX Project Lead Programmer and Coordinator

    Joined:
    Dec 7, 2002
    Messages:
    3,146
    Likes Received:
    9
    Trophy Points:
    48
    >> after installing 3535b over 3535

    have you noticed my warning concerning installation of 3535b over 3535? :)
    you -should- reset your settings (global ones)
    and, preferrably, reset per-card settings, too

    the bug happens because 353b uses different prolog/epilog with different GUIDs
    you can try solving the bug by re-registering kxfxlib.kxl (right click on it when you have kX Mixer running)

    /Eugene
     
  3. HumanRes

    HumanRes New Member

    Joined:
    Mar 6, 2003
    Messages:
    26
    Likes Received:
    0
    Trophy Points:
    0
    ok I misunderstood the reset-thing, i now resetted global settings instead of dsp and it worked. Thnx;)
     

Share This Page

visited