3548 released - BETA - x86 and x64 builds

Discussion in 'General Discussion' started by Eugene Gavrilov, Jul 28, 2009.

  1. Eugene Gavrilov

    Eugene Gavrilov kX Project Lead Programmer and Coordinator

    Joined:
    Dec 7, 2002
    Messages:
    3,146
    Likes Received:
    9
    Trophy Points:
    48
    hi there :)

    3548 is out
    There are two versions: x86 and x64. Please only install the one which fits for your OS.

    Changes:
    * Fixed a bug with power management (ASIO channels were not restored properly after sleep/hibernation)
    * Fixed a bug 'Master Mixer unusable" on 10k1 cards under Vista/Windows7
    * Fixed support for multiple E-DSP cards
    * Fixed a compatibility issue with Windows 7

    SDK:
    * Certain parts of kX API and kX Mixer plugin management released open source (GPL)
    * Included Mac OS X-compatible SDK with full source code for kxapi.a
    (the kxapi.a binary to be included with the OS X driver)

    Bug reports:
    Please use two different threads for reporting bugs.
    x86 version: here
    x64 version: here

    Download links:

    x86 version (Windows XP, Windows Vista, Windows 7): kxdrv3548-x86-full.exe
    x64 version (Windows XP, Windows Vista, Windows 7): kxdrv3548-x64-full.exe

    You can read current project status here.

    As always, your input is welcome and highly appreciated :)
    Don't forget that we accept donations via centrance website.

    E.

    LEGACY:
    previous x86 build: here - version 3545b
    previous x64 build: here - version 3547
     
  2. RPGWiZaRD

    RPGWiZaRD New Member

    Joined:
    Dec 29, 2007
    Messages:
    132
    Likes Received:
    1
    Trophy Points:
    0
    * Fixed a compatibility issue with Windows 7 <-- Care to explain exactly which issue? Perhaps the kxmixer.exe not loading by default unless you ran in Vista comp. mode?

    Anyway thanks once again for your awesome work! I bet 5.1 users will like this one with Master Mixer hopefully working now. :)

    I would install it right away but I'm a bit busy, will try later or tomorrow, just had to show my appriciation.
     
  3. Eugene Gavrilov

    Eugene Gavrilov kX Project Lead Programmer and Coordinator

    Joined:
    Dec 7, 2002
    Messages:
    3,146
    Likes Received:
    9
    Trophy Points:
    48
    Îòâåò: 3548 released - BETA - x86 and x64 builds

    win7: yes, you no longer need to run it in vista compatibility mode

    E.
     
  4. Russ

    Russ Well-Known Member

    Joined:
    Jan 17, 2005
    Messages:
    5,722
    Likes Received:
    13
    Trophy Points:
    48
    Thanks E.

    Just installed 3548 x86, so I have not done much testing as of yet, but no problems so far (WinXP).

    ---
    3rd party plugins (kxl) and addons (kxa) from previous (x86) SDK versions are not compatible with 3548 x86 (including UFX and ProFX).
     
    Last edited: Aug 4, 2009
  5. imperia

    imperia Active Member

    Joined:
    Dec 17, 2002
    Messages:
    200
    Likes Received:
    0
    Trophy Points:
    26
    Windows 7 Compatibility - Very nice. Thanks E.
     
  6. mr_duke

    mr_duke New Member

    Joined:
    Jul 29, 2009
    Messages:
    8
    Likes Received:
    0
    Trophy Points:
    0
    Îòâåò: 3548 released - BETA - x86 and x64 builds

    Thanks Eugene!

    BTW, does the new driver address the issue with >2G RAM?
     
  7. c0nstantine

    c0nstantine New Member

    Joined:
    Jul 29, 2009
    Messages:
    7
    Likes Received:
    0
    Trophy Points:
    0
    yes, what about ">4Gb RAM" bug!? =)
     
  8. gooday

    gooday New Member

    Joined:
    Feb 18, 2003
    Messages:
    89
    Likes Received:
    0
    Trophy Points:
    0
    OK, I'll try it right away. Win 7 compliable is not so hard I think, cos the driver architecture is very much like the Vista. I'm using 3539 and hack the startup kxmixer.exe in reg, just worked pretty good.
     
  9. The_neo

    The_neo New Member

    Joined:
    Jan 9, 2004
    Messages:
    93
    Likes Received:
    0
    Trophy Points:
    0
    unable to install KX on win xp sp3 build 3264
     
  10. Russ

    Russ Well-Known Member

    Joined:
    Jan 17, 2005
    Messages:
    5,722
    Likes Received:
    13
    Trophy Points:
    48
    Are you sure that it was the x86 version of 3548 that you tried to install?
     
  11. MegaByte

    MegaByte New Member

    Joined:
    May 25, 2007
    Messages:
    25
    Likes Received:
    0
    Trophy Points:
    0
    Congratulations! Now sound is as clear as it was in windows xp x64. However, the sampling rate in my emu10k1 still cannot be selected. It's set to 48hkz default and cannot be changed.

    Furthermore, sound redirection seems to have no effect.
     
  12. The_neo

    The_neo New Member

    Joined:
    Jan 9, 2004
    Messages:
    93
    Likes Received:
    0
    Trophy Points:
    0


    yes,Russ.... here my hardware specs..

    Driver Name:kX Audio Driver (Debug)
    Driver Date: Jul 28 2009 23:49:24
    Driver Version: 5.10.00.3548 - debug
    DB Name:none
    kX Generic [ffe0]:confused::confused::confused:
    PCI Information:
    Device: 21102 Subsys: 80601102 ChipRev: ff
    Card HAS AC97 codec
    Codec name: Unk AC97-codec [ffffffff]
    3D Extension: Reserved (31)
    Codec is 2.0 compliant
    Capabilities[ffff] : -dedicated MIC PCM IN channel- -reserved1- -bass & treble- -simulated stereo- -headphone out- -loudness-
    DAC resolutions : -16-bit- -18-bit- -20-bit-
    ADC resolutions : -16-bit- -18-bit- -20-bit-
    Ext Capabilities [ffff]: -var rate PCM audio- -2x PCM audio out- -var rate MIC in- -PCM center DAC- -PCM surround DAC- -PCM LFE DAC- -slot/DAC mappings-
    Port: ffe0 Irq: 0x8(8)
    Playback buffer: 20a0
    Record buffer: 4000
    Number of AC3 buffers: 4
    Tank memory: 256 kb
    GSIF buffer: 256 samples
    OS version: [2 5 1 Service Pack 3, v.3264; 2 5 1 Service Pack 3, v.3264; 156 148]



    AMD 64 X2 6000+ ,SBLIVE 5.1 model 100
     
  13. Russ

    Russ Well-Known Member

    Joined:
    Jan 17, 2005
    Messages:
    5,722
    Likes Received:
    13
    Trophy Points:
    48
    Ahh, OK, when you said it was unable to install, I assumed that you meant that it wouldn't run, or gave you an error or something... not that it installed but did not detect your card model correctly...

    I think the problem is with the subsystem ID. It seems that kX does not recognize it... Is it an OEM model? Does it not work?
     
  14. c0nstantine

    c0nstantine New Member

    Joined:
    Jul 29, 2009
    Messages:
    7
    Likes Received:
    0
    Trophy Points:
    0
    Russ, will my SB live! 5.1 SB0220 normally work on win7 x64, if I have 4Gb RAM?
     
  15. The_neo

    The_neo New Member

    Joined:
    Jan 9, 2004
    Messages:
    93
    Likes Received:
    0
    Trophy Points:
    0

    No oem model....earlier it worked ......but, after installing post sp3 updates ,it is not recognising the card....even original creative didnot install...:oops:
     
  16. Russ

    Russ Well-Known Member

    Joined:
    Jan 17, 2005
    Messages:
    5,722
    Likes Received:
    13
    Trophy Points:
    48
    The card is OK, but I think the RAM is going to be a problem (but you may get lucky, some people do (if windows creates the buffers below 2 GB, then it will work, but even so, it may only be temporary)).
     
    Last edited: Jul 30, 2009
  17. Russ

    Russ Well-Known Member

    Joined:
    Jan 17, 2005
    Messages:
    5,722
    Likes Received:
    13
    Trophy Points:
    48
    It sounds like something happened to the EEPROM. (I think the subsystem ID for SB0100 is 80621102, so yours seems to be off by 1 number). Even so, I think kX should work OK.
     
  18. The_neo

    The_neo New Member

    Joined:
    Jan 9, 2004
    Messages:
    93
    Likes Received:
    0
    Trophy Points:
    0


    any quick solution???
     
  19. Russ

    Russ Well-Known Member

    Joined:
    Jan 17, 2005
    Messages:
    5,722
    Likes Received:
    13
    Trophy Points:
    48
    Well, you could try re-seating the card in the PCI slot (maybe it is just not seated right (i.e. maybe it came loose when connecting a cable, etc)). Beyond that there is no quick fix that I know of.
     
  20. The_neo

    The_neo New Member

    Joined:
    Jan 9, 2004
    Messages:
    93
    Likes Received:
    0
    Trophy Points:
    0



    thank you...let me try:)
     

Share This Page

visited