3550 Vista x64 - Kx Mixer Options Empty (Bug)

Discussion in 'Bug Reports' started by SeraphicGate, Sep 30, 2009.

  1. SeraphicGate

    SeraphicGate New Member

    Joined:
    Apr 5, 2009
    Messages:
    68
    Likes Received:
    0
    Trophy Points:
    0
    Hi. I found what appears to be a bug with these new drivers on Windows Vista x64 (4GB Memory). The Kx Mixer page only has off options (no on) and the other drop down boxes are empty. I am looking to be able to do direct recording, but it does not seem to be able to be turned on, since the only options are off.

    Also, to get any audio playback at all I had to switch from the default Wave Out HQ to Master Mixer in Vista sound configuration.

    http://img193.imageshack.us/img193/9771/28469352.jpg
     
    Last edited: Sep 30, 2009
  2. Russ

    Russ Well-Known Member

    Joined:
    Jan 17, 2005
    Messages:
    5,722
    Likes Received:
    13
    Trophy Points:
    48
    I do not know if it will work for you, but you can try enabling Direct SPDIF Recording using kX Console:

    shw 12 x

    Where 'x' is:
    0: OFF
    1: SPDIFA
    2: SPDIFB
    3: SPDIFC
    4: i2sa
    5: i2sb
    6: i2sc

    e.g.
    To enable Direct SPDIF Recording from Coaxial (with my card):
    shw 12 2
     
    Last edited: Oct 1, 2009
  3. krylko

    krylko New Member

    Joined:
    Jul 25, 2006
    Messages:
    17
    Likes Received:
    0
    Trophy Points:
    0
    I have the same problem (bug) in kX Mixer under Windows 7 x64 RC as the original poster. I have tried SHW 12 2 (and all other options) in kX Console but I get 'Invalid Command'. I have SB0350 (Audigy 2 ZS Gold) I wonder if other x64 users have the same problem.
     
  4. Russ

    Russ Well-Known Member

    Joined:
    Jan 17, 2005
    Messages:
    5,722
    Likes Received:
    13
    Trophy Points:
    48
    Oops, sorry (I posted it wrong... will correct it)... It is case sensitive... It should be 'shw 12 2'.
    Let us know if that works.
     
  5. SeraphicGate

    SeraphicGate New Member

    Joined:
    Apr 5, 2009
    Messages:
    68
    Likes Received:
    0
    Trophy Points:
    0
    Problem is I have the creative driver pack installed, would have to format and reinstall kx drivers to try this. However, don't really have much an idea as to how to do what you suggested Russ. Even so, how do you set it to 48khz or to enable direct recording? Isn't what you suggested just to select the input device?
     
  6. Russ

    Russ Well-Known Member

    Joined:
    Jan 17, 2005
    Messages:
    5,722
    Likes Received:
    13
    Trophy Points:
    48
    It is easy... Right/Secondary click on any blank spot in kxmixer (to get the context menu) and choose kX Console from the menu. Type in the command and press enter.

    Selecting the input device for direct recording is what enables direct recording.

    As for the frequency, that can be done in kX Console as well, but that is for output, not input (input frequency is set in your recording application).

    Again, I do not know if it is going to work or not (it depends on if the bug is just with the GUI)... I do not even know if it is currently supported in Windows 7/Vista... so maybe just wait and see if someone else tries it and posts their results.
     
    Last edited: Oct 1, 2009
  7. SeraphicGate

    SeraphicGate New Member

    Joined:
    Apr 5, 2009
    Messages:
    68
    Likes Received:
    0
    Trophy Points:
    0
    Sounds like krylko has somewhat the same card as me (I have Pro Model 'card + case bay'). Seems like they know what they are doing with your suggesting too, so I hope they can reply.
     
  8. SeraphicGate

    SeraphicGate New Member

    Joined:
    Apr 5, 2009
    Messages:
    68
    Likes Received:
    0
    Trophy Points:
    0
    So did anyone else duplicate this or is it just a problem on my system?
     
  9. =MO=MaTriX

    =MO=MaTriX New Member

    Joined:
    Sep 1, 2004
    Messages:
    6
    Likes Received:
    0
    Trophy Points:
    0
    hello everyone

    ive posted in another thread already that ive got the same problem here.
    my system is windows 7 64bit pro with 8gb ram.

    today i tested the creative drivers just for fun and it seems that these drivers also dont support spdif out in 64bit. ive found some documentations that spdif passthru only works under 32bit systems.

    with creative drivers i also could not activate the digital output so these creative drivers are crap ^^

    now i use kx drivers back again and i hope someone can fix the problem with the spdif in the drivers.

    Flo

    ps: is there a command to activate ac3 passthru and route it to spdif 0 in the console?
     
  10. BK-Morpheus

    BK-Morpheus New Member

    Joined:
    Oct 24, 2009
    Messages:
    5
    Likes Received:
    0
    Trophy Points:
    0
    AW: Re: 3550 Vista x64 - Kx Mixer Options Empty (Bug)

    You can set the passthru in your kX konsole.
    http://www.driverheaven.net/bug-reports/191372-no-ac3-outpul-spdif-kx3550.html#post1306298

    I got the same problem...i can not put ac3 over SPDIF with kX Drivers, but i also tried the Creative Drivers and i was able to hear ac3 sourrund sound over SPDIF (i'm using Win7 64bit).
     

Share This Page

visited