7.5 Catalyst drivers out for Vista discuss and vote here

Discussion in 'AMD Graphics Cards' started by CATALYST maker, May 31, 2007.

?

Please rate the 7.5 Vista drivers

  1. 10 - these drivers kick more ass than a gang of octopii wearing boots at an ass kicking convention

    3 vote(s)
    9.4%
  2. 9

    0 vote(s)
    0.0%
  3. 8

    5 vote(s)
    15.6%
  4. 7

    1 vote(s)
    3.1%
  5. 6

    4 vote(s)
    12.5%
  6. 5

    3 vote(s)
    9.4%
  7. 4

    0 vote(s)
    0.0%
  8. 3

    2 vote(s)
    6.3%
  9. 2

    4 vote(s)
    12.5%
  10. 10 - Oh dear back to the drawing board please, these drivers should be locked up with Paris Hilton

    10 vote(s)
    31.3%
  1. CATALYST maker

    CATALYST maker ATI driver guru

    Joined:
    Nov 4, 2002
    Messages:
    678
    Likes Received:
    8
    Trophy Points:
    0
    go get em now and let us know what you think
     
  2. digitalwanderer

    digitalwanderer Colour Commentator

    Joined:
    May 8, 2002
    Messages:
    5,619
    Likes Received:
    2
    Trophy Points:
    0
    For the very first time, I think your servers are too slow! :p

    Thanks Terry. :)

    EDITED BITS: If you have trouble getting the all-in-one driver package, you can grab the components seperately quickly here.
     
  3. Spyre

    Spyre New Member

    Joined:
    Mar 3, 2003
    Messages:
    240
    Likes Received:
    1
    Trophy Points:
    0
    New Features

    This release of Catalyst™ introduces the following new features:

    * DirectX 10 driver support for the Radeon™ HD 2900 XT (single card and CrossFire™ configurations) for Windows Vista
    * Second Generation ATI Theater™ 650

    DirectX 10 driver support for the Radeon™ HD 2900 XT (single card and CrossFire™ configurations) for Windows Vista


    This release of Catalyst™ introduces the ATI DirectX 10 driver for the Radeon™ HD 2900 XT, for both single cards and CrossFire™ configurations. The ATI DirectX 10 driver used in combination with the Radeon™ HD 2900 XT (and an application designed to take advantage of the power of the DirectX 10 API) delivers incredible graphics effects never seen before on the PC.

    Second Generation ATI Theater™ 650

    This release of Catalyst™ introduces the second generation ATI Theater™ 650. This product will provide support for the new MCE 2006 requirements such as DRM support. Further, it will include features to support ATI All-In-Wonder products. It will also provide improved TV quality and Broadcast Flag support which enables full US terrestrial DTV support.

    Performance Improvements

    OpenGL performance is improved on the ATI Radeon™ X1950 XTX at high resolutions (1920x1200 or greater) with anti-aliasing and anisotropic filtering enabled. Doom 3 and Quake 4 improves as much as 13-18%, and Prey improves at least 15.6%. The ATI Radeon™ X1950 Pro and X1650 XT also sees improvements in Doom 3 and Quake 4 of up to 14.1% at higher resolutions with anti-aliasing and anisotropic filtering enabled.

    Resolved Issues for the Windows Vista Operating System

    This section provides information on resolved issues in this release of the ATI Catalyst™ Software Suite for Windows Vista. These include:

    • Doom3/Quake 4: Setting the in game options for Video Quality to Medium and Screen Size to 1024x768 no longer results in display corruption being noticed when setting AA to 4x. Further details can be found in topic number 737-25802
    • IL2 Sturmovik->Forgotten Battles: Setting the in-game hardware options to custom and landscape detail to perfect no longer results in the water textures appearing corrupt when playing the game under the Windows Vista operating system. Further details can be found in topic number 737-26687
    • Lego Star Wars II: Starting a new game and walking outside through any of the doors available no longer results in flickering/flashing being noticed during the fade transition. Further details can be found in topic number 737-27454
    • Quake 4/Serious Sam: Attempting to launch the games with AA set to 2x or higher and the Catalyst™ Control Center->Advanced View->3D preview running in the background no longer results in the operating system failing to respond. Further details can be found in topic number 737-26690
    • A Fatal Uninstall Error of ATI Catalyst™ Install Manager is no longer experienced on some hardware configurations running Vista. Further details can be found in topic number 737-27083
    • Catalyst™ Control Center: The Content Viewing selection for Component Video is no longer blank in the Basic view when using only an HDMI display device. Further details can be found in topic number 737-27084
    • CrossFire™: The text and buttons found in the CrossFire™ disable warning message are no longer cropped in all supported languages excluding English. Further details can be found in topic number 737-27085
    • Switching between users with Catalyst™ Control Center->Color aspect open, no longer incorrectly enables the Reactivate ATI Color controls button on some hardware configurations. Further details can be found in topic number 737-27086
    • In the Catalyst™ Control Center, a blank page is no longer seen in the basic view when changing extended desktop to clone mode with CRT and SDTV connected on some ASIC families. Further details can be found in topic number 737-27088
    • In the Catalyst™ Control Center the localization "Select a Skin" window page is now localized with the appropriate languages on some hardware configurations. Further details can be found in topic number 737-27087
    • Enabling CrossFire™ no longer automatically enables 'Triple Buffering' and disables 'Support DXT texture format' in 3D->More Settings. Further details can be found in topic number 737-27090
    • The position of the TV as reported by the Catalyst™ Control Centre when switching from underscan to overscan no longer differs between the operating systems Windows XP and Windows Vista. Further details can be found in topic number 737-27079
    • Mode changes including extending the desktop is no longer observed to be extremely slow with two monitors attached and enabled on the ATI Radeon™ X1800 series of products. Further details can be found in topic number 737-27080
    • Overlay Theater Mode no longer fails under the conditions that the desktop is extended to a secondary display on ATI Radeon™ X1300/X1550 series of products. Further details can be found in topic number 737-27082
    • On some hardware configurations the Catalyst™ Control Center "Content Viewing selection for Component Video" page is no longer blank in the Basic view when using only an HDMI display device. Further details can be found in topic number 737-27452
    • Switching between users with Catalyst™ Control Center->Color aspect open, no longer incorrectly enables the "Reactivate ATI Color controls" button on some hardware configurations. Further details can be found in topic number 737-27086
    • An error message is no longer displayed when disabling CrossFire™ under the Windows Vista operating system. Further details can be found in topic number 737-27453
    • Catalyst™ Control Center: Attempting to change the Core clock settings within the Overdrive™ aspect no longer results in the new setting failing to be applied. Further details can be found in topic number 737-27455
    • WinDVD8: Enabling hardware acceleration no longer results in corruption being noticed during video playback. Further details can be found in topic number 737-27616
    • Using Windows Media Player 11 to play an MPEG file using HDMI audio on a system running Windows Vista no longer results in file not playing properly if swapping the primary and secondary display devices. Further details can be found in topic number 737-27617
    • Mode changes including extending the desktop is no longer observed to be extremely slow with two monitors attached and enabled on the ATI Radeon™ X1800 series of products. Further details can be found in topic number 737-27456
    • Playing HD DVD content followed by attempting to hot unplug a display device and then hot-plugging the same display device to a different port no longer results in the HD DVD playback failing to resume. Further details can be found in topic number 737-27618

    Known Issues Under the Windows Vista Operating System


    • This section provides information on known issues associated with the ATI Catalyst™ Vista RTM driver for both the 32bit and 64bit versions of the Microsoft Windows Vista operating system. These include:
    • Homeworld2: Setting the game options to default and starting a single player game may result in display corruption being noticed. Further details can be found in topic number 737-26692
    • Never Winter Nights->Undrentide: Enter the Advanced Video Options within the game may result in the inability to enable the Shiny Water option. Further details can be found in topic number 737-27462
    • NHL 07: The in-game display settings may fail to be applied when playing the game under the Windows Vista operating system when using a supported ATI Radeon™ product. Further details can be found in topic number 737-23549
    • X-Plane: Playing the game under the Windows Vista operating system may result in display corruption being noticed when using an ATI Radeon™ X1900/1950 series of product. Further details can be found in topic number 737-25522
    • In the Catalyst™ Control Center, the Help buttons drop down box appear towards left side of the window instead of right side for some languages on certain hardware configurations. Further details can be found in topic number 737-27089
    • Playing a DVD under the Windows Vista operating system using the Windows Media Player may result in the DVD failing to play when switching between display devices using the hot-key function. Further details can be found in topic number 737-24472. Fixed in 8.39
    • Resuming from an S3 state may result in a longer than expected time for the Windows Vista operating system to resume. Further details can be found in topic number 737-25798
    • Hot-plugging a CRT to a system running Windows Vista and containing an ATI Radeon™ X1100/1150 series of product may result in extended desktop mode failing to be applied. Further details can be found in topic number 737-25801
    • The desktop shortcut to the Catalyst™ Control Center may disappear after performing a Windows Anytime Upgrade on some hardware configurations running Vista. Further details can be found in topic number 737-27078
    • On some hardware configurations the CIM video driver installer lists The Catalyst™ Install Manager and Microsoft Visual C++ among components of the Component Selection Menu whereas these should not appear since they are mandatory and not optional. Further details can be found in topic number 737-27081
    • Enabling CrossFire™ followed by disconnecting and then reconnecting the CRT display device may result in duplicate video options being seen within the Catalyst™ Control Center. Further details can be found in topic number 737-27457
    • Catalyst™ Control Center->OverDrive™: The OverDrive™ setting are not retained for individual accounts. This issue may also be experienced under the Windows Vista operating system. Further details can be found in topic number 737-25805
    • The OverDrive™ clocks may fail to revert back to the default settings and the Apply and Discard buttons may not become enabled when changing the clock settings for both the primary and secondary display devices. Further details can be found in topic number 737-27619
    • Enabling CrossFire™ followed by setting AA to 14x and AF to 16x may result in the AA showing a setting of 0x level when disabling CrossFire™ and unchecking the AA option in the 3D aspect. Further details can be found in topic number 737-27458
    • Making changes to the Color aspect found in the Catalyst™ Control Center without applying the changes may result in the Reactivate ATI color controls button remaining active after the Catalyst™ Control Center is closed and then re-launched. Further details can be found in topic number 737-27459
    • The Record function currently fails to work when using an ATI All-In-Wonder X1300 and time shifting is enabled. Further information can be found in topic number 737-22014
    • A blank screen may be displayed after unchecking all the Component Video formats except when the 480i30 custom mode is applied. Further details can be found in topic number 737-27620
    • Enabling CrossFire™ followed by setting the Overdrive™ clocks to their maximum settings may result in the Catalyst™ Control Center failing to accurately report the requested Overdrive™ values. Further details can be found in topic number 737-27621
    • Connecting a secondary display device and enabling extended desktop mode may result in changes being made to the secondary display device being reflected on the primary display device. Further details can be found in topic number 737-27460
    • After installing the ATI display driver and Catalyst™ Control Center the display driver may not be listed in the installed components. Further details can be found in topic number 737-27461
    • The desktop shortcut to the Catalyst™ Control Center may disappear after performing a Windows Anytime Upgrade on some hardware configurations running Vista. Further details can be found in topic number 737-27078
    • A green or black screen may be displayed when configuring MCE to ATSC mode. Further details can be found in topic number 737-27622
    • Playing a DVD using either WinDVD or PowerDVD may result in corruption being noticed if the players is rotated to any position other than landscape. Further details can be found in topic number 737-27463
    • Setting the Avivo Video De-interlacing setting to auto, motion adaptive or vector adaptive may result in certain DVDs, menu videos and some special features failing to benefit from the options. Further details can be found in topic number 737-27196
    • Installing the display driver under the Windows Vista operating system may result in the display resolutions of 1680x1050, 1800x1440, 1920x1080 and 1920x1200 not being available when using an analog CRT display device. Further details can be found in topic number 737-27464
    • Running through the un-install of the ATI display driver may result in the display driver failing to be completely removed. Further details can be found in topic number 737-27466
     
  4. Teme

    Teme Super Moderator

    Joined:
    Dec 22, 2004
    Messages:
    8,496
    Likes Received:
    175
    Trophy Points:
    73
    I think not. I got drives and AVIVO pack in 10 mins in total with my 2048/512 line ;) I just was fast to avoid the rush :D
     
  5. Buddahpest

    Buddahpest Active Member

    Joined:
    Jul 1, 2002
    Messages:
    218
    Likes Received:
    0
    Trophy Points:
    26
    This is a little weird.

    I did an upgrade install of the 7.5's from the 7.4's under Vista Ultimate X64. During the process, I received a message from the installer saying that no driver was detected and that installation could not continue.

    However, the install kept going and then I was prompted to reboot. Upon reboot, everything installed properly and the CCC shows version 7.5. The date on the drivers also changed to the 17th of May.
     
  6. purush

    purush New Member

    Joined:
    Jun 29, 2002
    Messages:
    97
    Likes Received:
    1
    Trophy Points:
    0
    7.5 drivers

    In one word 'Superb' contrary to all the negative reviews I heard about ATI 2900XT I intend to go ahead and buy it. I just returned Nvidia 8800GXT after taking a 20% reduction. I had nothing but troubles configuring their control panel. It would not recognize my 1080p resolution in my Sharp 37 " LCD TV, somehow could not get the image to fill the screen, it would cut off the right hand portion of the screen, I even changed my PSU to 750 Watts. I spent three days trying to figure out. No matter what everyone is grumbling I much prefer ATI products and all the three computers in the house have ATI cards.
     
  7. MechaMorph

    MechaMorph New Member

    Joined:
    Mar 30, 2007
    Messages:
    5
    Likes Received:
    0
    Trophy Points:
    0
    I have an issue with my CCC. After installing 7.5 CCC keeps crashing. I get the following information:

    Description:
    Stopped working

    Problem signature:
    Problem Event Name: CLR20r3
    Problem Signature 01: ccc.exe
    Problem Signature 02: 2.0.0.0
    Problem Signature 03: 451d264f
    Problem Signature 04: CLI.Component.Runtime
    Problem Signature 05: 2.0.2693.36852
    Problem Signature 06: 464d0138
    Problem Signature 07: cb
    Problem Signature 08: 6
    Problem Signature 09: System.NullReferenceException
    OS Version: 6.0.6000.2.0.0.256.1
    Locale ID: 1033

    Restarting does not correct the problem. It just crashes again almost immediately.

    This is a Crossfired X1950 Pro system on a Xpress 3200 chipset with an AMD X2 4200+ running Vista Ultimate.

    -MM

    EDIT: After a reboot ATT was allowing to enable Crossfire again. CCC still crashing though. Drivers seem stable so far.

    EDIT 2: Weirdest damn thing just happened. Did a Windows update and downloaded 2 patches (Malicious tool and the iPod fix). rebooted. ATT tried to initialize Crossfire right off the bat which made the system hang. Rebooted into safemode and removed ATT. Booted back into Vista and CCC is now functioning correctly. o_O
     
    Last edited: Jun 2, 2007
  8. vbawol

    vbawol New Member

    Joined:
    Dec 14, 2002
    Messages:
    7
    Likes Received:
    0
    Trophy Points:
    0
    Comany of heros patch 1.7 enabled DX10. With the Supplemental drivers for 2900xt I was able to use the DX10 option but with 7.5 the options are greyed out.

    Anyone else getting this problem? or is it just me.



    Edit: With 7.5 drivers my 2900xt is showing up as "Radeon X1900 Series Secondary" in the log file from company of heroes

    00:35:14.71 SPDx9 -- Driver Name = atiumdag.dll Desc = Radeon X1900 Series Secondary


    Also 3dmark06 shows GFX as "Radeon X1900 Series Secondary" yet Device manager shows "ATI Radeon HD 2900XT" ver 8.380.0.0
     
    Last edited: Jun 1, 2007
  9. GeneralClaymore

    GeneralClaymore Active Member

    Joined:
    Oct 17, 2004
    Messages:
    436
    Likes Received:
    2
    Trophy Points:
    28
    There working great so far, a new setting poped up. LCD overdrive. I have no idea whats it for :rofl:
     
  10. darkrender

    darkrender New Member

    Joined:
    Jun 1, 2007
    Messages:
    1
    Likes Received:
    0
    Trophy Points:
    0
    Do they support the X2300? Having been waiting a new driver for a long time.
     
  11. MidnightWatcher

    MidnightWatcher New Member

    Joined:
    Nov 5, 2002
    Messages:
    164
    Likes Received:
    0
    Trophy Points:
    0
    Installation went fine, but now when I select 1440x900 @ 60Hz my monitor goes blank, and says unsupported mode, recommended mode is 1440x900 @ 60Hz. ??? The only refresh rate that will work is 75Hz. Is this a bug?

    I'm using Vista Home Premium x64.
     
  12. theonlybabyface

    theonlybabyface GO CANUCKS GO!!!

    Joined:
    Dec 14, 2002
    Messages:
    129
    Likes Received:
    0
    Trophy Points:
    0
    No issues so far...solid drivers!!! ;)
     
  13. stelea16

    stelea16 New Member

    Joined:
    Jun 1, 2007
    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    0
    I`m experiencing the same thing, I get an out of range error when trying to set 1440x900 mode on my LCD, even though that`s it`s native resolution. The 8.37.4.2&3 didn`t do this...anybody have any idea why it`s happening?
     
  14. jumpyjim

    jumpyjim ATI FanBoi

    Joined:
    Jun 1, 2003
    Messages:
    23
    Likes Received:
    0
    Trophy Points:
    0
    The 7.5's seem fine so far, no problems whatsoever :)
     
  15. thecaretaker

    thecaretaker New Member

    Joined:
    May 12, 2003
    Messages:
    31
    Likes Received:
    0
    Trophy Points:
    0
    Hello Terry M, yes you know me. Your No.1 fan,

    What is going on at your place these days. Spare a thought for a poor school caretaker. Nothing in 7.5 fixes any of my reported issues, in fact they make them worse. Fewer and fewer demos wants to run smoothly with every update.

    The demo Adrenalin by Smash Designs splutters like hell then crashes before it ends
    Download Link


    What have you done Terry to openGL to make demos like Legomania run at 1 frame every 5 seconds and all the characters made up of wireframe?
    Legomania download links

    Why do I get demos that fail to run with diagnostics that say this:
    [​IMG]
    Download link

    Why do I have 164 demos that crash with this:
    [​IMG]

    Why do I keep getting these errors in event log every time I boot:

    IRQARB: ACPI BIOS does not contain an IRQ for the device in PCI slot 2, function 0. Please contact your system vendor for technical assistance.

    IRQARB: ACPI BIOS does not contain an IRQ for the device in PCI slot 7, function 0. Please contact your system vendor for technical assistance.

    I am seriously wondering why I spent so much money buying ATI and what in heaven made me moved to Vista. This isn't progress Terry.

    Is anyone listening anymore? I have submitted reports!
     
  16. Judas

    Judas Obvious Closet Brony Pony

    Joined:
    May 13, 2002
    Messages:
    39,221
    Likes Received:
    1,292
    Trophy Points:
    138
    The exact issues i've experienced thecaretaker...

    The problem i ran into was a horrible download that appears to run without an issue, but was corrupt in some manner or another.

    I'd highly suggest doing a complete uninstall of those drivers and a wipe of the ATI references.

    Then redownload the latest 7.5's and install again.
     
  17. thecaretaker

    thecaretaker New Member

    Joined:
    May 12, 2003
    Messages:
    31
    Likes Received:
    0
    Trophy Points:
    0
    Thanks for the quick reply. I will give it another try. But I have tried so many times before, nothing seems to change it. Got the latest BIOS, XI-Fi drivers. ATI Motherboard drivers. Got all the lastest Windows Updates. Nobody can ever accuse me of not keeping up to date m8.

    I'm also unable to use crossfire. When I install the drivers, click to enable in CCC. Instant crash. I have to uninstall in safe mode to stop it looping.

    Apart from 3D stuff, the system is rock solid and Vista works well. But all my issues are related to my Radeon 1800XT. Thought I understood most things by now, but this beats me. It's got to be driver related, maybe more on the motherboard side though..:-(

    Sapphire PC-A9RD480Adv
     
  18. Judas

    Judas Obvious Closet Brony Pony

    Joined:
    May 13, 2002
    Messages:
    39,221
    Likes Received:
    1,292
    Trophy Points:
    138
    Erg, that's not good at all, i'd wonder if maybe the card was bad or something else strange going on,

    have you ran through a solid 24 hour mem test..... sounds like somethings just not right.
     
  19. Varsity

    Varsity New Member

    Joined:
    Jun 1, 2007
    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    0
    Edit: Silly me, I didn't have MSXML4 installed. How the heck did I manage to mod the 7.4s last time?
     
    Last edited: Jun 2, 2007
  20. Randomness

    Randomness somewhere in the wired

    Joined:
    Dec 17, 2005
    Messages:
    370
    Likes Received:
    3
    Trophy Points:
    0
    Hello:

    I too am experiencing this same problem as MidnightWatcher and stelea16 where my monitor will not function at 1440x900 @ 60Hz ; However it does work at 75Hz. I get a similar monitor error stating that the Display mode is not supported.

    Vista Home Premium 32bit and Catalyst 7.5
    X1950 Pro 256MB
    Samsung SyncMaster 941BW
    connected via DVI

    Take care,

    Randomness
     
    Last edited: Jun 2, 2007

Share This Page

visited