Ati 2900 xt after reboot shows as Radeon X1900 Series Secondary w/cat7.5

Discussion in 'AMD Graphics Cards' started by vbawol, Jun 10, 2007.

  1. vbawol

    vbawol New Member

    Joined:
    Dec 14, 2002
    Messages:
    7
    Likes Received:
    0
    Trophy Points:
    0
    Hello,

    I am a long time DH fan 7th time poster.

    The problem Im having is with the Cat 7.5 drivers and my 2900xt. Install the 7.5 drivers and after I reboot, games show my GFX as "Radeon X1900 Series Secondary" and that ensures that no DX10 games will run. In the device manager it allways shows up as ATI Radeon HD 2900 XT

    --Installed 7.5 driver w/no reboot yet 3dmark06 shows, DX10 works fine:
    Display Device 1/2
    ATI Radeon HD 2900 XT Driver 8.380.0.0

    Description ATI Radeon HD 2900 XT
    Manufacturer ATI Technologies Inc.
    Total Local Video Memory 510 MB
    Total Local Texture Memory 510 MB
    AGP Aperture Size 1.75 GB
    Driver File atiumdag.dll
    Driver Version 8.380.0.0
    Driver Date 5-17-2007

    --After reboot it shows, No DX10 support:
    Display Device 1/2
    ATI Radeon HD 2900 XT Driver 8.380.0.0

    Description Radeon X1900 Series Secondary
    Manufacturer ATI Technologies Inc.
    Total Local Video Memory 514 MB
    Total Local Texture Memory 514 MB
    AGP Aperture Size 1.75 GB
    Driver File atiumdag.dll
    Driver Version 8.380.0.0
    Driver Date 5-17-2007


    It looks like all other games (like CoH) have this problem also. I have used driver cleaner .NET and reinstalled the drivers many times and this happens everytime after reboot.

    Can anyone with vista64 and 2900xt check 3dmark06 for the GFX description? and see if it says "Radeon X1900 Series Secondary".

    Any ideas or help are welcome.

    Thanks,
    vbawol
     

Share This Page

visited