ATi Radeon Mobility Modded Catalyst/Drivers for Windows XP 32-bit (Updated)

Discussion in 'AMD Graphics Cards' started by dansrfe, Nov 4, 2010.

  1. Raen

    Raen New Member

    Joined:
    Feb 26, 2011
    Messages:
    18
    Likes Received:
    0
    Trophy Points:
    0
    Sorry for the double post, but I'm having problems updating to these v11.9 drivers.

    When doing a manual install/update via Device Manager, it says that it wasn't able to find any better match/suitable drivers. Tried updating in Safe Mode but also without any results.

    My gfx card is a Mobility Radeon HD 3650, so there shouldn't be any problem updating.
    I've checked "CX125297.inf" and the line "ATI MOBILITY RADEON HD 3650" = ati2mtag_M76, PCI\VEN_1002&DEV_9591" is there, but should there be any more lines referring to 3650?

    EDIT: Problem solved!
    Had to choose "Don't search. I will choose the driver to install", deselect any driver on the list, click "Have Disk..." and then go the the .inf file location, etc.
    (In Safe Mode to avoid any errors)

    Working good as always ;)
     
    Last edited: Oct 9, 2011
  2. evilky

    evilky New Member

    Joined:
    Oct 10, 2011
    Messages:
    1
    Likes Received:
    0
    Trophy Points:
    0
    Hello! After searching the whole day for some compatible ATI mobility HD 5470 xp drivers i found this forum. So i ask you, if you would be so kind and give me a link for the drivers that i need, i saw your note, 81 downloads and only 1 reply... i understand how you feel, but i dont need the latest drivers any of them would be fine so i can finally make this work. your help would be much appreciated!
     
  3. jamiejee

    jamiejee New Member

    Joined:
    Oct 11, 2011
    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    0
    Hello,

    after a couple of hours searching whole the net to get the new drivers for my graphic card, trying Mobility Modder by myself etc. I found this thread.

    I have ASUS M51SE laptop with ATI Mobility Radeon HD 3470, Win XP SP3 Professional. I've never thought about updating the drivers, until today that I've found out there's hardware acceleration support in newest Firefox for WebGL, but it requires modern version of drivers (about:support said to update to at least 10.6).

    @dansrfe:
    I've found your 11.4 modded drivers (ha, the power of internet; I will not publish the link however if you don't want it) and it seems it works just fine. I've launched Firefox 7 and now it says in about:support that WebGL is supported, and I was able to run those examples: Demo Repository - WebGL Public Wiki and they run very smoothly.

    Thanks for the drivers. I will surely report back if I encounter any issues; if not, it means everything works fine. Regards.

    Edit:
    Just one thing about installation. I had to choose "Don't search, I will choose the driver to install" instead of "Include this location in search" and then choose "HD 3470", otherwise Windows kept telling me that I already had super awesome 3-years-old drivers and there is no need to upgrade, which was clearly bullshit.
     
    Last edited: Oct 11, 2011
  4. Hokum

    Hokum New Member

    Joined:
    Oct 23, 2011
    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    0
    @dansrfe - you seem to have done a great job, but you seem to have taken down the links now.

    I'm about to buy a new notebook but have ruled out one with the 6990m because I need an XP system for various old work apps and devices. So it looks like I'm forced to go Nvidia. Am I correct in this fatalism, or would I be able to get a 6990m functional? Also - please, please, put maybe one of the links back?
     
  5. jamiejee

    jamiejee New Member

    Joined:
    Oct 11, 2011
    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    0
    Just one thing to add to my previous post.

    The things I described before referred to laptop's built-in display (1440x900). It worked just fine after installing modded 2011.04 and 2011.09 drivers.

    I have also external monitor: Belinea 1925 S1W LCD (nominal resolution also 1440x900). This monitor worked fine with original 2008 laptop-bundled Radeon drivers.

    Little side story a.k.a off-topic:

    Some time ago I had very weird issue with the monitor (the colors were very weird, like 'colorized', with the 'dye' depending on the monitor's RGB temperature settings -- but this is not related to the topic -- RTV repair guy flushed & newly loaded hardware drivers of the monitor, so now the colors are normal. He said he's never seen case like that).

    The things is now, that the external monitor does not comply with modded Radeon drivers (neither 2011.09 nor 2011.04). Maximum resolution I could achieve was 1280x900 or sth like that, I don't remember, maybe 1280x1024. When I tried setting the native 1440x900, monitor was switching off and OSD display was saying "Out of frequency" (same with generic Microsoft monitor drivers, and the ones I've got from Belinea).

    I rolled back to 2008 original laptop drivers and then I was able to run 1440x900 on Belinea.

    So, finally, the corollary is: modded drivers sometimes work fine, but sometimes not or not fully.
     
  6. ulit

    ulit New Member

    Joined:
    Oct 24, 2011
    Messages:
    1
    Likes Received:
    0
    Trophy Points:
    0
    Hi, all!
    I have notebook HP G62-a14ER, there are two videocards, one of them is ATI Mobility HD 5470 ( PCI\VEN_1002&DEV_68E0&SUBSYS_143A103C&REV_00\4&2A7D5098&0&0008)
    I can't find driver win XP.

    I've installed the latest Omega Drivers, but it doesn't help.

    I understand, that win 7 is good, but i need to use win XP for some tasks on my notebook.
     
  7. dansrfe

    dansrfe New Member

    Joined:
    Jul 15, 2009
    Messages:
    55
    Likes Received:
    0
    Trophy Points:
    0
    September 2011 link is back up. I trust you guys to reply with your experiences now otherwise I will stop updating this thread and remove the links forever.

    Please don't break my trust and take 10 seconds of your time to comment on how the installation went for you. That's all I ask. I don't even need a thanks.
     
  8. Hokum

    Hokum New Member

    Joined:
    Oct 23, 2011
    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    0
    Thanks!!! What would you say the chances are of this working on 6990? If it doesn't work, what scale of 'wrong' would we be expected to see? I mean, is it more likely to be at the frequent BSOD -side or just minor effects not displaying correctly? If minor effects are more likely, I'll risk it and happily report back.
     
  9. elnarcho

    elnarcho New Member

    Joined:
    Nov 1, 2011
    Messages:
    1
    Likes Received:
    0
    Trophy Points:
    0
    Hello Dansrfe,

    It looks like September link is back down. Either Internet Explorer nor Google Chrome cannot show the page.

    Thanks in advance. I (we) really appreciate your work. ;)

    Edit: the link is up again. Sorry about my complain.
     
    Last edited: Nov 1, 2011
  10. Alexandrus

    Alexandrus New Member

    Joined:
    Aug 8, 2004
    Messages:
    1
    Likes Received:
    0
    Trophy Points:
    0
    Worked for me, but the driver is NOT modded properly, as OpenGL isn't working.
     
  11. Synchro69

    Synchro69 New Member

    Joined:
    Nov 7, 2011
    Messages:
    1
    Likes Received:
    0
    Trophy Points:
    0
    Tnx for re-uploading the driver mate. It works great for me on my ATI Mobility 3470!
     
  12. dansrfe

    dansrfe New Member

    Joined:
    Jul 15, 2009
    Messages:
    55
    Likes Received:
    0
    Trophy Points:
    0
    To be honest I don't mod for individual cards. I think there is a guide somewhere on this forum that details on how to identify your card's unique ID and put that information into the INF file.
     
  13. Raen

    Raen New Member

    Joined:
    Feb 26, 2011
    Messages:
    18
    Likes Received:
    0
    Trophy Points:
    0
    Thanks for your comprehension dansrfe, been using v11.09 until now without any much hassle, almost flawlessly, besides the little glitches described before.

    Feel free to mod and release updated drivers from time to time, if you have the time/patience, we'll all appreciate it :)
     
  14. Zone2

    Zone2 New Member

    Joined:
    Dec 5, 2011
    Messages:
    1
    Likes Received:
    0
    Trophy Points:
    0
    Wow, great. Good to have a modded driver.

    Everything went fine while installing. (edit) Have got a CQ56 203 SG - embetted HD 4250, AMD 800 series chip set, AMD Athlon II P360 (2x @ 2,3GHz), 3GB DDR3.
    It is some tima ago ... was testing this driver here, got 90 points at heaven bench (DX9, WinXP 32) ... later I tried the same thing with 11.11c and got 90 points, with plug in wall. With the same driver and feeded with electrons from akku I got 61 at the use of 8% power in max. performance mode. In max. battery mod I only got a score of 42 Points at the use of 9 - 10 % Power *wtf*. Now I am wondering ... is it absolutely recomended to use a mobility modded driver?
    First, with driver given out from HP, I got a score of 88P / 11% (max performance) | 50 / 8% (max battery) | 88P with electricity outa wall.

    all right, I solved the problem: The system runs an other "energy administration" with plug in. That is the reason for differences to the later driver.

    btw ... 3Dmark06 score is 10 to 20 points lower with latest driver (getting now 1915)
     
    Last edited: Dec 5, 2011
  15. dansrfe

    dansrfe New Member

    Joined:
    Jul 15, 2009
    Messages:
    55
    Likes Received:
    0
    Trophy Points:
    0
    New Release: November 2011 Mobility Modded Drivers

    Please install/update and REPLY back with any errors or problems you had and how you fixed them (if you did).
     
  16. Raen

    Raen New Member

    Joined:
    Feb 26, 2011
    Messages:
    18
    Likes Received:
    0
    Trophy Points:
    0
    Thanks for the v11.11 drivers.

    Everything installed fine in the end, had to do like in post #61, but this time in normal mode, because Windows in safe mode couldn't find some files and gave some errors when installing the .inf.
     
  17. Sim77

    Sim77 New Member

    Joined:
    Dec 19, 2011
    Messages:
    1
    Likes Received:
    0
    Trophy Points:
    0
    Same problem here, i have an ASUS K73BY notebook with 6470 mobility 1gb, i cant find driver for win_xp_sp3, PLEASE DANSRFE - - - H E L P US !!
     
  18. regisk

    regisk New Member

    Joined:
    Dec 19, 2011
    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    0
    Is there a way to make it work on a Radeon HD 6370? It did'nt recognize my laptop card :(
     
  19. regisk

    regisk New Member

    Joined:
    Dec 19, 2011
    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    0
    Same here, but with my 6370 mobility :( PLEEEEEEEASE, HELP! :tears:
     
  20. Laskaris

    Laskaris New Member

    Joined:
    Jul 20, 2011
    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    0
    Hello,

    works lika a charm. I mod my drivers myself (change .inf file) but I do have problems to make CC to install through setup.exe - how do you skip check routine so that CC can be installed through setup.exe Dansrfe? It always works with your packages. I normaly use Ati Tray Tools so it is not a big deal, but it would be nice to know how you do it.

    Thank you for your efforts.

    with best regards,

    L.
     

Share This Page

visited