Bad Lag In Older Game

Discussion in 'Gaming Discussion' started by drwho, Feb 22, 2016.

  1. drwho

    drwho Active Member

    Joined:
    Aug 6, 2004
    Messages:
    707
    Likes Received:
    28
    Trophy Points:
    38
    I play an older game which is called Silent Hunter 4. I've been experiencing bad lag in the game since I reinstalled it on my computer awhile back. I honestly don't know if there is a cure, but I thought I'd ask if there might be a solution I might not have thought of. Things I've tried is different drivers (older and newer), going from a third party sound card to onboard sound, have tried both Nvidia and AMD GPUs, and many other things too numerous to mention. I should mention I don't seem to have any problems with the newer games I play.

    My computer specs are as follows.

    850w PSU
    Intel i7 6770k (no OC)
    Asrock z170 Gaming 6+
    Asus GTX 970 Strix 4 GB
    G.Skill DDR4 3200 16 GB
    Samsung SSD Evo 850 250 GB
    Samsung G29C790 29"

    The reason I'm asking about this other than the fact the game lag is very annoying is the fact that SH4 is my all time favorite game and it keeps drawing me back to play.
     
  2. Trusteft

    Trusteft HH's Asteroids' Dominator

    Joined:
    Nov 2, 2004
    Messages:
    23,883
    Likes Received:
    3,658
    Trophy Points:
    153
    1. Have you tried running it with a single cpu core?
    2. Have you tried dxwnd.exe?
    3. You don't mentioned your OS. If it is a newer OS I assume you tried compatibility options, right?
    4. Have you tried reducing the poll rate of mouse and of keyboard to 125hz?
     
  3. drwho

    drwho Active Member

    Joined:
    Aug 6, 2004
    Messages:
    707
    Likes Received:
    28
    Trophy Points:
    38
    My bad. My OS is Windows 10 64-bit.

    Can't say I know anything about a dxwnd.exe.

    I've not tried running the game using 1 cpu core.

    Not sure if I can reducing the poll rate of the mouse or keyboard. Not really sure how to do it either.
     
  4. Trusteft

    Trusteft HH's Asteroids' Dominator

    Joined:
    Nov 2, 2004
    Messages:
    23,883
    Likes Received:
    3,658
    Trophy Points:
    153
    Check the software that comes with them. If there is any. If there isn't, no idea how to do so, if it is even possible.
    With some games it greatly helps. For example the re-release of Reach for the stars (2004) is unplayable on most system if you don't reduce it to 125hz. Same with Harbinger and few others.
    If you can't change them, try the other things first.
     
  5. Dyre Straits

    Dyre Straits 10 Grandkids -2 Great-grandsons

    Joined:
    May 13, 2002
    Messages:
    19,582
    Likes Received:
    2,550
    Trophy Points:
    153
    The most recommended option for doing this is to set the CPU to use just one core on the older games. It's been quite some time since I had to do it, but, it has to do with setting the AFFINITY for just that particular game/app.
     
  6. drwho

    drwho Active Member

    Joined:
    Aug 6, 2004
    Messages:
    707
    Likes Received:
    28
    Trophy Points:
    38
    Sorry to say that setting one core on a processor to run a game is something I've never done before. I will do some googling and see if I can find out how.
     
  7. Trusteft

    Trusteft HH's Asteroids' Dominator

    Joined:
    Nov 2, 2004
    Messages:
    23,883
    Likes Received:
    3,658
    Trophy Points:
    153
    I haven't done it in years, but what used to be the case would be to run the game and then go to task manager, find the exe and right click on it to set the affinity to whatever you wanted. A process which has to be repeated every time.
     
  8. drwho

    drwho Active Member

    Joined:
    Aug 6, 2004
    Messages:
    707
    Likes Received:
    28
    Trophy Points:
    38

    Thanks for the help, I will give this a try and report back after testing. :D
     
    Dyre Straits likes this.

Share This Page

visited