bug reports for OS X driver 1.2b0

Discussion in 'MAC OS X Driver' started by Eugene Gavrilov, Oct 13, 2008.

  1. Eugene Gavrilov

    Eugene Gavrilov kX Project Lead Programmer and Coordinator

    Joined:
    Dec 7, 2002
    Messages:
    3,146
    Likes Received:
    9
    Trophy Points:
    48
    please report 1.2b0-specific issues and bugs here

    if you think the bug requires additional information or discussion, start a new topic and do only post a very brief description of the problem in this thread (as well as a link to your new topic)

    PLEASE do not post suggestions, ideas, 'thanks', 'how do I' questions here!

    E.
     
  2. danricci

    danricci New Member

    Joined:
    Oct 11, 2008
    Messages:
    5
    Likes Received:
    0
    Trophy Points:
    0
    distortion still remains in SB Live 5.1 (SB0100 - D000).My OsX is 10.5.5. Distortion after 1 Min 15seg. After 9˜10 min, back to normal. 15min back distortion.
     
    Last edited: Oct 16, 2008
  3. zaurak

    zaurak New Member

    Joined:
    Sep 25, 2008
    Messages:
    9
    Likes Received:
    0
    Trophy Points:
    0
    Thanks for the new release.

    1. Sleep/wake works like a charm, except that there is no sound after wake-up, but I've edited the uninstall script to unload and reload the kext, and works very well.
    2. The kernel Panic persist in 1.2b0 as in 1.1b1. With 1.1b0 its OK.
    3. I don't know what is the connection with it, but this release fixed for me the "jumpy mouse" issue after wake-up, and causes a display issue using digital output from the graphic card, but I switched to analog and its OK.
    4. No distortion for me.

    Zaurak
     
    Last edited: Oct 17, 2008
  4. Oxtie

    Oxtie Active Member

    Joined:
    May 14, 2008
    Messages:
    137
    Likes Received:
    0
    Trophy Points:
    26
    IMF (InsanelyMac Forums) + DH Reported:
    1. System Crashes: (11+) confirms (Kernel Panics 4) (System Freeze aka lockups 7) It seems that turning off ACPI makes everthing normal see these follow up posts
    2. No sound after driver update: 1 user
    3. System Sounds disabled after update: 2 users confirmed
    4. No sound after StandBy resume: (3+)
    5. System goes to standby (sleep) instead of shutdown (3+)
    6. kX Installer fails to start drivers and fails to detect source of conflict dusing installation. (it appears another audio driver locked Pci BUS giving "BUS error") [related to 1 2]

    a question popped up @ IMF
    Where are SPDIF enable/disable settings?

    SenVa posted something related to hallab (not sure if it helps)

    Edited:
     
    Last edited: Nov 10, 2008
  5. gregbacsi

    gregbacsi New Member

    Joined:
    Oct 14, 2008
    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    0
    hello, first of all thanks for your work, i really appreciate it. but i have a really serious problem with the OS X driver 1.2b0: at the first time i`ve installed the 1.0b3, and that was a bad move, becouse there was an ugly distortion.

    then i`ve installed the 1.2b0 without uninstalling the 1.0b3, and i guess thats cause my actual problem: there is the same distortion with the latest 1.2b0.

    since that i`ve tried to uninstall both of them, but the device is still there in the system prefs, so i guess it wasnt that successful. anyway, i have a sound blaster 5.1 live!, as a device id: kX SB0228 10k1 [e880]

    so, my question is that, what should i do? how to uninstall completely, just to have the opportunity to install properly?

    thanks for your time, and sorry for my bad english.

    sincerely, greg
     
  6. gregbacsi

    gregbacsi New Member

    Joined:
    Oct 14, 2008
    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    0
    kk, the problem is still there after a full reinstall. this time i've installed only the latest 1.2b0, but the distorsion comes - exactly after 1 min and 7 seconds. so i think that's not my bad.

    i guess the only thing i can do that waiting for a new, fixed verison. anyway keep up the good work!
     
  7. braso

    braso New Member

    Joined:
    Oct 15, 2008
    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    0
    Hi, thanks for the driver first, it's really appreciate and i know you work hard for it..
    I have a CT4620 SB LIve, i installed you're latest driver, works great but for 10 minutes only.
    -How can i determine the version driver i'm using, i was running with the 1.1b0 and upgrade to version 1.2b0.
    -I have the same problem, works great for the first 10 minutes and distortion and die...
    -I'm running 10.5.4 JaS
    -If i unload/reload the driver manually , works great for the next 10 minutes..

    Thanks

    Braso
     
  8. themax

    themax New Member

    Joined:
    Oct 25, 2007
    Messages:
    23
    Likes Received:
    0
    Trophy Points:
    0
    The sound now is relly great, good 5.1 movies sound by analog output, but get random kernel panics, 5-40 minutes.

    No kernel panick whit v1 but the sound suck a bit whit that version.

    Card: Audigy 2 ZX

    Thanks for your work, when the DSP arrive, kx would be the best driver for OSX.
     
  9. djsubject

    djsubject New Member

    Joined:
    Aug 16, 2008
    Messages:
    63
    Likes Received:
    0
    Trophy Points:
    0
    since installing this driver i get a system lock up (4 to 40 minutes also)

    have to hard reboot, bar that this driver is very good,

    Emu 1820m

    Subz
     
  10. AlexYankee

    AlexYankee New Member

    Joined:
    Oct 3, 2008
    Messages:
    4
    Likes Received:
    0
    Trophy Points:
    0
    Îòâåò: bug reports for OS X driver 1.2b0

    Lock up and kernel panic also with 1.2b0
    10.5.5 Vanilla Kernel
     
  11. chimp420

    chimp420 New Member

    Joined:
    Oct 18, 2008
    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    0
    Hi, updated to this version and system audio was gone. Audio from iTunes and Quicktime remained fine. Switched back to 1.1b0. My model is Audigy 2 ZS but I don't know the rest of the specifications. Hope this helps.

    Thanks E. for all your work.
     
  12. Insphire

    Insphire New Member

    Joined:
    Mar 31, 2003
    Messages:
    27
    Likes Received:
    0
    Trophy Points:
    0
    Im still getting random kernel panics with this version.

    Audigy 2 platinum.
    C2Q 6600
     
  13. catboy

    catboy New Member

    Joined:
    Aug 12, 2008
    Messages:
    6
    Likes Received:
    0
    Trophy Points:
    1
    10.5.5 core2duo
    Audigy 2 zs

    System crash !! randomly. ..
     
  14. Gintas

    Gintas New Member

    Joined:
    Aug 23, 2008
    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    0
    Also getting random kernel panics! :(
    Sleep is working, but after resume I have no sound.

    Ideneb 1.3 (10.5.5 vanilla kernel)
    Audigy2 ZS Platinum
     
  15. zaurak

    zaurak New Member

    Joined:
    Sep 25, 2008
    Messages:
    9
    Likes Received:
    0
    Trophy Points:
    0

    I modified the uninstall script as follows to be able to have sound after resume from sleep. But i can't use the 1.2b0 driver because of the kernel panic.

    sudo echo
    sudo kextunload /System/Library/Extensions/kXAudioDriver.kext
    sync
    sudo kextload /System/Library/Extensions/kXAudioDriver.kext
    sync
    sudo sync
     
  16. Peles

    Peles New Member

    Joined:
    Oct 21, 2008
    Messages:
    1
    Likes Received:
    0
    Trophy Points:
    0
    Hi,
    My system can't shut down propperly after installing sound drivers 1.2b0 on Kalyway 10.5.2
    It just goes to sleep instead and all fans are still on. Have to manually shut it down with power button.
    Any help there?

    Another question...I how can I remove these drivers from system completely?
    Thanks.
     
  17. dj_stick

    dj_stick Apple Fanboy?

    Joined:
    Jun 3, 2003
    Messages:
    17,575
    Likes Received:
    204
    Trophy Points:
    88
    delete the kext file(s) from system/library/extensions
     
  18. Snow_white

    Snow_white New Member

    Joined:
    Oct 16, 2008
    Messages:
    7
    Likes Received:
    0
    Trophy Points:
    0
    But that means that you have to manualy start the script each time your pc wakes up from sleep mode right?
     
  19. zaurak

    zaurak New Member

    Joined:
    Sep 25, 2008
    Messages:
    9
    Likes Received:
    0
    Trophy Points:
    0
    Yes, i put the script to my desktop and i execute it manually. I'm shure it will be fixed in the next release, so it's just a temporary iconvenience. Anyway i still use the 1.1b0 because of the kernel panics.
     
  20. speedracer67

    speedracer67 New Member

    Joined:
    Oct 22, 2008
    Messages:
    4
    Likes Received:
    0
    Trophy Points:
    0
    I am also getting random kernel panics using 1.20b. I am using an Audigy 2ZS Platinum Pro. OS X 10.5.5 with voodoo beta 2c kernel on otherwise Vanilla install.

    Please keep up the good work! It's greatly appreciated!
     

Share This Page

visited