bug reports for OS X driver 1.2b1

Discussion in 'MAC OS X Driver' started by Eugene Gavrilov, Nov 19, 2008.

  1. allanchen

    allanchen New Member

    Joined:
    Mar 17, 2009
    Messages:
    4
    Likes Received:
    0
    Trophy Points:
    0
    Emu 0404 card not work with 10.5.6 ipc version.Same as under XP,FPGA programming failed!

    ==== E-mu E-DSP initialization
    ==== FPGA is not programmed, upload FPGA firmware...
    Error: FPGA programming failed!
    ==== E-DSP Parameters were reset to defaults
    ==== Dock is connected and is functioning properly
    ==== Current E-DSP status
    Card: 'E-0404 10k2 [e800]'
    Options: 7f - Hamoa Sync Dock_online Dock_offline
    Hana ID: 7f
    Versions: 127.127, 127.127, 127
    Dock is Powered-On. [0x7f]
    WClock: 7 [OFF]
    Def clock: -1
    HANA is Unknown!
    HANA IRQs: 7f
    SPDIF mode [7f]:
    Out: Professional; Copy-protected
    In: ; Professional; Copy-protected; Not Valid
    Optical Type: [7f] -- Input: ADAT, Output: ADAT
    MIDI In: dock2 , dock2 [7f]
    MIDI Out: 7f
    LEDs: 7f 7f 7f
    ADC pads: 7f - Dock_1 Dock_2 Dock_3 0202_1
    DAC pads: 7f - Dock_1 Dock_2 Dock_3 Dock_4 0202_1
    Dock misc: [7f] DAC mute: 1111 headphones: 7
    ADAT Unlocked
    SPDIF Unlocked
    BNC Locked : 6000
    SPDIF Locked : 6000
    reg 14-1f:[7f] [7f] [7f] [7f] [7f] [7f] [7f] [7f] [7f] [7f] [7f] [7f]
    reg 30-3f:[7f] [7f] [7f] [7f] [7f] [7f] [7f] [7f] [7f] [7f] [7f] [7f] [7f] [7f] [7f]
     
  2. robbone

    robbone New Member

    Joined:
    Apr 17, 2009
    Messages:
    4
    Likes Received:
    0
    Trophy Points:
    0
    hi, i have E-mu 1820, after installing the drivers (kXAudioDriver-1.2b1.dmg) I do not have sound, the command 'edspctrl' in terminal initialize FPGA firmware and still nothing. I have not even kx mixer only kx manager but it is empty. How install EMU 1820? Please help - I must use this card in Logic. Result when type "edspctrl" in terminal:

    ==== E-mu E-DSP initialization
    ==== FPGA appears to be already programmed
    ==== Dock is connected and is functioning properly
    ==== Current E-DSP status
    Card: 'EM8810 10k2 [d000]'
    Options: 4 - Dock_online
    Hana ID: 55
    Versions: 3.4, 3.4, 0
    Dock is Powered-On. [0x1]
    WClock: 0 [Int 48]
    Def clock: 48000
    HANA is UnMuted
    HANA IRQs: f
    SPDIF mode [10]:
    Out: Consumer
    In: Consumer; Not Valid
    Optical Type: [3] -- Input: ADAT, Output: ADAT
    MIDI In: dock2 , none [3]
    MIDI Out: c
    LEDs: 0 12 0
    ADC pads: 0 -
    DAC pads: 0 -
    Dock misc: [0] DAC mute: 0000 headphones: 0
    ADAT Unlocked
    SPDIF Locked : 36035
    BNC Locked : 18285
    SPDIF Locked : 12000
    reg 14-1f:[7f] [7f] [7f] [7f] [7f] [7f] [7f] [7f] [7f] [7f] [7f] [7f]
    reg 30-3f:[7f] [7f] [7f] [7f] [7f] [7f] [7f] [7f] [7f] [7f] [7f] [7f] [7f] [7f] [7f]
     
  3. ka11

    ka11 New Member

    Joined:
    Apr 19, 2009
    Messages:
    1
    Likes Received:
    0
    Trophy Points:
    0
    Hi, couple of days ago I installed RETAIL MAC OS X Leopard 10.5.6 using a boot-132 cd. Obivously, my sound didn't work so I came up to this site and installed these drivers - used installer in .dmg, restarted pc and couldn't see any output devices in midi settings.. tried doing this couple of times - didn't work. Even unloading kext in terminal was unsuccessful. Any ideas why this doesn't work ? I'm a Mac-noob so I don't really know much :p. Any help would be appreciated.
     
  4. billmaudit

    billmaudit New Member

    Joined:
    Jun 16, 2009
    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    0
    HI, I got EMU 0404 on Leo 10.5.7
    I tried the kx driver on windows xp and OSX, firmware is not uploading (error mesage)
    card is detected but no sound coming out whatever output is chosen.

    edspctrl results :
    Code:
    ==== E-mu E-DSP initialization
    ==== FPGA is not programmed, upload FPGA firmware...
    Error: FPGA programming failed!
    ==== E-DSP Parameters were reset to defaults
    ==== Dock is connected and is functioning properly
    ==== Current E-DSP status
    Card: 'E-0404 10k2 [cc00]'
    Options: 7f - Hamoa Sync Dock_online Dock_offline
    Hana ID: 7f
    Versions: 127.127, 127.127, 127
    Dock is Powered-On. [0x7f]
    WClock: 7 [OFF]
    Def clock: -1
    HANA is Unknown!
    HANA IRQs: 7f
    SPDIF mode [7f]:
    	Out: Professional; Copy-protected
    	In: ; Professional; Copy-protected; Not Valid
    Optical Type: [7f] -- Input: ADAT, Output: ADAT
    MIDI In: dock2 , dock2  [7f]
    MIDI Out: 7f
    LEDs: 7f 7f 7f
    ADC pads: 7f - Dock_1 Dock_2 Dock_3 0202_1 
    DAC pads: 7f - Dock_1 Dock_2 Dock_3 Dock_4 0202_1 
    Dock misc: [7f] DAC mute: 1111 headphones: 7
    ADAT Unlocked
    SPDIF Unlocked
    BNC Locked : 6000
    SPDIF Locked : 6000
    reg 14-1f:[7f] [7f] [7f] [7f] [7f] [7f] [7f] [7f] [7f] [7f] [7f] [7f] 
    reg 30-3f:[7f] [7f] [7f] [7f] [7f] [7f] [7f] [7f] [7f] [7f] [7f] [7f] [7f] [7f] [7f]
    
    After booting on XP and using the official emu drivers (sound works ok then), then reboot under OSX and edspctrl results :
    Code:
    ==== E-mu E-DSP initialization
    ==== FPGA appears to be already programmed
    ==== Dock is not connected
    ==== Current E-DSP status
    Card: 'E-0404 10k2 [cc00]'
    Options: 1 - Hamoa   
    Hana ID: 55
    Versions: 1.0, 127.127, 127
    Dock is Powered-On. [0x7f]
    WClock: 0 [Int 48]
    Def clock: 48000
    HANA is Muted
    HANA IRQs: f
    SPDIF mode [10]:
    	Out: Consumer
    	In: Consumer; Not Valid
    Optical Type: [1] -- Input: ADAT, Output: SPDIF
    MIDI In: 0202, dock1 [31]
    MIDI Out: 8
    LEDs: 7f 7f 7f
    ADC pads: 7f - Dock_1 Dock_2 Dock_3 0202_1 
    DAC pads: 7f - Dock_1 Dock_2 Dock_3 Dock_4 0202_1 
    Dock misc: [7f] DAC mute: 1111 headphones: 7
    ADAT Unlocked
    SPDIF Locked : 36462
    BNC Locked : 22588
    SPDIF Locked : 6000
    reg 14-1f:[7f] [7f] [7f] [7f] [7f] [7f] [7f] [7f] [7f] [7f] [7f] [7f] 
    reg 30-3f:[7f] [7f] [7f] [7f] [7f] [7f] [7f] [7f] [7f] [7f] [7f] [7f] [7f] [7f] [7f] 
    
    system.log
    Code:
    16/06/09 14:37:18 kernel kXAudioDevice[0x5473400]::init: --- driver start-up, version 1.2b1 
    16/06/09 14:37:18 kernel kXAudioDevice[0x5473400]::initHardware(0x3a0a680) 
    16/06/09 14:37:18 kernel kXAudioDevice[0x5473400]::initHardware: bus/dev/func: 5/1/0; device/subsys/chip: 00041102:40021102:04010003 - at port cc00 
    16/06/09 14:37:18 kernel kXAudioDevice[0x5473400]::initHardware: I/O range @0x10 (0000cc00) mapped into 0000cc00 [up to 0000cc1f] 
    16/06/09 14:37:18 kernel kXAudioDevice [HAL] --- kX Software Abstraction Level Library init --- 
    16/06/09 14:37:18 kernel kX Audio Driver (Debug) 
    16/06/09 14:37:18 kernel kXAudioDevice [HAL] Hw PCI device: dev: 41102 sub: 40021102 rev: 3 
    16/06/09 14:37:18 kernel kXAudioDevice [HAL] card name: 'E-0404 10k2 [cc00]' 
    16/06/09 14:37:18 kernel kXAudioDevice [HAL] initializing kX HAL... 
    16/06/09 14:37:18 kernel kXAudioDevice [HAL] hal: init e-dsp 
    16/06/09 14:37:18 kernel kXAudioDevice [HAL] hal: need to upload E-DSP FPGA firmware and setup routing 
    16/06/09 14:37:18 kernel kXAudioDevice [HAL] HW voices reset 
    16/06/09 14:37:18 kernel kXAudioDevice [HAL] mpu init 
    16/06/09 14:37:18 kernel kXAudioDevice [HAL] DSP initialization 
    16/06/09 14:37:18 kernel kXAudioDevice [HAL] !! connect: regs not found (pgm1: 8; (sCenter1); pgm2: 9; (out8) 
    16/06/09 14:37:18 kernel kXAudioDevice [HAL] !! connect: regs not found (pgm1: 8; (sCenter2); pgm2: 9; (out9) 
    16/06/09 14:37:18 kernel kXAudioDevice [HAL] Note: microcode EQ set to 'bypass' for OSX 
    16/06/09 14:37:18 kernel kXAudioDevice [HAL] Note: microcode ReverbLT disabled for OSX 
    16/06/09 14:37:18 kernel kXAudioDevice [HAL] Note: microcode Chorus disabled for OSX 
    16/06/09 14:37:18 kernel kXAudioDevice [HAL] Microcode compiled: Nov 19 2008 04:42:31; [Standard microcode]; with '10 Band EQ' 
    16/06/09 14:37:18 kernel kXAudioDevice [HAL] --- Library init completed --- 
    16/06/09 14:37:18 kernel kXAudioDevice [??] [ResetSettings] 
    16/06/09 14:37:18 kernel kXAudioDevice[0x5473400]::createAudioEngine() 
    16/06/09 14:37:18 kernel kXAudioEngine[0x3ae9800]::init 
    16/06/09 14:37:19 kernel kXAudioEngine[0x3ae9800]::initHardware(0x5473400) 
    16/06/09 14:37:19 kernel kXAudioDevice [HAL] asio: allocating voices 0,1; latency: -4800 -- 32-bit 
    16/06/09 14:37:19 kernel kXAudioDevice [HAL] asio: alloc_output(chn=2; hw=0) 
    16/06/09 14:37:19 kernel kXAudioEngine[0x3ae9800]::peformFormatChange(0x5629f00, 0x2e1d2ee8, 0) 
    16/06/09 14:37:19 kernel kXAudioDevice [HAL] asio: allocating voices 2,3; latency: -4800 -- 32-bit 
    16/06/09 14:37:19 kernel kXAudioDevice [HAL] asio: alloc_output(chn=3; hw=2) 
    16/06/09 14:37:19 kernel kXAudioEngine[0x3ae9800]::peformFormatChange(0x5629e00, 0x2e1d2ee8, 0) 
    16/06/09 14:37:19 kernel kXAudioDevice [HAL] asio: allocating voices 4,5; latency: -4800 -- 32-bit 
    16/06/09 14:37:19 kernel kXAudioDevice [HAL] asio: alloc_output(chn=6; hw=4) 
    16/06/09 14:37:19 kernel kXAudioEngine[0x3ae9800]::peformFormatChange(0x5473800, 0x2e1d2ee8, 0) 
    16/06/09 14:37:19 kernel kXAudioDevice [HAL] asio: allocating voices 6,7; latency: -4800 -- 32-bit 
    16/06/09 14:37:19 kernel kXAudioDevice [HAL] asio: alloc_output(chn=7; hw=6) 
    16/06/09 14:37:19 kernel kXAudioEngine[0x3ae9800]::peformFormatChange(0x5629c00, 0x2e1d2ee8, 0) 
    16/06/09 14:37:19 kernel kXAudioDevice [HAL] asio: allocating voices 8,9; latency: -4800 -- 32-bit 
    16/06/09 14:37:19 kernel kXAudioDevice [HAL] asio: alloc_output(chn=4; hw=8) 
    16/06/09 14:37:19 kernel kXAudioEngine[0x3ae9800]::peformFormatChange(0x5629a00, 0x2e1d2ee8, 0) 
    16/06/09 14:37:19 kernel kXAudioDevice [HAL] asio: allocating voices 10,11; latency: -4800 -- 32-bit 
    16/06/09 14:37:19 kernel kXAudioDevice [HAL] asio: alloc_output(chn=5; hw=10) 
    16/06/09 14:37:19 kernel kXAudioEngine[0x3ae9800]::peformFormatChange(0x5629800, 0x2e1d2ee8, 0) 
    16/06/09 14:37:19 kernel kXAudioDevice [HAL] asio: allocating voices 12,13; latency: -4800 -- 32-bit 
    16/06/09 14:37:19 kernel kXAudioDevice [HAL] asio: alloc_output(chn=8; hw=12) 
    16/06/09 14:37:19 kernel kXAudioEngine[0x3ae9800]::peformFormatChange(0x5629700, 0x2e1d2ee8, 0) 
    16/06/09 14:37:19 kernel kXAudioDevice [HAL] asio: allocating voices 14,15; latency: -4800 -- 32-bit 
    16/06/09 14:37:19 kernel kXAudioDevice [HAL] asio: alloc_output(chn=9; hw=14) 
    16/06/09 14:37:19 kernel kXAudioEngine[0x3ae9800]::peformFormatChange(0x5629600, 0x2e1d2ee8, 0) 
    
    FPGA is already programmed, but I still got no sound ! If I do a reset with edspctrl, the firmware is unable to upload again, I'm stuck.
    Are kxdriver sources available ?
     
    Last edited: Jun 16, 2009
  5. Oxtie

    Oxtie Active Member

    Joined:
    May 14, 2008
    Messages:
    137
    Likes Received:
    0
    Trophy Points:
    26
    Yawn... does anyone still check for updates besides me?


    actually IMF thread is also dried out...
     
  6. mdcy

    mdcy New Member

    Joined:
    Jun 28, 2009
    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    0
    My sound card is Sound blaster live, code is ct4830, i install 1.20b1 but only hear sound from right, left ear can not hear anything. And no balance ajust opition.
    System configration.
    Apple Hackintoshi 10.5.6
    Intel E6550
    4GB (ddr2 800*2)
    640GB WD Black Version
    Ati 1950XTX 512MB DDR3
    Soyo 22 Wlcd
    Sound blaster live Ct4830
     
  7. Oxtie

    Oxtie Active Member

    Joined:
    May 14, 2008
    Messages:
    137
    Likes Received:
    0
    Trophy Points:
    26
    If you mean stereo (2.0) not playing on your 5.1 speakers then Click HERE because 5.1 media plays well on this driver although I admit this really shouldn't be this way around :p
     
  8. hardikk

    hardikk New Member

    Joined:
    May 15, 2009
    Messages:
    6
    Likes Received:
    0
    Trophy Points:
    0
    where i can download the KxAudioDriver source's ? ?? i need recopmpile it for 64 bit !
     
  9. Oxtie

    Oxtie Active Member

    Joined:
    May 14, 2008
    Messages:
    137
    Likes Received:
    0
    Trophy Points:
    26
    Nope, no one can get it :p
     
  10. Bekoff

    Bekoff New Member

    Joined:
    Aug 28, 2008
    Messages:
    11
    Likes Received:
    0
    Trophy Points:
    0
    Îòâåò: bug reports for OS X driver 1.2b1

    Hi! But sorry for my English..
    When I start Logic Pro 8 now is get the window like;
    Logic Error.gif
    Report.gif
    Code:
    Process:         Logic Pro [207]
    Path:            /Applications/Logic Pro.app/Contents/MacOS/Logic Pro
    Identifier:      com.apple.logic.pro
    Version:         8.0.0 (1437.23)
    Build Info:      Logic-14372300~12
    Code Type:       X86 (Native)
    Parent Process:  launchd [118]
    
    Date/Time:       2009-07-09 18:32:16.511 +0500
    OS Version:      Mac OS X 10.5.5 (9F33)
    Report Version:  6
    
    Exception Type:  EXC_BAD_ACCESS (SIGSEGV)
    Exception Codes: KERN_PROTECTION_FAILURE at 0x00000000bf7ffffc
    Crashed Thread:  0
    
    Thread 0 Crashed:
    0   com.apple.AppKit              	0x908ba670 -[NSView _convertRectToSuperview:] + 5
    1   com.apple.AppKit              	0x908ba5cb -[NSView _convertRect:toAncestor:] + 92
    2   com.apple.AppKit              	0x908ba62c -[NSView _convertRect:toAncestor:] + 189
    3   com.apple.AppKit              	0x908ba62c -[NSView _convertRect:toAncestor:] + 189
    4   com.apple.AppKit              	0x908ba62c -[NSView _convertRect:toAncestor:] + 189
    5   com.apple.AppKit              	0x908ba62c -[NSView _convertRect:toAncestor:] + 189
    6   com.apple.AppKit              	0x908ba62c -[NSView _convertRect:toAncestor:] + 189
    7   com.apple.AppKit              	0x908ba62c -[NSView _convertRect:toAncestor:] + 189
    8   com.apple.AppKit              	0x908ba42b -[NSView convertRect:toView:] + 226
    9   com.apple.AppKit              	0x90965c95 -[NSView _setKeyboardFocusRingNeedsDisplayInRect:force:] + 192
    10  com.apple.AppKit              	0x90965bce -[NSView setKeyboardFocusRingNeedsDisplayInRect:] + 70
    11  com.apple.prokit              	0x021c2567 -[NSProSegmentedScrubber setNeedsDisplayInRect:] + 151
    12  com.apple.AppKit              	0x90965bce -[NSView setKeyboardFocusRingNeedsDisplayInRect:] + 70
    13  com.apple.prokit              	0x021c2567 -[NSProSegmentedScrubber setNeedsDisplayInRect:] + 151
    14  com.apple.AppKit              	0x90965bce -[NSView setKeyboardFocusRingNeedsDisplayInRect:] + 70
    15  com.apple.prokit              	0x021c2567 -[NSProSegmentedScrubber setNeedsDisplayInRect:] + 151
    16  com.apple.AppKit              	0x90965bce -[NSView setKeyboardFocusRingNeedsDisplayInRect:] + 70
    17  com.apple.prokit              	0x021c2567 -[NSProSegmentedScrubber setNeedsDisplayInRect:] + 151
    18  com.apple.AppKit              	0x90965bce -[NSView setKeyboardFocusRingNeedsDisplayInRect:] + 70
    19  com.apple.prokit              	0x021c2567 -[NSProSegmentedScrubber setNeedsDisplayInRect:] + 151
    20  com.apple.AppKit              	0x90965bce -[NSView setKeyboardFocusRingNeedsDisplayInRect:] + 70
    21  com.apple.prokit              	0x021c2567 -[NSProSegmentedScrubber setNeedsDisplayInRect:] + 151
    22  com.apple.AppKit              	0x90965bce -[NSView setKeyboardFocusRingNeedsDisplayInRect:] + 70
    23  com.apple.prokit              	0x021c2567 -[NSProSegmentedScrubber setNeedsDisplayInRect:] + 151
    24  com.apple.AppKit              	0x90965bce -[NSView setKeyboardFocusRingNeedsDisplayInRect:] + 70
    25  com.apple.prokit              	0x021c2567 -[NSProSegmentedScrubber setNeedsDisplayInRect:] + 151
    26  com.apple.AppKit              	0x90965bce -[NSView setKeyboardFocusRingNeedsDisplayInRect:] + 70
    27  com.apple.prokit              	0x021c2567 -[NSProSegmentedScrubber setNeedsDisplayInRect:] + 151
    28  com.apple.AppKit              	0x90965bce -[NSView setKeyboardFocusRingNeedsDisplayInRect:] + 70
    29  com.apple.prokit              	0x021c2567 -[NSProSegmentedScrubber setNeedsDisplayInRect:] + 151
    30  com.apple.AppKit              	0x90965bce -[NSView setKeyboardFocusRingNeedsDisplayInRect:] + 70
    31  com.apple.prokit              	0x021c2567 -[NSProSegmentedScrubber setNeedsDisplayInRect:] + 151
    32  com.apple.AppKit              	0x90965bce -[NSView setKeyboardFocusRingNeedsDisplayInRect:] + 70
    33  com.apple.prokit              	0x021c2567 -[NSProSegmentedScrubber setNeedsDisplayInRect:] + 151
    34  com.apple.AppKit              	0x90965bce -[NSView setKeyboardFocusRingNeedsDisplayInRect:] + 70
    35  com.apple.prokit              	0x021c2567 -[NSProSegmentedScrubber setNeedsDisplayInRect:] + 151
    36  com.apple.AppKit              	0x90965bce -[NSView setKeyboardFocusRingNeedsDisplayInRect:] + 70
    37  com.apple.prokit              	0x021c2567 -[NSProSegmentedScrubber setNeedsDisplayInRect:] + 151
    38  com.apple.AppKit              	0x90965bce -[NSView setKeyboardFocusRingNeedsDisplayInRect:] + 70
    39  com.apple.prokit              	0x021c2567 -[NSProSegmentedScrubber setNeedsDisplayInRect:] + 151
    40  com.apple.AppKit              	0x90965bce -[NSView setKeyboardFocusRingNeedsDisplayInRect:] + 70
    41  com.apple.prokit              	0x021c2567 -[NSProSegmentedScrubber setNeedsDisplayInRect:] + 151
    42  com.apple.AppKit              	0x90965bce -[NSView setKeyboardFocusRingNeedsDisplayInRect:] + 70
    43  com.apple.prokit              	0x021c2567 -[NSProSegmentedScrubber setNeedsDisplayInRect:] + 151
    44  com.apple.AppKit              	0x90965bce -[NSView setKeyboardFocusRingNeedsDisplayInRect:] + 70
    45  com.apple.prokit              	0x021c2567 -[NSProSegmentedScrubber setNeedsDisplayInRect:] + 151
    46  com.apple.AppKit              	0x90965bce -[NSView setKeyboardFocusRingNeedsDisplayInRect:] + 70
    47  com.apple.prokit              	0x021c2567 -[NSProSegmentedScrubber setNeedsDisplayInRect:] + 151
    48  com.apple.AppKit              	0x90965bce -[NSView setKeyboardFocusRingNeedsDisplayInRect:] + 70
    49  com.apple.prokit              	0x021c2567 -[NSProSegmentedScrubber setNeedsDisplayInRect:] + 151
    50  com.apple.AppKit              	0x90965bce -[NSView setKeyboardFocusRingNeedsDisplayInRect:] + 70
    51  com.apple.prokit              	0x021c2567 -[NSProSegmentedScrubber setNeedsDisplayInRect:] + 151
    52  com.apple.AppKit              	0x90965bce -[NSView setKeyboardFocusRingNeedsDisplayInRect:] + 70
    53  com.apple.prokit              	0x021c2567 -[NSProSegmentedScrubber setNeedsDisplayInRect:] + 151
    54  com.apple.AppKit              	0x90965bce -[NSView setKeyboardFocusRingNeedsDisplayInRect:] + 70
    55  com.apple.prokit              	0x021c2567 -[NSProSegmentedScrubber setNeedsDisplayInRect:] + 151
    56  com.apple.AppKit              	0x90965bce -[NSView setKeyboardFocusRingNeedsDisplayInRect:] + 70
    57  com.apple.prokit              	0x021c2567 -[NSProSegmentedScrubber setNeedsDisplayInRect:] + 151
    58  com.apple.AppKit              	0x90965bce -[NSView setKeyboardFocusRingNeedsDisplayInRect:] + 70
    59  com.apple.prokit              	0x021c2567 -[NSProSegmentedScrubber setNeedsDisplayInRect:] + 151
    60  com.apple.AppKit              	0x90965bce -[NSView setKeyboardFocusRingNeedsDisplayInRect:] + 70
    61  com.apple.prokit              	0x021c2567 -[NSProSegmentedScrubber setNeedsDisplayInRect:] + 151
    62  com.apple.AppKit              	0x90965bce -[NSView setKeyboardFocusRingNeedsDisplayInRect:] + 70
    63  com.apple.prokit              	0x021c2567 -[NSProSegmentedScrubber setNeedsDisplayInRect:] + 151
    64  com.apple.AppKit              	0x90965bce -[NSView setKeyboardFocusRingNeedsDisplayInRect:] + 70
    65  com.apple.prokit              	0x021c2567 -[NSProSegmentedScrubber setNeedsDisplayInRect:] + 151
    66  com.apple.AppKit              	0x90965bce -[NSView setKeyboardFocusRingNeedsDisplayInRect:] + 70
    67  com.apple.prokit              	0x021c2567 -[NSProSegmentedScrubber setNeedsDisplayInRect:] + 151
    68  com.apple.AppKit              	0x90965bce -[NSView setKeyboardFocusRingNeedsDisplayInRect:] + 70
    69  com.apple.prokit              	0x021c2567 -[NSProSegmentedScrubber setNeedsDisplayInRect:] + 151
    
    

    Russian speaking peoples! Please, help me here..
     
    Last edited: Jul 19, 2009
  11. bionikl

    bionikl New Member

    Joined:
    Jan 15, 2006
    Messages:
    4
    Likes Received:
    0
    Trophy Points:
    0
    Hi eugene, i work on a audigy 2 z gamer edition and mac os x 10.5.3 and i can work using logic audio or anything else, works great your super kx driver.

    i updated to mac os x 10.5.4...and logic audio 8 says no sync, audio and midi so i can´t work anymore.

    i´ve tried mac os x 10.5.5, and same problem...
    i don´t know what kind of info u need to fix it...

    thanks again Kx driver is the best, i use it under win xp and win vista, great work too.
     
  12. gaetanfo

    gaetanfo New Member

    Joined:
    Jul 10, 2009
    Messages:
    1
    Likes Received:
    0
    Trophy Points:
    0
    Re : bug reports for OS X driver 1.2b1

    Where can I get that driver ?
    TIA
     
  13. Bekoff

    Bekoff New Member

    Joined:
    Aug 28, 2008
    Messages:
    11
    Likes Received:
    0
    Trophy Points:
    0
    Îòâåò: Re : bug reports for OS X driver 1.2b1

    Go and download!
     
  14. wmb

    wmb New Member

    Joined:
    Jul 19, 2009
    Messages:
    1
    Likes Received:
    0
    Trophy Points:
    0
    Hi there,

    Using 1.2b1 I'm encountering the following problems:

    -All Cider- based games don't output on the right speaker. Other apps/games work perfectly
    -Mail.app doesn't produce any sounds w/ this driver. Onbourd sound and Mail.app works well
    -Sometimes (very seldom) audio gets distorted or completely muted.

    Hardware:
    SB Live! Player 1024
    EP45-DS3L
    4GB RAM
    E7400 Processor

    Software:
    OSX 10.5.7 (Vanilla Kernel)
     
    Last edited: Jul 20, 2009
  15. Eugene Gavrilov

    Eugene Gavrilov kX Project Lead Programmer and Coordinator

    Joined:
    Dec 7, 2002
    Messages:
    3,146
    Likes Received:
    9
    Trophy Points:
    48
    Îòâåò: Re: bug reports for OS X driver 1.2b1

    your card needs a different firmware...
    please search linux communities or ALSA [linux] driver source code
    I have no access to E-DSP firmwares [from E-mu], and I'm using ALSA GPL-covered firmware binaries. The ones bundled with the kX driver are found in edspctrl source code (see kX SDK for Windows).

    so, you need to check if your problem is solved in Linux world, if yes, find the firmware, compile it into edspctrl and check it. If it works, send the firmware to me to be included with the next driver release

    it seems that there were several new hardware revisions of E-DSP cards that would require different FPGA firmware binaries

    E.
     

Share This Page

visited