Can't install PAX Drivers/Suite for my Titanium Fatal1ty Professional

Discussion in 'PAX Drivers' started by soluu, Aug 12, 2010.

  1. soluu

    soluu New Member

    Joined:
    Aug 12, 2010
    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    0
    Heyho!

    Looking to get the drivers working now for more then 24 Hours :(.
    I checked nearly every thread here but i couldn find a solution yet.

    Yesterday i reinstalled my Windows from W7 Ultimate 32bit to W7 Ultimate 64bit. Drivers worked fine with 32bit version of windows but got problems over problems with W7 64. I nearly tried every driver (Ofcourse cleaned reg, installationfiles n stuff before and after every de/installation.)

    The Problem is that few Versions put out I-001 Errors, DoInstall Errors such as

    Creative Produkt Registration:
    Error=I-001 C:\Users\Admin\Downloads\PAX PCIe XFI Creative Titanium Suite 2010(2)\CTShared\WinDir not found.

    Soundblaster X-Fi:
    Warning=I-012 DoInstall fails to launch C:\Users\Admin\Downloads\PAX PCIe XFI Creative Titanium Suite 2010(2)\Audio\Register\SETUP.INX. DoInstall return error code is -2147213312.
    Warning=I-012 DoInstall fails to launch C:\Users\Admin\Downloads\PAX PCIe XFI Creative Titanium Suite 2010(2)\Audio\Register\SETUP.INX. DoInstall return error code is -2147213312.
    Error=I-001 C:\Users\Admin\Downloads\PAX PCIe XFI Creative Titanium Suite 2010(2)\Audio\Setup\..\..\MTB6\Setup.iss not found.

    Sometimes the Drivers continue to install but dont finish, they just close always at like 80-90%. Otherwise they just open and open new installation windows untill i got like 20. then im frustrated and kill the setup32 progress :(

    Even if the Drivers dont pass 100% few drivers get installed as an example im able to start the Volume Panel but thats all. if i want to start console launcher or ANY other tool it gives me an errormessage like "no audio device found."

    havent changed anything in bios, computer or smth. thats why i dont get why it works with 32bit version but not with 64bit.

    really need help. im frustrated as fuck =(
     
  2. jbl2226h

    jbl2226h New Member

    Joined:
    Feb 3, 2008
    Messages:
    33
    Likes Received:
    0
    Trophy Points:
    0
    Same problem here,somehow i managed to install it but half of the softwer doesen't work,good thing i have sound and its nice :)
     
  3. soluu

    soluu New Member

    Joined:
    Aug 12, 2010
    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    0
  4. Robert McClelland

    Robert McClelland I'm An Uncle for 2nd time Staff Member

    Joined:
    Jun 25, 2002
    Messages:
    15,327
    Likes Received:
    253
    Trophy Points:
    108
    Hi soluu How long ago you formated? If could be hard drive error issue. You muss have clean installed on the suite and used driver sweaper or paid net cleaner one. Please download the dvd suite one. I be releasing new set soon :).
     
  5. soluu

    soluu New Member

    Joined:
    Aug 12, 2010
    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    0
    well i installed windows 7 5 days ago and installed your drivers at the same day. dont think thats going to be the problem. but it works now even if i dont know why so its ok :)

    pretty nice bass actually. love it with beyerdynamic mmx-300 :D
     
  6. Robert McClelland

    Robert McClelland I'm An Uncle for 2nd time Staff Member

    Joined:
    Jun 25, 2002
    Messages:
    15,327
    Likes Received:
    253
    Trophy Points:
    108
    thanks wait for the new driver release reason why I don't release driver set yet I want get the tweaks working prefect first. once they do I get the driver sets going again.
     
  7. thedemon

    thedemon New Member

    Joined:
    Jul 4, 2003
    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    0
    I am having a similar issue.

    That is exactly what is happening for me, only the install will only get to 13%.

    I reformatted yesterday and installed Windows 7 64bit.

    It's the same if I use PAX PCIe XFI PAX Audio Suite DVD 2010 V2.00 or PAX PCIe XFI PAX Audio Suite DVD 2010 V3.00.
     
  8. Robert McClelland

    Robert McClelland I'm An Uncle for 2nd time Staff Member

    Joined:
    Jun 25, 2002
    Messages:
    15,327
    Likes Received:
    253
    Trophy Points:
    108
    ya wait for something special coming soon you won't need the suite now :). I got PCI E drivers too.
     
  9. thedemon

    thedemon New Member

    Joined:
    Jul 4, 2003
    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    0
    Sounds good. :)

    It is always a battle to get everything working right in Windows 7 with the x-fi, and the official drivers have been completely useless, so I appreciate the work you have put into this to make things work. One way or the other I know this will get sorted.

    Funny thing is, the drivers which worked for my last install didn't work this time, so that leads me to believe something on my side may be the culprit.
     

Share This Page

visited