Can't install PCIe Titanium Fatality Champion Series

Discussion in 'PAX Download - PCIe X-Fi Series' started by Jorgee!, Feb 19, 2012.

  1. Jorgee!

    Jorgee! New Member

    Joined:
    Mar 19, 2011
    Messages:
    12
    Likes Received:
    0
    Trophy Points:
    0
    Hi, my card wont get recognized... its always the same thing i dont know why.

    I have XFI PCI-e Titanium fatality champion series...

    I've downloaded PAX MASTER PCIe Titanium Driver Suite V1.30.7z

    Installed from ./setup.exe and then i got no sound, sound icon with X.

    I ran ./drivers/setup.exe and installed WDM drivers replacing shared drivers or something like that, and don't have sound.

    After some tries installing the same drivers got sound from Windows 7 default drivers i think...

    In Devices manager i have High Definition Audio device, and before the uninstall i had X-FI SB or something like that.

    Any help? Do I have to install something else so my card gets recognized as X-fi SB?
     
  2. Robert McClelland

    Robert McClelland I'm An Uncle for 2nd time Staff Member

    Joined:
    Jun 25, 2002
    Messages:
    15,327
    Likes Received:
    253
    Trophy Points:
    108
    What your device id?
     
  3. Jorgee!

    Jorgee! New Member

    Joined:
    Mar 19, 2011
    Messages:
    12
    Likes Received:
    0
    Trophy Points:
    0
    PCI\VEN_1102&DEV_000B&SUBSYS_00431102&REV_03
    PCI\VEN_1102&DEV_000B&SUBSYS_00431102
    PCI\VEN_1102&DEV_000B&CC_040300
    PCI\VEN_1102&DEV_000B&CC_0403


    Which is the titanium fatality champion series

    I got the card recognized by running ./drivers/setup.exe of PAX PCI XFI ALL OS Driver V4.05.7z

    [​IMG]
     
    Last edited: Feb 19, 2012
  4. Robert McClelland

    Robert McClelland I'm An Uncle for 2nd time Staff Member

    Joined:
    Jun 25, 2002
    Messages:
    15,327
    Likes Received:
    253
    Trophy Points:
    108
    Did you try installed threw WDM installer in driver folder?
     
  5. Jorgee!

    Jorgee! New Member

    Joined:
    Mar 19, 2011
    Messages:
    12
    Likes Received:
    0
    Trophy Points:
    0
    Yes, like I sad in the first post I ran ./setup and then ./drivers/setup.exe
     
  6. Robert McClelland

    Robert McClelland I'm An Uncle for 2nd time Staff Member

    Joined:
    Jun 25, 2002
    Messages:
    15,327
    Likes Received:
    253
    Trophy Points:
    108
    How strange did you formated long ago just like to know?
     
  7. Comp

    Comp New Member

    Joined:
    May 21, 2009
    Messages:
    18
    Likes Received:
    0
    Trophy Points:
    0
    Having the same issue as the guy above and I have the exact same device ID. I once posted on here a long while back with issues relating to the installer not working and you added the device id of my card so the installer worked. I decided recently to update my drivers again and now the installer doesn't work quitting out saying "Driver not found".
     

Share This Page

visited