Computer won't turn on

Discussion in 'Hardware Discussion & Support' started by Louiemaster, Sep 13, 2007.

  1. Louiemaster

    Louiemaster Masto Commando

    Joined:
    Feb 3, 2004
    Messages:
    295
    Likes Received:
    0
    Trophy Points:
    26
    Long story short, my computer wouldn't turn on anymore after a hard reset. However, if I left it plugged in, it would spontaneously turn on but wouldn't POST. All the fans would come on, along with the lights. It wouldn't respond to the power button and I've checked all the cables along with buying a new PSU.

    My question is, could my motherboard have been fried by my old PSU? And is there any way to check this without buying a new one. Also, could my CPU, RAM, or Video Card have been fried too?
     
  2. Judas

    Judas Obvious Closet Brony Pony

    Joined:
    May 13, 2002
    Messages:
    39,846
    Likes Received:
    1,755
    Trophy Points:
    138
    If you purchased a NEW PSU and it didn't resolve the problem.. it is likely your motherboard..

    best way to test this is to unplug EVERYTHING... only leave the motherboard plugged in... and disconnect the cables for the hardrives or other devices from the motherboard so ONLY the motherboard/CPU/RAM are plugged in (also disconnect the external devices like keyboard/mouse/etc. but leave the Monitor plugged in)..

    See what happens then,

    If same thing, remove the RAM.... try again.... same thing, Try removing the CPU... see what happens... If it repeats yet again, it's definitely a dead motherboard.
     
  3. Teme

    Teme Super Moderator

    Joined:
    Dec 22, 2004
    Messages:
    8,496
    Likes Received:
    175
    Trophy Points:
    73
    Hmm.. I would ad BIOS reset to the do list.
     
  4. procupine14

    procupine14 Why is it Beeping!?!?!

    Joined:
    Apr 10, 2007
    Messages:
    1,396
    Likes Received:
    39
    Trophy Points:
    58
    yeah also try clearing your CMOS and see if it has any affect whatsoever
     
  5. Louiemaster

    Louiemaster Masto Commando

    Joined:
    Feb 3, 2004
    Messages:
    295
    Likes Received:
    0
    Trophy Points:
    26
    Yeah I've reset the CMOS like 20 times before. I'll try slowly taking everything out.
     

Share This Page

visited