DH Mobility Modder V3 released ! (64 bit support)

Discussion in 'Mobility Modder Discussion' started by HardwareHeaven, Sep 16, 2005.

  1. waltervanbergen

    waltervanbergen New Member

    Joined:
    Apr 5, 2006
    Messages:
    5
    Likes Received:
    0
    Trophy Points:
    0
    Hello Patje,

    I went looking for a new driver as mine was quite old, ofcourse no updates from Acer, the laptop I have.

    First the Laptop

    Acer Aspire 1600
    Intel Pentium 4 CPU 2.40GHz
    1 GB RAM
    ATI MOBILITY RADEON 9000 (ATI MOBILITY/RADEON 9000 AGP (0x4C66))
    Driver version number: 6.14.10.6601

    Windows XP Home Edition Service Pack 2 (Build 2600)
    DirectX Version 9.0c

    I've downloaded the newest desktop driver Catalyst 6.3 and the CCC panel and used the DH Mobility Modder V3. My video games seems to be runner smoother and better then before.

    Only big problem is video. When I try to play a wmv file the computer plays the first frame of the movie and the becomes very sloppy and compltely "hangs". I have noticed some other players using the Omega drivers were coping with the same problem. I flashed my bios (one of the solutions provided there) but that didn't work out. I have tweaked the settings a little, removed, cleaned and reinstalled the whole package but the problem is still there. Any ideas?

    Thanks in advance!
     
  2. jrbiers

    jrbiers New Member

    Joined:
    Apr 6, 2006
    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    0
    Lost in downloading processs

    Hello, I tried to follow you instructions, but I lack the skills or information to correctly use the mod. I went to the ATI website and located the current Catalyst download. I downloaded the Microsoft .NET portion, then I began to download the Catalyst Control Center Package. There is a third package listed AVIVO Video Converter, but I never got to that portion because I thought it was the mobility drivers that your instructions warned against. So after downloading the .NET I began the converter, and sure enough just as your instructions stated the prompt stated INF could not be found and setup was incomplete. So I then clicked on your link for the DH MODTOOL 3 and clicked open. The window closed after a few seconds. I began the ATI download again, same result. So, I then clicked on your link but chose SAVE, but have no idea where to save it.



    I am using a Sony Vaio PCG-K25, with 446Mb of Ram using a Intell Pentium 4 2.8 Ghz, which utilizes the ATI Radeon IGP 345M version 6.14.0010.6444. Its main driver is ati2dvag.dll.



    Please forgive me but I am from the typewriter world history and do not understand some of the language used in the forum pages. Thank you for your work and time considering my problem.



    Sam
     
  3. waltervanbergen

    waltervanbergen New Member

    Joined:
    Apr 5, 2006
    Messages:
    5
    Likes Received:
    0
    Trophy Points:
    0
    Hi,

    Your problem shouldn't be too hard to solve.

    Download the mod and just save it on your desktop. Install the drivers from ATi and as soon as you get the INF error just press ok. The installation will stop. Just as you experienced.

    Now click on the mod you put on your desktop. It will do everything automitcally. It will check the files and then asks to resume installation. Just click yes and you're done!

    Make sure you use the standard folders when the ATi package asks for where to install in order to use the common file structure.

    To put it simple: just click next and don't change directories by clicking browse. Should be typewriter proof :D
     
  4. jrbiers

    jrbiers New Member

    Joined:
    Apr 6, 2006
    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    0
    Thank you very much for taking the time to help. After the INF notice and the Setup incomplete notice, I clicked on the mod I put on my desktop. But then I get error message
    C:\DocumentsandSettings\Sam\Desktop\DHmodtool3.exe is not a valid Win32 application.

    Did I interpret you instructions to literal and I should have saved it elsewhere??

    Sam
     
  5. waltervanbergen

    waltervanbergen New Member

    Joined:
    Apr 5, 2006
    Messages:
    5
    Likes Received:
    0
    Trophy Points:
    0
    Mmm thats strange indeed. You are using windows XP right? Guess you must be as your specs doesnt seem that old.

    Remove the modder from your desktop by deleting it.

    Try downloading the modder again from http://www.driverheaven.net/patje/files/DHmodtool3.exe

    and save it to your desktop again. Double click again to see if you still get the error. Maybe the file got corrupted during the download.

    Otherwise a real specialist needs to answer your question.

    Btw anyone any idea why I still have lagging video's? Can't get it solved :(
     
  6. patje

    patje Former Mobility Modman

    Joined:
    Oct 16, 2002
    Messages:
    1,475
    Likes Received:
    0
    Trophy Points:
    0
    Walter,

    Can you try playing the wmv's with a different player?
    VideoLAN for example is a free and very good player which might not be affected with the problem

    Hope that helps
    Groetjes
    Patje
     
  7. jrbiers

    jrbiers New Member

    Joined:
    Apr 6, 2006
    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    0
    Okay, I found at least one source of the problem: an unknown spyware program was running during the download of the mod. So after eliminating that spyware program I reloaded the Mod. Then ATI drivers. At the INF failure, I went to the Mod (now actually appearing as a desktop icon in windows format not DOS), and opened it. New error: "Component 'Richtx32.ocx' or one of its dependencies not correctly registered: a file is missing or invalid." Any ideas?? Thanks again.
     
  8. Spinnacre

    Spinnacre New Member

    Joined:
    Apr 12, 2006
    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    0
    Easing your Richtx.OCX pains

    I've just installed Win x64 and followed all prior suggestions toward fixing the error about Richtx.OCX missing or not registered, with no success.

    So, on another forum (Wilders Security), I found a solution that worked for me and it should work for all other Windows versions:

    So, thanks Javacool! And, of course, MANY thanks to Patje for this mod! Now, I have to go see if I can get this annoying 200M to install...
     
  9. Spinnacre

    Spinnacre New Member

    Joined:
    Apr 12, 2006
    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    0
    Anyone having trouble with a link to Catalyst, have you tried using ATI Tray Tools? It was suggested somewhere else.

    Oh, I got the drivers for my Radeon Mobility X200 (in an HP zv6007 widescreen laptop) installed in Windows XP x64, but not by using the DH Mobility Mod (maybe beause it's not in the supported adapter list :hmm: ) , but I did manage to get it installed manually using the Update Driver feature.

    I got into detail in a post at PlanetAMD64 here for all the noobies. Honestly, the DH Mod may have played a part in my eventual success, but I don't feel like trying to recreate my success to prove it... because it's late. And I have no idea what it atually does... But thanks again everyone.
     
  10. Jorg40

    Jorg40 New Member

    Joined:
    Apr 16, 2006
    Messages:
    4
    Likes Received:
    0
    Trophy Points:
    0
    ATI MOBILITY RADEON 9200

    I really need support for that, so does other 9200 users, we cant play HL2 and some of us like me are Game Developers and CG Artist/Animator.

    I havent updated my driver since 2004, and I get an INF error when trying to install Cat 6.3
    (it always has been like this, that I couldnt update... my laptop manufacturer says I should contact ATi and so I did, but they say that they dont have support for Mobility any longer)

    If you would be so cool/kind/smart/super nice to help me get the newest drivers into my conputer you will be listed and credited wherever I make a game or CG movie.

    Greetings from Norway.
     
  11. waltervanbergen

    waltervanbergen New Member

    Joined:
    Apr 5, 2006
    Messages:
    5
    Likes Received:
    0
    Trophy Points:
    0
    Hi Patje,

    I'm sorry to say that Video Lan suffers the same problems, no video playback and the computer totally "freezes". Only a hard reboot will get it going again. I deinstalled version 10 of WMP too, but that didnt have any effect either. Think there is something in the Catalyst driver my video card can't handle.

    Groeten
    Walter
     
  12. herting

    herting New Member

    Joined:
    Nov 3, 2005
    Messages:
    1
    Likes Received:
    0
    Trophy Points:
    0
    I'm having the same problem as you, waltervanbergen, if anybody knows how to make it so watching a video won't kill my system I would appreciate the help. I have had similar problems with the Omega Drivers which finally compelled me to not use them.

    Never going to buy another ATI product after spending the last 1.5 years hitting my head up against this sort of crap every couple weeks.
     
  13. pbx

    pbx New Member

    Joined:
    Apr 24, 2006
    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    0
    ATI Radeon Mobility 9200 64MB

    Hi,

    I'm having problems with my ATI radeon mobility 9200 (64MB) video card in my HP pavilion zt3000.
    I dont know what else I need to do to install last version of the drivers. The last drivers from HP simply do not work.
    Then I tried the drivers from ATI but I got this "inf error" message. Then I used program dhmood, but after the installation when I resarted the computer the screen became fuzzy.
    I contacted HP support with no positive results (after the failure of every solution, they even told me to reinstall my operating system!). Then I contacted ATI and they told me to contact HP :mad: .
    Finally I found omegadrivers but after the installation I get a black screen :tears: .
    I need at least the version 6.14.10.6525 to play Project Entropia for example. But the only working version is 6.14.10.6451 (previous from the last) provided by HP.
    Can someone please help???
    Thanks in advance,

    pbx
     
    Last edited: Apr 25, 2006
  14. Moskie

    Moskie New Member

    Joined:
    Apr 26, 2006
    Messages:
    1
    Likes Received:
    0
    Trophy Points:
    0
    I probably already know the answer, but I'll give it one last shot: will this tool let me set up multiple displays on my laptop? I'd like to extend my desktop over one external monitor and my laptop screen. I have a Dell Latitude D610 with a Mobility X300, running Win2k.

    Every thing I've read leads me to believe this is impossible, but I'd really, really like to do it. Does this tool help with this?
     
  15. HardwareFee

    HardwareFee New Member

    Joined:
    Nov 21, 2004
    Messages:
    6
    Likes Received:
    0
    Trophy Points:
    0
    It's possible in my opinion. My laptop has got an older Mobility 9600 and in Catalyst Control Center I can set up to extend the desktop over my external CRT and the internal widescreen display or a TV screen and the internal display. Also I can clone the desktop, so it looks the same on both screens.

    You only should use actual ATI drivers (this tool can help you getting them to work) and voilá! Older driver version usually work too, but newer is better.
     
  16. nvrnuff

    nvrnuff New Member

    Joined:
    May 3, 2006
    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    0
    I just applied the DH mobility modder to my gateway m280e tablet (x600 se gfx) and it works great. Noticeable speed improvement. But it disables my ability to change my screen orientation. Does anyone know of a workaround for this? I would manipulate the inf files myself, but I'm dumb so I can't. I would even settle for a third party program that does it.
     
  17. waltervanbergen

    waltervanbergen New Member

    Joined:
    Apr 5, 2006
    Messages:
    5
    Likes Received:
    0
    Trophy Points:
    0
    Hi,

    Still having problems with sloppy video (or even worse, my computer totally stops functioning) when I try to play any kind of video.

    Acer Aspire 1600
    Intel Pentium 4 CPU 2.40GHz
    1 GB RAM
    ATI MOBILITY RADEON 9000 (ATI MOBILITY/RADEON 9000 AGP (0x4C66))
    Driver version number: 6.14.10.6601

    Windows XP Home Edition Service Pack 2 (Build 2600)
    DirectX Version 9.0c

    Discussed the problem in detail at page 7.

    If someone has been able to solve this problem I would love to here about it!

    Thanks, Walter
     
  18. Kurai

    Kurai New Member

    Joined:
    May 5, 2006
    Messages:
    1
    Likes Received:
    0
    Trophy Points:
    0
    ok here is my question. I'm running this
    Gateway laptop
    AMD 64 4000+ with Win XP sp2 32 bit
    Mobility X600
    My Display Versions>
    2D Vers. 6.14.10.6553
    Control panel: 6.14.10.5157

    nothing else is needed
    anyway I downloaded the latest version from ATI the catalysts 6.4 i followed everything and managed to install it smoothly, however when my comp booted to finish the install it reacted unstable and before the logon screen came the famous Blue Screen of Death appeared and my Laptop rebooted, i tried a second time nothing so i just chose the last know con to boot and it restoed it. so here is my Q. is it safer doe a laptop such as mine to have the drivers uninstalled first then install the new ones or is it simpler to go to my system manager on display drivers and just updated them through there. without causing my system to have a display crash.
     
  19. mcp_2

    mcp_2 New Member

    Joined:
    May 18, 2006
    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    0
    Hi I have a problem. The CCC installer still says it's looking for the INF file even after I run your mod tool.

    Toshiba Satellite A85 Notebook
    ATI Radeon Mobility 9000 IGP
    Windows XP sp 2 or something higher

    The CCC I got was under Drivers and Software -> Windows XP -> RADEON -> Catalyst 6.4

    I also tried with v 6.3
    This is NOT the IGP or the mobility CCC installer as the instructions state.

    0. Delete the C:\ATI folder and everything in them.
    1. I run the extractor/installer. Errors as predicted asking for INF file and the other generic error message.
    2. I run the mod tool clicking on go mobile after it has selected C:\ati
    3. Run the installer to get: INF error: Video Driver not found.

    How can I deal with this? Or do I even want to with my 9000 IGP?

    Thanks

    edit:
    Under device manager:
    Device Instance:
    PCI\VEN_1002&DEV_7835&SUBSYS_FF001179&REV_00\4&20BA39E9&0&2808
    Hardware ID:
    PCI\VEN_1002&DEV_7835&SUBSYS_FF001179&REV_00
    PCI\VEN_1002&DEV_7835&SUBSYS_FF001179
    PCI\VEN_1002&DEV_7835&CC_030000
    PCI\VEN_1002&DEV_7835&CC_0300
     
    Last edited: May 18, 2006
  20. patje

    patje Former Mobility Modman

    Joined:
    Oct 16, 2002
    Messages:
    1,475
    Likes Received:
    0
    Trophy Points:
    0

Share This Page

visited