E-MU 1616 driver (working inputs!!!)

Discussion in 'MAC OS X Driver' started by >Alejandro, Apr 15, 2018.

  1. >Alejandro

    >Alejandro New Member

    Joined:
    Mar 14, 2018
    Messages:
    19
    Likes Received:
    3
    Trophy Points:
    3
    No. I added support for multiple sound cards in 2021, just didn't post it.
     
    Last edited: Jul 23, 2022
  2. ITzTravelInTime

    ITzTravelInTime New Member

    Joined:
    Oct 14, 2018
    Messages:
    12
    Likes Received:
    2
    Trophy Points:
    3
    Coincidently i just added multiple cards support to my fork too and i pushed the updated source code on github, now you can use the individual sound cards on macos and they will show up in system preferences and other software individually like in the attached picture of midi audio setup on my test rig.

    BTW we should chat provately somewhere about development of the kx audio driver since we are the most active developers on it.

    7369A94A-8268-4A09-8437-BC8D489FA27F.jpeg
     
  3. >Alejandro

    >Alejandro New Member

    Joined:
    Mar 14, 2018
    Messages:
    19
    Likes Received:
    3
    Trophy Points:
    3
    I read about it on the insanelymac forum and decided to post it too since I haven't done it for a long time.
    If you think I've used your code, take a look here. This is an ac97 application where two sound cards are visible in the tab. It was in March.

    What card do you have, 1212, 1616 or 1820?
    I remember you had 0404 which didn't work, still doesn't work?
     
    Last edited: Jul 24, 2022
  4. ITzTravelInTime

    ITzTravelInTime New Member

    Joined:
    Oct 14, 2018
    Messages:
    12
    Likes Received:
    2
    Trophy Points:
    3
    Actually in the ac97 app it just shows the user clients and not the usable audio engines, the actual issue was that only one audio engine did show up and was actually usable because of a audio engine uid issue (basically all the engines created by the driver had the same uid) so last week i just added different uids for each engine based on their io port address (since that's unique to each card), and that allows for each engine to be used le individually. This is a fix you should use too and you can find it in the powerpc branch of my repo, here:

    https://github.com/ITzTravelInTime/kx-audio-driver/tree/PPC_Experimental

    For the sound cards i got a 1212m for cheap to use as a test card, and that's what you see in the picture. For the 0404 cards i suspect it's some issue with the fpga programming tool btw, because the programming fails consistently across the oses, cpu architectures and sound cards on both 0404.
     
  5. >Alejandro

    >Alejandro New Member

    Joined:
    Mar 14, 2018
    Messages:
    19
    Likes Received:
    3
    Trophy Points:
    3
    As I said, this is already implemented in my version of the driver. audio devices.png

    0404 works in Windows?
     
  6. peate

    peate Active Member

    Joined:
    Oct 31, 2003
    Messages:
    523
    Likes Received:
    21
    Trophy Points:
    28
    When are you releasing kX for Android??? :cool: :p
    Just kiddin', but it would be nice. I listen to so much music on my tablet.
     

Share This Page

visited