First Official Nvidia Omega Drivers release!!! (2k/XP)

Discussion in 'NVIDIA Graphics Cards' started by Omegadrive, Jul 7, 2002.

  1. Haloeighty8

    Haloeighty8 New Member

    Joined:
    Jul 9, 2002
    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    0
    Just installed the drivers right now and personally I think they look excellent!. I played some MOH:AA and it looks great! :) sure there is a price to pay for the image quality but who cares, I think I lost 400 points in 3dMark2k1SE. I just wanted to run it and see what I got with these drivers, but overall they seem very nice!. As it has been said before "beauty is in the eye of the beholder!". good work Omega, I have been following your drivers since you've putting out drivers for ATI based cards. I finally had it with them and got a ti4600, just couldn't deal with all the driver issues. Not to say your ATI drivers where bad, just didn't care for the way the radeon handled some games. Well I'll go back to messing around with these drivers and see how it goes, I haven't tried any Direct3D games yet.. maybe I shouldn't say anything yet! :) hehe.. nah, I'm sure they will work just fine.

    btw, for those having issues with the refresh 60hz thingie. the only utility that I have found that works with these drivers is Refresh Force. It works really well..

    Refresh Force
     
  2. digitalwanderer

    digitalwanderer Colour Commentator

    Joined:
    May 8, 2002
    Messages:
    5,619
    Likes Received:
    2
    Trophy Points:
    0
    Wow, let's call this a "mixed-bag" reaction.

    I'm using the 9x/me set, so maybe some of this doesn't apply, but some of it does so I felt like throwing some words in this thread.

    I loved the new Omegadrive drivers on most of my 3D-first person shooters & GTA3, but they don't seem to work out so hot on RTS games due to the aliasing. Someone has said it before, but the Omegadrive set is like a specialty coffee. It ain't quite the normal blend...some people will like it better and some people will hate it. If'n you don't like it, don't use them. There is absolutely no need to attack Omegadrive for offering his own custom set of drivers for people to use. Omegadrive has worked hard for a long time to help out people in the 3dfx & ATI world, just because you personally don't like his set is no reason to attack the man!

    I don't mind seeing people saying, "there's too much aliasing" or "these drivers make my games look like sh*t!"; but when I see people calling the O-man a liar and a fraud I get pissed off...

    ...please don't get me pissed off, I'm not having a good day and am just looking for someone to unload on. Don't make it you.

    Dig
     
  3. Lamentation

    Lamentation New Member

    Joined:
    May 17, 2002
    Messages:
    7
    Likes Received:
    0
    Trophy Points:
    0
    I said the coffee bit, but my sof2 crashes to a overbright desktop after a few minutes. Other than that, these drivers are fun. i always bumped up my LOD with other drivers anyway. can anyone play sof2 with these?
     
  4. digitalwanderer

    digitalwanderer Colour Commentator

    Joined:
    May 8, 2002
    Messages:
    5,619
    Likes Received:
    2
    Trophy Points:
    0
    Thanks Lamentation

    I couldn't remember who's words I've been ripping off and was just too pressed for time to go hunting thru the threads. I'll start crediting it to ya. :)

    I got SoF2 to work just fine, but it's under 98se. One of these days I'll re-install XP on my boxes, but I'm still feeling particularly sane today so not quite yet.... :p
     
  5. Ryan_clemens

    Ryan_clemens New Member

    Joined:
    Jul 1, 2002
    Messages:
    23
    Likes Received:
    0
    Trophy Points:
    0
    Refresh

    can the omega drivers be compatible with nvrt? I don't like multires.
    I have emailed nvrt but they did not respond. can these drivers please be like the nvidia drivers refresh rate so they work with amost of the refresh rate fixers?
     
  6. lumpypants

    lumpypants New Member

    Joined:
    Jul 9, 2002
    Messages:
    1
    Likes Received:
    0
    Trophy Points:
    0
    more mhz for memory and gpu in omega drivers?

    trying the omega drivers.
    since i like the look of incresaed LOD in games any way, i like these drivers so-far.

    I just need to know of a way to get a few more mhz out of the "overclock" scale.
    i was using nvmax to overclock my geforce 3 ti200 to 225 core and 525 memory!
    (NOT suposed to use any "tweakers" for these drivers)
    these drivers use the standard "cool-bits" registry numbers which top out at 220core and 500 memory.
    any way to get the "extended' values in this driver?
    I remember way back when there was a cool-bit fix that gave more than the reference drivers would allow
    is there a way to edit the binary values in that registry entry to get that extra mhz?

    THNX in advance for any replys or thoughts!

    using win XP BTW
     
  7. ErwHu

    ErwHu New Member

    Joined:
    Jul 9, 2002
    Messages:
    4
    Likes Received:
    0
    Trophy Points:
    0
    Erwin's Pages testing Omega drvs

    Hi,

    We are currently in the middle of a comparative GF4Ti4200 test. We used the 29.42 yesterday, and I tried these Omegas this morning. We will probably set these drivers under a paragraph in our review, since the differences in quality and speed are subtle yet noticeable. Much appreciated are the increased LOD, which thoroughly shows on higher detail locations and DX8 applications (Morrowind, 3DM2K1 Nature).

    Although we can't really talk of a complete new driverset (it's just an nVidia set with adjusted/forced tweaks) it does the job well (although Omega, you should fix that OpenGL problem so that we do not need to copy the .dll from the original 29.42).

    Cheers and keep up the good work.

    Erwin "Reaper" Husin
    Admin, Editor-in-chief

    Belgian. Passionate. All PC Gaming.
    http://www.erwinspages.tk
     
  8. GREEKRAGE

    GREEKRAGE Guest

    Do you mean the nvoglnt.dll file ????

    Did you get the B version drivers ???

    The A version had that problem but he fixed it in the B version.
     
  9. ldonyo

    ldonyo New Member

    Joined:
    May 9, 2002
    Messages:
    12
    Likes Received:
    0
    Trophy Points:
    0
  10. ErwHu

    ErwHu New Member

    Joined:
    Jul 9, 2002
    Messages:
    4
    Likes Received:
    0
    Trophy Points:
    0
    It was supposedly fixed, but RTCW still malfunctioned. JK2 however worked fine.
     
  11. Enchanter

    Enchanter New Member

    Joined:
    Jun 2, 2002
    Messages:
    7
    Likes Received:
    0
    Trophy Points:
    0
    Does this driver mean much to a GF2 MX? Also, does it help in 2D-quality?
     
  12. shock

    shock New Member

    Joined:
    Jul 12, 2002
    Messages:
    4
    Likes Received:
    0
    Trophy Points:
    0
    Hi,

    first of all: respect to all who create free software - and I'm not talking about free as in beer!

    following situation:

    I just (like 5 hours ago) installed the latest version on my XP - Yes I followed the readme - no I didnt touch the settings (initially).

    When I tried CS - I didnt have a slight drop in performance but went from pretty stable (except when having lots of fog-effects) 99fps down to unstable 50-70... as soon as some more polies (floated aroud a lot in spec mode) enter the scene they would drop down to below 20. :dead: - This is not quite the gaming fun I used to have.

    My Gaming-Sys:
    Athlon 1,4GHz
    512 MB DDR Ram
    nVidia GeForce2 Mx400
    ... blargh... if more is interesting - feel free to ask :p

    so - I tried the forum - read about "dont touch the defaults" - and about "set it to "maximum Image Quality for nwn"... so I set it up and: nwn runs fine - cs still @ low performance.
    Now - I need my frames in ego-shooters :D - so I tried actually messing with the setting (shame on me!) - to no avail. Still no good in performance.
    Ok - back to old drivers - no chance - still no fix in the performance issue - It didn't say Omaga Drivers in the Settings anymore, though.
    Next - reinstalled 29.42's - fine - rearranging icons on desktop - cs: no fix to my problem.

    the question:
    How do I get my old performance back? :confused:
    Are there possible adjustments to make to the driver settings, that I missed on your page? (I parsed the whole thing I think ) ?
    Are there any entries left in the system that need to be removed?
    Are there simply some files that need to be replaced/removed/edited/recompiled?

    I'm gratefull for any help on this ;) - unfortunately when having a problem with win I'm dependent on help - my deb runs fine - even after lots of torture with some home-made-drivers. :)

    cu and thx

    shocky
     
  13. Nequam

    Nequam New Member

    Joined:
    Jul 12, 2002
    Messages:
    5
    Likes Received:
    0
    Trophy Points:
    0
    First of all, I'd like to say that I think this new driver set is absolutely incredible. The improvement in detail is astounding, and well worth the minor drop in performance in my opinion. Thanks for going all out with the quality, Omega! Your driver philosophy rocks! :D

    Now, moving on to the real purpose of this post -- I've been having some stuttering problems with Soldier of Fortune II since I installed these new drivers. It's strange, because the framerate is still always high (between 60 to 100 FPS), and the gameplay is smooth between the stutters.

    I tried setting graphic quality and resolution down to minimal, but I still get the persistent laggy stuttering. Does anyone have any ideas on what might be causing this (and how I can fix it maybe?) Thanks! ;)
     
  14. Omegadrive

    Omegadrive Drivers? What Drivers???

    Joined:
    May 6, 2002
    Messages:
    1,526
    Likes Received:
    3
    Trophy Points:
    0
    shock, if you used the "Add/Remove Programs" method to remove my drivers, then there are no settings left, my driver remove ALL the settings they make upon removal, try using a registry cleaner (like the one in RivaTuner) to see if I missed something, but I'm pretty sure they remove everything.

    Nequam, it could be a program running in the background, when the program asks for CPU time then the stuttering occurs. Open the Task Manager, in the Processes tab,look for a process other than "System Idle Process" using the CPU every few seconds of so, then you'll have the program that is doing it.
     
  15. ATiWillCrumble

    ATiWillCrumble New Member

    Joined:
    Jul 10, 2002
    Messages:
    90
    Likes Received:
    0
    Trophy Points:
    0
    no nononnnnnnnnnnnnnnnnn more

    MUST HAVE REAL DETONATOR DRIVERS AHHHHHHHHHHHH..
     
  16. shock

    shock New Member

    Joined:
    Jul 12, 2002
    Messages:
    4
    Likes Received:
    0
    Trophy Points:
    0
    Re:

    Ok, Ill see to that soon (this weekend I have no time whatsoever) and report the results.

    Actually I'd have preferred a way to run your drivers @ the performanceloss anounced (8-12 on diffenerent sites) ;)

    well - thx for the quick answer.

    shocky

    ps: your drivers spread rather rapidly in the german cs community ;) - just wanted to let u know.
     
  17. shock

    shock New Member

    Joined:
    Jul 12, 2002
    Messages:
    4
    Likes Received:
    0
    Trophy Points:
    0
    *sigh*

    no success...

    I tried all the tools I found to display differences - reg-scan said detonators only installed.

    I followed all the tweaking guides I used before - I tried out all kinds of stuff myself (am rather lueless about win...)

    Still - the only difference I get is:
    With maximum detail and quality it wont go up over 30 fps
    With fewest detail and quality - it still would drop down to 10 :dead:

    soooo... what now?

    has anyone got a patch "install this and your freakin windows might actually give you the performance you need" ?

    Actually it is just like the calculating of polys has gotten worse - if I have few polys on screen - I get sweet 100fps - but one little gun-model and the performance drops like it hasent before.

    Is it possible that the 29.42 is NOT a good deto for the GeForce2 Mx400?

    Can someone recommend one?

    This kindof kills my gaming-time ;)
     
  18. shock

    shock New Member

    Joined:
    Jul 12, 2002
    Messages:
    4
    Likes Received:
    0
    Trophy Points:
    0
    reinstalled omega-driver for xp - the c one

    no change in performance... same fps...
     
  19. K.I.L.E.R

    K.I.L.E.R Kronos, Father of Zeus

    Joined:
    Jul 7, 2002
    Messages:
    162
    Likes Received:
    0
    Trophy Points:
    0
    It seemed faster. (no AF)
     
  20. ATiWillCrumble

    ATiWillCrumble New Member

    Joined:
    Jul 10, 2002
    Messages:
    90
    Likes Received:
    0
    Trophy Points:
    0
    the nvidia drivers are the best.....why make drivers for image quaility? i prefer the speed so at least the game would run. i'm not bothered about image qualitiy as long as it runs and it reasonably good to look at. ;)
     

Share This Page

visited