"Flickering" with driver 8.12.10

Discussion in 'AMD Graphics Cards' started by Tiber, Jun 4, 2005.

  1. Tiber

    Tiber New Member

    Joined:
    Jun 4, 2005
    Messages:
    5
    Likes Received:
    0
    Trophy Points:
    0
    Hi!

    I've installed the drivers 8.12.10 yesterday with XFree86 4.3 for a Radeon 9200. Running at 1280x1024 on a single crt monitor, I have heavy distortions in form of flickering horizontal lines, especially when resizing windows. See attached image or:

    http://www.e-tobi.net/stuff/flicker.jpg

    I'm running out of options now, so any help would be appreceated!

    bye,

    Tobias
    [​IMG]
    [​IMG]
     
    Last edited: Jun 12, 2005
  2. x0ph3r

    x0ph3r New Member

    Joined:
    Dec 22, 2002
    Messages:
    47
    Likes Received:
    0
    Trophy Points:
    0
    My guess would be that your driver isnt installed / configured correctly :) I'd reinstall and reconfigure. I had this same thing happen to me once too, and that was because my driver wasnt configured right, so check your xorg.conf / XF86Config..
     
  3. Tiber

    Tiber New Member

    Joined:
    Jun 4, 2005
    Messages:
    5
    Likes Received:
    0
    Trophy Points:
    0
    I ran fglxconfig several times, installed old driver versions, updated to the new ones - with no success. I have no idea, what config parameter could be wrong.

    The probably relevant parts of the configuration look like this:

    Code:
    Section "Module"
    		Load	"GLcore"
    		Load	"bitmap"
    		Load	"dbe"
    		Load	"ddc"
    		Load	"dri"
    		Load	"extmod"
    		Load	"freetype"
    		Load	"glx"
    		Load	"int10"
    		Load	"record"
    		Load	"speedo"
    		Load	"type1"
    		Load	"vbe"
    		# Load "extmod" but omit DGA extension
    		# (the DGA extension is broken in the fglrx driver)
    		SubSection "extmod"
    				Option "omit xfree86-dga"
    		EndSubSection
    EndSection
    
    Section "Device"
    		Identifier	  "Standardgrafikkarte"
    		Driver		  "fglrx"
    
    		# If X refuses to use the screen resolution you asked for,
    		# uncomment this; see "Bugs and Workarounds" for details.
    		#Option "NoDDC"
    
    		# === Video Overlay for the Xv extension ===
    		Option "VideoOverlay" "on"
    
    		# === OpenGL Overlay ===
    		# Note: When OpenGL Overlay is enabled, Video Overlay
    		#	   will be disabled automatically
    		Option "OpenGLOverlay" "off"
    
    		# === Use internal AGP GART support? ===
    		# If OpenGL acceleration doesn't work, try using "yes" here
    		# and disable the kernel agpgart driver.
    		Option "UseInternalAGPGART" "no"
    EndSection
    
    Section "Monitor"
    		Identifier   "Monitor0"
    		VendorName	  "CTX"
    		ModelName	   "CTX3700"
    		HorizSync 30 - 95 # DDC-probed
    		VertRefresh 50 - 160 # DDC-probed
    		# 1280x1024, 85.0Hz; hfreq=91.15, vfreq=85.02
    		ModeLine "1280x1024"	157.50 1280 1344 1504 1728 1024 1025 1028 1072 +hsync +vsync
    		# 1280x1024, 75.0Hz; hfreq=79.98, vfreq=75.03
    		ModeLine "1280x1024"	135.00 1280 1296 1440 1688 1024 1025 1028 1066 +hsync +vsync
    		# 1280x1024 @ 100.00 Hz (GTF) hsync: 108.50 kHz; pclk: 190.96 MHz
    		ModeLine "1280x1024" 190.96 1280 1376 1520 1760 1024 1025 1028 1085 -HSync +Vsync
    EndSection
    
    Section "Screen"
    		Identifier	  "Default Screen"
    		Device		  "Standardgrafikkarte"
    		Monitor		 "Monitor0"
    		DefaultDepth	24
    		SubSection "Display"
    			 Depth		 1
    			 Modes		 "800x600" "640x480"
    		EndSubSection
    		SubSection "Display"
    			 Depth		 4
    			 Modes		 "800x600" "640x480"
    		EndSubSection
    		SubSection "Display"
    			 Depth		 8
    			 Modes		 "800x600" "640x480"
    		EndSubSection
    		SubSection "Display"
    			 Depth		 15
    			 Modes		 "800x600" "640x480"
    		EndSubSection
    		SubSection "Display"
    			 Depth		 16
    			 Modes		 "800x600" "640x480"
    		EndSubSection
    		SubSection "Display"
    			 Depth		 24
    			 Modes		 "1280x1024" "1024x168" "800x600" "640x480"
    		EndSubSection
    EndSection
    
    Tobias
     
  4. RIV@NVX

    RIV@NVX Freedom is a feature.

    Joined:
    Jul 10, 2002
    Messages:
    4,476
    Likes Received:
    2
    Trophy Points:
    0
    Did this also occur with older drivers (8.8 or 8.10)?
     
  5. Tiber

    Tiber New Member

    Joined:
    Jun 4, 2005
    Messages:
    5
    Likes Received:
    0
    Trophy Points:
    0
    I have the same problem with 8.10.9 and 8.8.25. It even seems to be worse with 8.8.25.

    Probably this is only a matter of the right modline setting, but I have no idea, how to figure this out.

    Tobias
     
  6. RIV@NVX

    RIV@NVX Freedom is a feature.

    Joined:
    Jul 10, 2002
    Messages:
    4,476
    Likes Received:
    2
    Trophy Points:
    0
    Try removing 1280x1024 mode from XF86Config. Does it help?
     
  7. Tiber

    Tiber New Member

    Joined:
    Jun 4, 2005
    Messages:
    5
    Likes Received:
    0
    Trophy Points:
    0
    There's no problem with 1024x768 or 800x600. But everything above (tested up to 1600x1200) causes this strange distortions.

    I just switched to kernel 2.6.11 - just in case. But I still have these annoying flickering horizontal lines :-(

    1280x1024 works fine on Windows or with the standard drivers, that come with XFree 4.3 (but these are pretty slow). I haven't tried DRI yet.

    Tobias
     
  8. rgregory

    rgregory ATI Linux Staff

    Joined:
    Apr 13, 2005
    Messages:
    20
    Likes Received:
    0
    Trophy Points:
    0
    Tobias, how have you been swictching resolutions?

    If you haven't tried already, then you my want to try using the xrandr command. It should allow you to

    a) see what display modes are available (xrandr with no parameters)
    b) set the resolution of your choice (xrandr -s <size>)
    c) set the refresh rate (xrandr -r <rate>)

    It is possible that you are not currently getting an ideal rez/refresh. This could also be because of the horizontal and vertical sync range settings.

    I have found it useful to check your monitor's specs for the exact sync ranges it supports, then enter these values in XF86Config-4 in the "Monitor" section for HorizSync and VertRefresh. (the general ranges suggested in fglrxconfig do not always fit the monitor perfectly)

    PLEASE NOTE: You should NOT have to touch the modelines in XF86config-4 - these are claculted using GTF to provide VESA standard modes only. The actual list of available modes should be determined by your monitor's EDID data when X starts.
     
  9. Tiber

    Tiber New Member

    Joined:
    Jun 4, 2005
    Messages:
    5
    Likes Received:
    0
    Trophy Points:
    0
    Ok. In order to get xrandr to work at all, I had to remove extmod from the Module section. If I run xrandr, I get this:

    Code:
     SZ:    Pixels		  Physical	   Refresh
    *0   1280 x 1024   ( 361mm x 271mm )  *85
     1   1024 x 768	( 361mm x 271mm )   85
     2	832 x 624	( 361mm x 271mm )   75
     3	800 x 600	( 361mm x 271mm )   85
     4	640 x 480	( 361mm x 271mm )   85
    Current rotation - normal
    Current reflection - none
    Rotations possible - normal
    Reflections possible - none
    I can't change the refresh rate with xrandr. Only 85Hz is allowed. Modifying HorizSync and VertRefresh doesn't help either. I don't think, the problem has anything to do with the monitor. It's working pretty fine with 1280x1024@85 Hz on Windows or if I don't use the fglrx driver.

    Maybe I should give XOrg a try. But this is kinda tricky with Debian Sarge :-(

    Tobias
     
  10. rgregory

    rgregory ATI Linux Staff

    Joined:
    Apr 13, 2005
    Messages:
    20
    Likes Received:
    0
    Trophy Points:
    0
    Actually, you used to have to disable the DGA extension to get xrandr to work, but this hs been fixed with 8.14.

    It seems like you should be getting more refresh rate options from xrandr, although I don't know why you're not. Didn't fglrxconfig generate more than three modelines? Did you remove any (I admit I'm grasping)?

    Xorg is nice, but I'll stick with my Debian thanks :)
    It's not worth giving up apt. Now Ubuntu maybe...
     
  11. Kombatant

    Kombatant Active Member

    Joined:
    Apr 11, 2003
    Messages:
    644
    Likes Received:
    9
    Trophy Points:
    28
    You should definitely try Ubuntu, it's a keeper :)

    ...and Tiber, there are some sites which generate modelines; why don't you try to add a few by hand and see what happens?
     

Share This Page

visited