Headset + Digital out = doesnt work :(

Discussion in '3-D Audio' started by xforcek, Feb 20, 2006.

  1. xforcek

    xforcek New Member

    Joined:
    Feb 20, 2006
    Messages:
    8
    Likes Received:
    0
    Trophy Points:
    0
    today i tried to install the kxdrivers for my sblive player 5.1, but i cant get my soundcard get to work righ t :(

    I want to connect a headset and my AV Receiver to my SBLive, (via digital out)

    I connected the Headset to the ports 2 and 3, and it works, i can hear sound through them,

    after that i connected the avreceiver through a coax cable to port 5 (with an adapter)

    http://kb.kxproject.lugosoft.com/guide/pic/hi-io.jpg


    Now when i switch on the digital out only Button in the KX Mixer,
    i can hear sound through my receiver, but the sound through the headset doesnt work anymore :(

    When i switch back, the headset works, but i dont hear anything through my receiver,


    How can I get both to work withouth having to click the button all the time?


    :(
     
  2. Russ

    Russ Well-Known Member

    Joined:
    Jan 17, 2005
    Messages:
    5,722
    Likes Received:
    13
    Trophy Points:
    48
    Enable DOO mode for digital, and then use kxctrl to unmute the analog front and rear.
    Which registers would depend on the AC97 codec that you have and which model card you have.
    i.e. For my card I would do the following:

    Enable DOO mode.

    Then type the following in kX Console:
    sac97 2 0
    sac97 18 0
    sac97 36 0
     
    Last edited: Feb 21, 2006
  3. xforcek

    xforcek New Member

    Joined:
    Feb 20, 2006
    Messages:
    8
    Likes Received:
    0
    Trophy Points:
    0
    I'm using a SB Live! Player 5.1

    thanks, i typed
    sac97 2 0 0
    sac97 18 0 0
    sac97 36 0 0
    into the console,
    and it worked

    but the sound quality is very poor (and very loud)

    (music sounds like for example, voices in voice over ip software, or teamspeak/ventrilo voices)

    "Which registers would depend on the AC97 codec that you have and which model card you have."

    how could I find this out?
     
    Last edited: Feb 21, 2006
  4. Russ

    Russ Well-Known Member

    Joined:
    Jan 17, 2005
    Messages:
    5,722
    Likes Received:
    13
    Trophy Points:
    48
    What do you mean the sound quality is poor?
    The analog sound is poor, or the digital?

    As for the volume, try setting register 18 to 808 instead of 0.
    i.e.
    sac97 18 808
    If you look in kX's 'About" window, it should say which AC97 codec your card has.
     
  5. xforcek

    xforcek New Member

    Joined:
    Feb 20, 2006
    Messages:
    8
    Likes Received:
    0
    Trophy Points:
    0
    ----Hardware / Software configuration---------------
    Treibername:kX Audio Driver (Debug)
    Treiberdatum: Feb 17 2004 00:43:22
    Treiberversion: 5.10.00.3537 - debug
    DB Name:none
    SB0060 5.1 [ffe0]
    PCI Information:
    Device: 21102 Subsys: 80611102 ChipRev: 7
    Card has MPU device
    Kartenmodell ist '5.1'
    Card HAS AC97 codec
    Codec name: SigmaTel STAC9708
    3D Extension: SigmaTel 3D Enhancement
    Codec is 2.0 compliant
    Capabilities[6940] :
    DAC resolutions : -16-bit- -18-bit-
    ADC resolutions : -16-bit- -18-bit-
    Ext Capabilities [80]: -PCM surround DAC-
    Port: ffe0 Irq: 0x5(5)
    Playback buffer: 20a0
    Record buffer: 4000
    Number of AC3 buffers: 4
    Tank memory: 256 kb
    GSIF buffer: 256 samples
    OS version: [2 5 1 Service Pack 2; 2 5 1 Service Pack 2; 156 148]
    ----------------------------------------------------
     
  6. xforcek

    xforcek New Member

    Joined:
    Feb 20, 2006
    Messages:
    8
    Likes Received:
    0
    Trophy Points:
    0
     
  7. Russ

    Russ Well-Known Member

    Joined:
    Jan 17, 2005
    Messages:
    5,722
    Likes Received:
    13
    Trophy Points:
    48
    You have STAC9708 and the secondary I2S codec for the rear channels.
    I am not sure if register 36, or register 38, is the rear channels on your card (it is not always used the way it is listed in the datasheet). If it is register 38, than the above command is unmuting the center/sub channels instead of the rear channel, and that would cause problems with your digital output.

    Try playing a song, using analog out only (DOO mode off), and type the following in kX Console.
    sac97 36 8080

    See if that mutes the rear channels or the center/sub channels.
     
  8. Russ

    Russ Well-Known Member

    Joined:
    Jan 17, 2005
    Messages:
    5,722
    Likes Received:
    13
    Trophy Points:
    48
    Are you listening to the same thing on the receiver, and the headphones?
     
  9. xforcek

    xforcek New Member

    Joined:
    Feb 20, 2006
    Messages:
    8
    Likes Received:
    0
    Trophy Points:
    0

    When I set DOO off, I get sound only through my headset,
    after I typep in "sac97 36 8080" I could still hear sound through my headset, I dont know if that is what u meant?

    In the mixer center is also not muted, after typing the command

    yes, I only use the headset for gaming and the receiver for DVDs / music



    thanks for your help :)
     
  10. Russ

    Russ Well-Known Member

    Joined:
    Jan 17, 2005
    Messages:
    5,722
    Likes Received:
    13
    Trophy Points:
    48
    You wouldn't see anything in the mixer.
    Reset AC97 (click the Reset button on the 'AC97' page of kxmixer).
    Then mute the front channels in the mixer, so that only the rear channels are going to your headphones.
    Then type 'sac97 36 8080' in kX console, and see if that mutes the headphones completely.
    If it does not, then try typing 'sac97 38 8080' and see if that does it.
     
  11. Russ

    Russ Well-Known Member

    Joined:
    Jan 17, 2005
    Messages:
    5,722
    Likes Received:
    13
    Trophy Points:
    48
    But you want to do both at the same time, with the music/DVD on the receiver and the game sounds on the headset?
     
  12. xforcek

    xforcek New Member

    Joined:
    Feb 20, 2006
    Messages:
    8
    Likes Received:
    0
    Trophy Points:
    0
    right,


    none of the commands muted the headset :confused:
     
  13. Russ

    Russ Well-Known Member

    Joined:
    Jan 17, 2005
    Messages:
    5,722
    Likes Received:
    13
    Trophy Points:
    48
    Are you using the 'Swap front and rear' option in kxmixer?
    If so, try the same thing again, except mute the Rear channel in kxmixer instead of the front (and unmute the front, and put the volume back at 0 dB, and don't forget to Reset AC97).
     
  14. xforcek

    xforcek New Member

    Joined:
    Feb 20, 2006
    Messages:
    8
    Likes Received:
    0
    Trophy Points:
    0
    no I dont use swap f/r speaker option
     
  15. Russ

    Russ Well-Known Member

    Joined:
    Jan 17, 2005
    Messages:
    5,722
    Likes Received:
    13
    Trophy Points:
    48
    Nevermind about the analog rear channels. I mis-read your first post. I thought you had surround headphones, but it is just a stereo headset, so you do not have to worry about the rear channels.
    Just use:
    sac97 2 0
    sac97 18 808

    Sorry, when you said headphones, I was thinking headphones, instead of headset, so when you said that it was plugged into 2 ports on the back of the card I was thinking analog front and rear, instead of analog front and microphone. (but then it is strange that muting the analog front channels in kxmixer, did not mute you headphones).

    As for the volume/poor sound, did you try setting AC97 register 18 to 808? That should make the volume better, and maybe improve the sound.

    As for finding information on your codec, you can look at the datasheet here:
    http://kxproject.lugosoft.com/docs.php?language=en

    It shows which registers do what, but they may not be used exactly as they are listed in the datasheet, and I am not exactly sure how it works with the I2S codec (my card is differrent and does not use the I2S codec)..

    If you look at the datasheet, and play around with kX Console, you can figure most of it out yourself.

    As for listening to the game sounds, and music at the same time (i.e. different signal sent to the receiver and to the headphones), that is a little trickier, and requires some understanding of kX and the DSP. (i.e. setting the software to use the appropriate kX Wave devices, and making the right connections in the DSP, to do what you want.).
    i.e.
    Use a custom DSP setup.
    Set your music/DVD to use kX Wave(0/1), and connect FxBux(0/1) directly to the Digital Front outputs of epilog.
    Set the default Windows sounds (and thus your games) to use kX Wave(4/5), and connect FxBus(4/5) directly to the analog front outputs of epilog.
    But, the best setup (for you) would really depend on other factors (your specific needs), and it is best that you learn about the DSP yourself, so you can make your own custom setup that best suits your needs.
     
    Last edited: Feb 21, 2006
  16. xforcek

    xforcek New Member

    Joined:
    Feb 20, 2006
    Messages:
    8
    Likes Received:
    0
    Trophy Points:
    0
    yes it worked,
    thanks!


    ahh sorry my posting was maybe a bit confusing,

    I dont want to send a different signal to the receiver and headset,

    i just wanted to set my soundcard up, so that i can choose whether i listen to the sound with my headset or my receiver (by turning the receiver on)

    i didnt want to send a different signal like for example only music to the receiver

    I listen to gameosund and music at the same time just by letting winamp run while i play


    thanks alot for your helpful postings

    i finally got the mic to work too thanks!
     

Share This Page

visited