help firefox problem

Discussion in 'General Software Discussion' started by Nacht, Feb 22, 2006.

  1. Nacht

    Nacht ein Krieger

    Joined:
    Jan 29, 2004
    Messages:
    3,127
    Likes Received:
    1
    Trophy Points:
    0
    Firefox has started showing certain random text elements in italics. For exmple, the text box I'm typing in for this post is all in italics. News articles on BBC are in italics, the menu selection box on the Driverheaven home page is all in italics. Does anybody know how this happened or how to fix it?
     
  2. daedal

    daedal Uber Coffee Drinker

    Joined:
    Mar 12, 2005
    Messages:
    2,250
    Likes Received:
    0
    Trophy Points:
    0
    Hmm. Funky.
    Have you tried going into View/Character Encoding and see?
     
  3. g35x

    g35x Hellhound Pilot

    Joined:
    Aug 20, 2005
    Messages:
    1,101
    Likes Received:
    2
    Trophy Points:
    0
    try reinstalling it?
     
  4. Nacht

    Nacht ein Krieger

    Joined:
    Jan 29, 2004
    Messages:
    3,127
    Likes Received:
    1
    Trophy Points:
    0
    Messed with the char. encoding and nothing helped. Also reinstalled over my current installation and it didnt help. This is extremely annoying...please help!

    EDIT: I just noticed IE is doing it too...if that helps anyone with a diagnosis..

    EDIT2: I'm not sure whether it was a corrupted font file or missing shortcut...but I fixed the problem (finally) by deleting all the fonts in the system folder and reinstalling them.
     
    Last edited: Feb 23, 2006
  5. PangingJr

    PangingJr Member

    Joined:
    Mar 14, 2003
    Messages:
    5,989
    Likes Received:
    56
    Trophy Points:
    0
    bad shortcuts and/or bad registry value/data which are related to the Windows's fonts causes problem like this. and this is usually caused by third-party that uses and installs its own fonts on to its own folder.
    you can solve this problem just like that. but if this happens again check the Windows registry.

    anyway, for others, below would be a bit more complete way to fix this problem. check these out before going to a clean Windows install.

    check "Fonts" folder and see if any shortcut file in the folder?
    if any, then open the file Properties and check the target of the actual fonts file in the Target box,
    then, remove all bad shortcut(s). you may also need to replace all of the bad shortcut files with real font files.

    once you have done that, do not reboot your computer till you have done the next step...
    open the Registry Editor and go to "HKLM\SoftwareMicrosoftWindowsNTCurrentVersion\Fonts",
    on the right hand side of the editor check and edit or remove all incorrect value (and/or data).
    then reboot your computer.
     

Share This Page

visited