OS X driver 1.0b2 (ALPHA)

Discussion in 'MAC OS X Driver' started by Eugene Gavrilov, Aug 12, 2008.

  1. Eugene Gavrilov

    Eugene Gavrilov kX Project Lead Programmer and Coordinator

    Joined:
    Dec 7, 2002
    Messages:
    3,146
    Likes Received:
    9
    Trophy Points:
    48
    hi :cool:

    kX Audio driver for OS X (Leopard and Tiger) released.

    This is ALPHA build, use it on your own risk.

    Features:
    * 16-bit playback on most 10k1/10k2 cards
    * supports up to 8 speakers (configure them in OS X 'Audio and MIDI' panel)
    * should support SPDIF and headphones outputs, if applicable
    * supports external modules (LiveDrive)
    * supports hardware volume control and mute

    Unimplemented:
    * recording
    * SPDIF/AC-3 passthrough
    * 24-bit playback and 16/24-bit recording on 10k2/audigy/audigy2 cards
    * kX DSP and routing, no custom DSP effects, SDK and API
    * hot-plug for PCMCIA device (Audigy2 ZS notebook) - surprise removal will probably cause a lock-up or kernel panic
    * any sampling rate except 48000Hz not supported, OS X uses built-in SRC, which is quite good

    Known issues:
    * E-mu E-DSP cards are supported, but their FPGA firmware is not uploaded by default. If you are using Hackintosh, you will need to install kX driver, ensure audio is OK and reboot into OS X, this way FPGA firmware will be preserved and you will get audio.
    * When installing under Leopard, you may need to reboot after you run the installer, because leopard won't load driver KEXT file
    * audio samples in 'Sounds' preference may sound distorted in Leopard (due to unknown reason)

    Important:
    * front and rear outputs may be swapped by default for your card (this depends on your AC97 codec and card model). make sure you connect the speakers to 'Rear' output if you don't hear anything in front speakers, or re-configure audio in 'Audio MIDI Setup'.


    ====
    Please report any bugs to this thread: "1.0b2 bug reports"
    ====
    Download: kXAudioDriver-1.0b2.dmg. By downloading and installing the driver you agree to be bound by the license agreement. The driver is provided AS IS without warranty of any kind.


    Have a nice day and good luck! :)

    Eugene
     
    Last edited: Aug 12, 2008
  2. Mcb

    Mcb New Member

    Joined:
    Aug 12, 2008
    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    0
    Just installed, sound working in a hackintosh with iATKOS v4i + Audigy 2 ZS. Feedback soon! Thanks for the awesome work!
     
  3. Oxtie

    Oxtie Active Member

    Joined:
    May 14, 2008
    Messages:
    137
    Likes Received:
    0
    Trophy Points:
    26
    Fan-tastic!!!!!!!!!!!!!!!!!!!!!!!!! I can't wait for that day when they include your drivers in Distros :)

    GUYS! For that 10 Minutes issue, Do that workaround mentioned in my thread (thanks to Hagar)

    Oxtie (aka LAMA @ InsanelyMac)
     
    Last edited: Aug 12, 2008
  4. Insphire

    Insphire New Member

    Joined:
    Mar 31, 2003
    Messages:
    27
    Likes Received:
    0
    Trophy Points:
    0
    Eugene, i knew that if somebody was able to do this, it was YOU and your people here!
    This is just amazing, my Audigy II Platinum is working now, even in 5.1 mode.

    THANK YOU MAN!
    DiegoMax (aka Insphire)
     
  5. terrormav

    terrormav New Member

    Joined:
    Aug 2, 2006
    Messages:
    1
    Likes Received:
    0
    Trophy Points:
    0
    edit: after pausing the sound now has static

    you are the man works great!!!!! (sound is on the black output instead of green...no big deal)

    my setup

    soundblaster live
    leo4allv3
     
    Last edited: Aug 12, 2008
  6. DrSpawn

    DrSpawn New Member

    Joined:
    Aug 1, 2008
    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    0
    Thank you, i try it immediatly!
     
  7. HueponiK

    HueponiK New Member

    Joined:
    Jan 4, 2006
    Messages:
    6
    Likes Received:
    0
    Trophy Points:
    0
    Audigy4 non-pro working with same issues! Thanks!

    Ñïàñèáî! Êóäà ïî-ðóññêè ïèñàòü áëàãîäàðíîñòè? :)
     
  8. Max M.

    Max M. h/h member-shmember

    Joined:
    Dec 7, 2002
    Messages:
    2,690
    Likes Received:
    9
    Trophy Points:
    63

    >Êóäà ïî-ðóññêè ïèñàòü áëàãîäàðíîñòè?
    ñþäà èëè â ïî÷òó
     
  9. catboy

    catboy New Member

    Joined:
    Aug 12, 2008
    Messages:
    6
    Likes Received:
    0
    Trophy Points:
    1
    BIIIIIIG Thks....good work for first version
     
  10. Oxtie

    Oxtie Active Member

    Joined:
    May 14, 2008
    Messages:
    137
    Likes Received:
    0
    Trophy Points:
    26
    Eugene, I've added your driver release quote at the begining of the page :) and updated the information as you mentioned (home page etc) The page will most probably exceed the 10000 views by next 24 hours :)

    E, will these driver work on PPC based system? (Universal Binary?)
    Are you going on vacation without fixing the main issue? :tears:

    As always, any update from your side will be mentioned in my first post
    Thanks once again for a fine quality work time!

    Oxtie aka (Lama@InsanelyMac)
     
  11. dj_stick

    dj_stick Apple Fanboy?

    Joined:
    Jun 3, 2003
    Messages:
    17,575
    Likes Received:
    204
    Trophy Points:
    88
  12. Jellybeansmasha

    Jellybeansmasha New Member

    Joined:
    Aug 14, 2008
    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    0
    No sound using EMU 1212m.

    Using balanced cables maybe that is why?
     
  13. dj_stick

    dj_stick Apple Fanboy?

    Joined:
    Jun 3, 2003
    Messages:
    17,575
    Likes Received:
    204
    Trophy Points:
    88
    balanced/unbalanced should have no affect - that's all handled post DSP/DAC
     
  14. themax

    themax New Member

    Joined:
    Oct 25, 2007
    Messages:
    23
    Likes Received:
    0
    Trophy Points:
    0
    Nice work men,thanks.

    Installed ok and working all chanels tested in a Audigy 2 ZS whit 5.1 movie whit VLC.

    After 10 minutes the sound stop working.

    Next step, DSP & routing.
     
  15. Jellybeansmasha

    Jellybeansmasha New Member

    Joined:
    Aug 14, 2008
    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    0
    Anyone like me with an Emu 1212m and have it working?
     
  16. Eugene Gavrilov

    Eugene Gavrilov kX Project Lead Programmer and Coordinator

    Joined:
    Dec 7, 2002
    Messages:
    3,146
    Likes Received:
    9
    Trophy Points:
    48
    E-DSP requires FPGA firmware to be uploaded into the device. This is not yet supported. FPGA firmware is preserved across reboots, but it is cleared if you turn off your PC. You need to boot kX Driver for Windows, configure the card, ensure audio is working, after that - reboot to OS X, the driver should work in this case. Although, I haven't tested this scenario myself.

    In the future, E-DSP FPGA firmware will be included with OSX driver.

    E.
     
  17. Jellybeansmasha

    Jellybeansmasha New Member

    Joined:
    Aug 14, 2008
    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    0
    Thanks Eugene.
     
  18. Oxtie

    Oxtie Active Member

    Joined:
    May 14, 2008
    Messages:
    137
    Likes Received:
    0
    Trophy Points:
    26
    Eugene, someone PMed me with Russian!! help -->

    у меня система 10,4,11 хакинтошь, воткнул Creative SB Live, поставил дрова , перегрузился и система не смогла загрузить дрова kx.
    грузится смог тока через -v.
    хочу спросить , перед установкой ваших дров нужно было удалить HD Audio или не обязательно, в чем может быть проблема, что система не загружается нормально ?
    заранее благодарю за ответ.

    Translated but, difficult:
    I have a system 10,4,11 hakintosh, stuck Creative SB Live, delivered firewood, overloading the system and was unable to load firewood kx.
    loaded able current through-v.
    I want to ask before installing your firewood needed to remove the HD Audio or not necessarily, what may be the problem that the system does not load properly?
    thank in advance for your reply.


    I think this person want to remove HD audio driver (to make the system boot normally) and install kX :)
    should I send this person the following in Russian??? (Translated ofcourse) :D

    OK, I understand you're Russian but I'm not :) but I'll try to help (with the Google translation)
    Я не говорят по-русски, но я постараюсь помочь.

    If you want to remove your HD audio driver, you must first find the loaded driver
    1. Click "Apple" menu ->click "about this mac", click "More info"
    2. Click "Extensions" (from left) and see which driver is loaded (HD xxx.kext)
    To unload the driver,
    3. Click "Go" menu, click "Utilities", Double click "TERMINAL"
    4. type

    sudo -s
    (password)
    kextunload /System/Library/Extensions/HD xxx.kext

    5. Double click finder -> System -> Library -> Extensions
    6. Delete HD xxx.kext


    hehehe, I can be a fool at times...
     
    Last edited: Aug 15, 2008
  19. DrunkenDonkey

    DrunkenDonkey New Member

    Joined:
    Aug 18, 2008
    Messages:
    5
    Likes Received:
    0
    Trophy Points:
    0
    I have studied russian like 10 or more years ago, barely remember anything, but here is some better translation than google :p

    ps: there is no way I can translate english reply back in russian ;)
     
  20. jimaul

    jimaul New Member

    Joined:
    Aug 16, 2008
    Messages:
    4
    Likes Received:
    0
    Trophy Points:
    0
    2 DrunkenDonkey
    As i see you dont understand my problem?
    Моя система
    Asus P5B-E;Core2 Duo;2 gb mem;Creative SB Live
    Mas OSX 10.5.4 Leo4All
    Я пробовал установить драйвера (kxAudio 1.02 и 1.03 пробовал установить), после инсталяции kxAudio я перегрузил Mac OSX , но звуковая карта так и не появилась в системе. Так же я пробовал установить kxAudio на 10,4,11 , результат был тот же : звуковой карты не было в системе.
    В чем проблема ?
     

Share This Page

visited