OS X driver 1.2b1 (BETA)

Discussion in 'MAC OS X Driver' started by Eugene Gavrilov, Nov 19, 2008.

  1. Eugene Gavrilov

    Eugene Gavrilov kX Project Lead Programmer and Coordinator

    Joined:
    Dec 7, 2002
    Messages:
    3,146
    Likes Received:
    9
    Trophy Points:
    48
    hi :)

    1.2b1 (BETA) version is out.

    Changes:

    * Fixed issues with 10k1-based cards [noise after some minutes]
    * Fixed some of Kernel Panics

    Features:
    * 16-bit or 24-bit playback on most 10k1/10k2 cards (depending on card model)
    * supports up to 8 speakers (configure speaker configuration in OS X 'Audio and MIDI' panel)
    * should support SPDIF and headphones outputs, if applicable
    * supports external modules (LiveDrive)
    * supports hardware-accelerated volume control and mute, but not RemoteIR or onboard volume controls

    Unimplemented:
    * SPDIF+AC-3 passthrough
    * 16/24-bit recording
    * kX DSP and routing, no custom DSP effects, unless you upload them by using kxctrl
    * SoundFonts and MIDI
    * hot-plug for PCMCIA device (Audigy2 ZS notebook) - surprise removal will probably cause a lock-up or kernel panic
    * any sampling rate except 48000Hz not supported, OS X uses built-in SRC, which is quite good

    Known issues:
    * E-mu E-DSP cards are now supported the same way they are under Windows version of the kX driver. In order to upload FPGA firmware after reboot, open Terminal and type 'edspctrl'. It should initialize FPGA firmware and any dock stations you have. Note that if you reboot after Windows, and you were running Creative drivers, you need to reset FPGA firmware. Type 'edspctrl -reset'. Use this command 'edspctrl -reset' if you don't hear anything after reboot or power-on.
    * power management is not fully functional, you may need to reset the card or unload/reload the driver after 'Sleep' or 'Hibernation'.
    * 'kxctrl' does not support SoundFonts
    * 'kX Manager' application currently does nothing. Ignore it :)

    Download link:

    kXAudioDriver-1.2b1.dmg

    Please post your bug reports here.

    If you get Kernel Panics or system locks up, do the following:

    * Reboot OS X
    * At darwin boot prompt [before the 'gray apple' logo] add the following commands:
    -v -debug=0x144
    * This will enable verbose start-up and will display more information during kernel panic

    After you get a new kernel panic [make sure to start your OS X with the options mentioned above], write down the following information:
    * EIP address of the error (EIP: 0xXXXXXXXX)
    * Address of the kX driver: "com.kXProject.driver.kXAudioDriver(1.2b1)@0xAAAAAAAA->0xBBBBBBBB"
    * Backtrace (CPU 0) Frame. This is show in the following way:
    0xCCCCCCC : 0xDDDDDDDD (0xEEEEE 0xFFFF ....)
    ...
    until "Backtrace terminated"
    and "BSD process name corresponding to current thread"

    Don't send me any screenshots of your display, unless your image is perfectly readable! :)
    ===

    Thanks to CEntrance, Inc., the company I'm currently working for, it is possible to support the project and to donate by using any VISA or MasterCard card. Just follow this link and 'add to cart' kX Driver Donation item. You will be able to choose the amount of money you wish to donate and proceed to check-out.

    Russian users may also wish to donate by using WebMoney or Yandex.Money systems. Detailed information is found here.

    And I would like to thank people who have already donated to the project! (I have received $57 in total so far).

    E.
     
    Last edited: Nov 23, 2008
  2. djsubject

    djsubject New Member

    Joined:
    Aug 16, 2008
    Messages:
    63
    Likes Received:
    0
    Trophy Points:
    0
    Hi,

    i got a kernal panic after i forced Quit of my AU host testing a Alpha plugin (so it may have been nothing to do with the KX Driver!)

    i booted with "-v -debug=0x144" & did not notice the info you wanted onthe long screen of txt that cam up, is there any way i can access the info from a log file or something, or next time (if it happens again) do i need to read quicker?

    :)
     
  3. speedracer67

    speedracer67 New Member

    Joined:
    Oct 22, 2008
    Messages:
    4
    Likes Received:
    0
    Trophy Points:
    0
    I'm experiencing sound distortion/buzzing with certain sound files. I'm trying to play back this movie trailer: Apple - Trailers - Star Trek It's the HD 1080P Trailer #2. There's definately a background buzz when playing the file. When playing with my standard OS X sound driver, it sounds fine.

    Also, FYI, I discovered yesterday that there was also terrible distortion/lag/sync issues using 1.20b0 playing this same file, but never had time to report it before 1.20b1 was released. The lag and sync issues now seem to be resolved, with just buzzing/distortion problems remaining. The driver is definately coming along nicely!
     
  4. Eugene Gavrilov

    Eugene Gavrilov kX Project Lead Programmer and Coordinator

    Joined:
    Dec 7, 2002
    Messages:
    3,146
    Likes Received:
    9
    Trophy Points:
    48
    Îòâåò: Re: OS X driver 1.2b1 (BETA)

    you need to type this command "-v -debug=0x144" every time you boot
    in this case, when you get a kernel panic, you won't get a gray screen with reboot request, but a lot of numbers. these numbers are the ones I need, not the ones you see when you boot... : )

    you can add -v -debug=0x144 to your com.apple.boot.plist file, if you wish

    E.
     
  5. djsubject

    djsubject New Member

    Joined:
    Aug 16, 2008
    Messages:
    63
    Likes Received:
    0
    Trophy Points:
    0
    Re: Îòâåò: Re: OS X driver 1.2b1 (BETA)

    Ahhhh, thanks :)


    well on booting with -v -debug=0x144 my E-MU 1820 would not play corectly at all (just bits of static from my host) itunes did play fine though :)

    on shutting down it gave a long stream of IRQ errors for the KX driver then did not shut down correctly (went in to sleep state as apposed to power off)

    as theres a good chance it was the alpha plugin i was testing & not the driver i'll wait & see if it happens again, if it dose i will boot with -v -debug=0x144-v & leave it on till it crashes again & get the info you need :)

    thanks again for your hard work & support!


    Subz
     
  6. Zexx

    Zexx New Member

    Joined:
    Nov 24, 2008
    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    0
    Îòâåò: OS X driver 1.2b1 (BETA)

    Bravo, Eugene!
    My Sound Blaster Live! Platinum is working now.
    Works and external modules (LiveDrive)
    Havent not try a microphone - will it work?
    With this version of the driver, I miss the noise and plays beautifully.
    I was not able to verify the long, but yesterday instead of 1 minute of music I listened to it for an hour. Now I will try to listen to a long time.
    Sound amazing.
    Also, I now try to try the card with the program Logic.
    Will it work there?
     
    Last edited: Nov 24, 2008
  7. jimaul

    jimaul New Member

    Joined:
    Aug 16, 2008
    Messages:
    4
    Likes Received:
    0
    Trophy Points:
    0
    2 Zexx
    Plz let me know how you turn it "external modules (LiveDrive)" ???
     
  8. Zexx

    Zexx New Member

    Joined:
    Nov 24, 2008
    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    0
    Îòâåò: OS X driver 1.2b1 (BETA)

    2jimaul
    Sound Blaster Live! Platinum is sold together with LiveDrive​
     
  9. wilygea

    wilygea New Member

    Joined:
    Nov 26, 2008
    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    0
    Hi, sorry but ... no sound in my Hackintosh AMD (iDeneb 10.5.5) Motherboard MSI K8N Plat. SoundBlaster Live!24 7.1 integrated :tears:

    But good work ;)
     
  10. wilygea

    wilygea New Member

    Joined:
    Nov 26, 2008
    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    0

    Thanks :tears:
     
  11. emil1977_2

    emil1977_2 New Member

    Joined:
    Dec 10, 2008
    Messages:
    10
    Likes Received:
    0
    Trophy Points:
    0
    I want working surrounder with redirection bass on sub for mac os x, please Eugeniy make this:) On my iDeneb 10.5.5 with SB Live 5.1 your drivers works perfectly, but when play itunes he play only in stereo without any bass.
     
  12. phade

    phade New Member

    Joined:
    Dec 13, 2008
    Messages:
    1
    Likes Received:
    0
    Trophy Points:
    0
    Just istalled but my SB Audigy Platinum EX (SB0090) INPUT doesn't work:
    no input devices in Audio section and, of course, no sound at all.
    I have a 10.5.5 on Intel system.

    Please Help Me.
    Thanks
     
    Last edited: Dec 13, 2008
  13. popovde

    popovde New Member

    Joined:
    Jan 1, 2009
    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    0
    Hello! Installed sound driver with the all the items described below. Sound card undecided, but no sound.

    0. Checked Compatiblity list above? Yes. Audigy. 10k2
    1. Cable connections checked from behind? On proper port? ond NOT on Mic port? Yes.
    2. Audio Midi Setup set with appropriate speakers? Performed Speaker Test? Yes. No sound.
    3. Speakers Powered ON? Power Cables checked? Yes.
    4. HeadPhones plugged in resulting in Mute? Yes.
    5. Any other drivers conflicting? OnBoard Audio disabled in BIOS? (Onboard drivers for Azalia / AppleHDA known to conflict) Azalia Disabled.
    6. Is Device's name mentioned properly in Audio Midi setup? eg. "kX 0350 etc" (Application \ Utilities) Name - kx SB 0092 10k2.
    7. "Intel ICH and PIIX Controller" was enabled in your OSX setup? unchecked Azalia, AppleHDA in setup? Yes.
    8. Volume Controls checked? Yes.
    9. Earlier versions working on your system? (have you tried earlier versions? see my signature for download links) No.
    10. Your sound works on XP/Vist???? (and with kX drivers for Windows???) Yes.
    11. BIOS shows information that PCI card is inserted properly? Yes.
    12. Tried other Distros such as JaS, Kalyway, Leo4All? etc? No. Only iDeneb 1.3 Mac Os 10.5.5
    13. Sound comes when you put your headphones ON? in the headphones port? Yes
    14. Unloading and Reloading driver kext works? No Sound.
     
  14. xtraa

    xtraa New Member

    Joined:
    Aug 18, 2008
    Messages:
    4
    Likes Received:
    0
    Trophy Points:
    0
    Everythings working fine on an Asrock Conroe 1333 with dual-celeron and leopard 10.5.6.

    Thanks you so much for this :)
     
  15. nelepos

    nelepos New Member

    Joined:
    Apr 6, 2008
    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    0
    Îòâåò: OS X driver 1.2b1 (BETA)

    Wor with my Emu 1212, but i have "wake up" problem...Thx, for this nice stuff...
    Can i use this driver in not only "16/48"? running fine with Logic 8.02
    Sorry for bad english =)
     
  16. Oxtie

    Oxtie Active Member

    Joined:
    May 14, 2008
    Messages:
    137
    Likes Received:
    0
    Trophy Points:
    26
    Is there any update on whats going on around here? :p hope it's NOT dead...

    Is it normal E goes on such a long vacation? no activity thats all...
     
  17. LestatCheb

    LestatCheb New Member

    Joined:
    Feb 7, 2009
    Messages:
    1
    Likes Received:
    0
    Trophy Points:
    0
    thanks for the driver!

    but after some time sound make wheezing (in audio programs or listening music in itunes).

    in kontakt-player I can go to the audio/midi options and click OK, then sound make normal.

    how can reset sound card without restarting computer or using
    resource-intensive kontakt-player?


    thanks!
     
  18. speedracer67

    speedracer67 New Member

    Joined:
    Oct 22, 2008
    Messages:
    4
    Likes Received:
    0
    Trophy Points:
    0
    Hi Eugene. I'm wondering if this project is still being maintained - I check here often for updates but haven't seen any in months. Would you kindly let us know if I should stop checking?
     
  19. arkstone

    arkstone New Member

    Joined:
    Sep 4, 2008
    Messages:
    4
    Likes Received:
    0
    Trophy Points:
    0
    Unimplemented: 16/24 Bit recording - what does it mean though? Will recording work on my Audigy 4 (Not SE)?

    EDIT:

    sorry dumb question :) I hope it will work in next release though... But strangely there's no news on it, Eugene are you here at all?
     
    Last edited: Feb 21, 2009
  20. snaka

    snaka New Member

    Joined:
    Mar 10, 2009
    Messages:
    1
    Likes Received:
    0
    Trophy Points:
    0
    Can't donate for MicIn via Visa, Eugen! :(
    Tells':
    There are no shipping methods available

    Ooops, forgot:
    iPC 10.5.6
    P5b + DualCore
    Audigy (SB0092 10k2 [b880])

    Playing sound perfect :) But so need microphone for skype :)
     
    Last edited: Mar 10, 2009

Share This Page

visited