PAX MASTER PCIe Titanium Driver Suite 2014 V1.15 Default Tweak Edition

Discussion in 'PAX Download - PCIe X-Fi Series' started by Robert McClelland, Jun 5, 2014.

  1. Robert McClelland

    Robert McClelland I'm An Uncle for 2nd time Staff Member

    Joined:
    Jun 25, 2002
    Messages:
    15,327
    Likes Received:
    254
    Trophy Points:
    108
    um wrong driver bud ;) and wrong thread ;) http://www.hardwareheaven.com/commu...anium-suite-driver-hd-full-2014-v1-10.227832/
     
  2. Algorythm

    Algorythm New Member

    Joined:
    Oct 4, 2014
    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    1
    Do not put the driver on windows 8.1 why?
     
  3. Robert McClelland

    Robert McClelland I'm An Uncle for 2nd time Staff Member

    Joined:
    Jun 25, 2002
    Messages:
    15,327
    Likes Received:
    254
    Trophy Points:
    108
    They work with 8.1 you need disable driver sign.
     
  4. Algorythm

    Algorythm New Member

    Joined:
    Oct 4, 2014
    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    1
    Thank you very much!
     
  5. Robert McClelland

    Robert McClelland I'm An Uncle for 2nd time Staff Member

    Joined:
    Jun 25, 2002
    Messages:
    15,327
    Likes Received:
    254
    Trophy Points:
    108
    Please used v1.35 set
     
  6. EOD

    EOD New Member

    Joined:
    Nov 4, 2014
    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    1
    Hi Robert,

    First of all thank you for your efforts making this card even better!
    My issue is that the console launcher seems to forget the changes i've made resets the settings to default (game mode, 2/2.1 spears, no bass redirection etc). Any help with this would be highly appreciated

    Vince

    Sound Blaster X-Fi Titanium Fatal1ty
    Windows 7 x64
     
  7. Robert McClelland

    Robert McClelland I'm An Uncle for 2nd time Staff Member

    Joined:
    Jun 25, 2002
    Messages:
    15,327
    Likes Received:
    254
    Trophy Points:
    108
    You may have put the computer to sleep for save settings that might fix it ;)
     

Share This Page

visited