PAX PCI XFI All OS Test thread.

Discussion in 'PAX Download - PCI X-Fi Series' started by Robert McClelland, Oct 16, 2011.

  1. spookgf

    spookgf New Member

    Joined:
    Mar 3, 2012
    Messages:
    17
    Likes Received:
    2
    Trophy Points:
    3
    First of all thanks for the reply.

    I did a clean install on a fresh installed windows 8 cp X64.

    Do you think that the "Product Identification Module Update" will help in my problem with the lost settings?It says that it is for hardware detection problems.

    Ps: My card is "X-Fi XtremeGamer Fatal1ty Professional Series"
     
  2. Robert McClelland

    Robert McClelland I'm An Uncle for 2nd time Staff Member

    Joined:
    Jun 25, 2002
    Messages:
    15,327
    Likes Received:
    254
    Trophy Points:
    108
    Yup it should If drivers don't installed I might not have your OEM ID :)
     
  3. Robert McClelland

    Robert McClelland I'm An Uncle for 2nd time Staff Member

    Joined:
    Jun 25, 2002
    Messages:
    15,327
    Likes Received:
    254
    Trophy Points:
    108
    Now you know why I kinda hold back on the release :).
     
  4. boyriot

    boyriot Headbangers

    Joined:
    Sep 4, 2011
    Messages:
    51
    Likes Received:
    0
    Trophy Points:
    6
    I'm sorry but it's not working..
    may be I should go back to win 7..
     
  5. spookgf

    spookgf New Member

    Joined:
    Mar 3, 2012
    Messages:
    17
    Likes Received:
    2
    Trophy Points:
    3
    I am home from work keen on try the solution with PDI,restarted my pc only to find that ALL my settings are SAVED.:D
    The only thing that i did last night was having a few drinks with my friends and letting my pc go to sleep mode(due to fresh install,i always change it).
    If anyone can confirm this it would be great.

    So for me only one question for Robert.In 1.3 version that i installed previously i had THX but not in 1.4 that i have now.I suppose that it is due to bad install, not that is not included in 1.4.Is there a way that i can install it individually?
     
    Last edited: Mar 12, 2012
  6. Robert McClelland

    Robert McClelland I'm An Uncle for 2nd time Staff Member

    Joined:
    Jun 25, 2002
    Messages:
    15,327
    Likes Received:
    254
    Trophy Points:
    108
    I always can redo the software suite :) I only want the the drivers make sure they work on 8 first then worry about suite bit later
     
  7. spookgf

    spookgf New Member

    Joined:
    Mar 3, 2012
    Messages:
    17
    Likes Received:
    2
    Trophy Points:
    3
    The driver seems to work fine so far from me.
     
  8. LordBlackthorn

    LordBlackthorn New Member

    Joined:
    Feb 27, 2005
    Messages:
    9
    Likes Received:
    0
    Trophy Points:
    0
    hi, i have an x fi elite pro pci-e card and tried installing the drivers but they don't work on 8. installed the PDI update and changed the drivers with the signed ones. no success.
     
  9. Robert McClelland

    Robert McClelland I'm An Uncle for 2nd time Staff Member

    Joined:
    Jun 25, 2002
    Messages:
    15,327
    Likes Received:
    254
    Trophy Points:
    108
    You have disable your driver sign press F8 durning boot up then it should work.
     
  10. LordBlackthorn

    LordBlackthorn New Member

    Joined:
    Feb 27, 2005
    Messages:
    9
    Likes Received:
    0
    Trophy Points:
    0
    you mean boot in safe mode and try installing the driver there? did not work. pressing f8 while booting does nothing Oo
     
    Last edited: Mar 16, 2012
  11. spookgf

    spookgf New Member

    Joined:
    Mar 3, 2012
    Messages:
    17
    Likes Received:
    2
    Trophy Points:
    3
  12. LordBlackthorn

    LordBlackthorn New Member

    Joined:
    Feb 27, 2005
    Messages:
    9
    Likes Received:
    0
    Trophy Points:
    0
  13. LordBlackthorn

    LordBlackthorn New Member

    Joined:
    Feb 27, 2005
    Messages:
    9
    Likes Received:
    0
    Trophy Points:
    0
    uhhh... this is a pci thread. do i have the wrong driver? do i need a pci-e one for my pic-e card?
     
  14. Robert McClelland

    Robert McClelland I'm An Uncle for 2nd time Staff Member

    Joined:
    Jun 25, 2002
    Messages:
    15,327
    Likes Received:
    254
    Trophy Points:
    108
    Yup wrong thread bud :)
     
  15. LordBlackthorn

    LordBlackthorn New Member

    Joined:
    Feb 27, 2005
    Messages:
    9
    Likes Received:
    0
    Trophy Points:
    0
    AW: PAX PCI XFI All OS Test thread.

    uuh, don't tell anyone ;) have you got a link for the latest pic-e driver for my x fi elite pro and win8? i don't really get the structure in these threads here :/
     
  16. Robert McClelland

    Robert McClelland I'm An Uncle for 2nd time Staff Member

    Joined:
    Jun 25, 2002
    Messages:
    15,327
    Likes Received:
    254
    Trophy Points:
    108
  17. standritsu

    standritsu New Member

    Joined:
    Mar 1, 2012
    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    0
    I have the same too , everything reset after restart.
     

Share This Page

visited