Radeon Omega Drivers v2.5.58 (Cat 4.7)

Discussion in 'AMD Graphics Cards' started by Omegadrive, Jul 17, 2004.

  1. psychlone

    psychlone M3A32-MVP GURU

    Joined:
    Apr 22, 2003
    Messages:
    55
    Likes Received:
    4
    Trophy Points:
    0
    issue resolved (?)

    I did yet ANOTHER format/install of XP, installed Omega 4.7's and THEN SP2 build 2169 and it works, but the install of SP2 failed right at the end...
    And, Ive tried to reinstall it from Windows Update, as well as the file I downloaded...so, uninstalled the 2158's, rebooted, installed (good this time) SP2 b2169 and tried the 2158's again, and the problem presented itself again.
    I've duplicated the problem numerous times...it IS SP2 b2169.
    I saw that Omega tried it out on 2149 and it worked well, but Microsoft changed something since then, obviously.
    So, back to 4.6's while I'm on the build 2169...
    Psychlone

    Windows XP is a 32 bit Graphical User Interface for a 16 bit upgrade of an 8 bit operating system made on a 4 bit computer by a 2 bit company that can't stand 1 bit of competition!
     
  2. Virus

    Virus New Member

    Joined:
    Apr 13, 2004
    Messages:
    42
    Likes Received:
    0
    Trophy Points:
    0
    Omega could you please answer on my post, my graka is hot as hell :dead:
     
  3. Linkster

    Linkster New Member

    Joined:
    Sep 22, 2003
    Messages:
    1
    Likes Received:
    0
    Trophy Points:
    0
    Display

    Not sure how this happened or why but my display was totally upside down!! Writing this is safemode as it is too hard to do it upside down. LOL

    Everything was fine with 551 drivers but when I installed the 558 drivers everything was upside down.

    Uninstalled them and will try again but totally weird!

    Running Sapphire 9800Pro, XP SP1 :confused:

    OK uninstalled and rebooted then installed 558 with no problem, strange!!

    Why do I have a secondary Radeon 9800 display adapter??? Is this the norm or is something off on my system??
     
    Last edited: Jul 19, 2004
  4. smitty

    smitty New Member

    Joined:
    Sep 4, 2003
    Messages:
    1
    Likes Received:
    0
    Trophy Points:
    0
    Strange Omega 4.7 Problem

    I have a Compaq Evo N800c laptop with the Mobility Radeon 7500 chip and I'm having a strange problem with the newest Omegas.

    When I close the screen on my notebook (push the screen down so the notebook is closed), and raise the screen, the display does not light back up. You can see the desktop, but it isn't illuminated. I have to change resolutions, and the screen illuminates again. This has been happening on the last couple of Omega drivers. This did not happen with the 4.5 and previous releases. Any ideas?
     
  5. Virus

    Virus New Member

    Joined:
    Apr 13, 2004
    Messages:
    42
    Likes Received:
    0
    Trophy Points:
    0
    Re: Display

    No thats normal :) ... thats for shure
     
  6. Shadow Lady

    Shadow Lady Avril Fan

    Joined:
    Jun 2, 2003
    Messages:
    1,262
    Likes Received:
    0
    Trophy Points:
    0
    why does it have to always show first and secondary display adapter? just curious -.-
     
  7. bubblejoe

    bubblejoe New Member

    Joined:
    Oct 9, 2003
    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    0
    Same problem for me, I must stick to 2544 as I am unable to watch any video smoothly with 2551 or 2558 :(

    Operating System: Windows XP Professional (5.1, Build 2600) Service Pack 2, v.2162 (2600.xpsp_sp2_idx.040709-1830)
    Processor: Intel(R) Pentium(R) 4 CPU 2.80GHz
    Memory: 510MB RAM
    DirectX Version: DirectX 9.0c (4.09.0000.0904)
    Card name: ATI MOBILITY RADEON 9000 (Omega 2.5.58)
    Display Memory: 64.0 MB


    My specs -> DxDiag.txt
     
  8. massimo

    massimo New Member

    Joined:
    Jan 10, 2003
    Messages:
    14
    Likes Received:
    0
    Trophy Points:
    0
    This is the second release of the omega drivers that gives me a problem.
    I use only one game :fligh simulator 2004, and it works well with the ati drivers but it gives to me many antialiasin problems with the omega drivers.
    my pc is a pentium IV 3 gig on an abit IC7g motherboard, serial ata and scsi4 HD 1 gig of ram and an ati 9700 pro board
     
  9. Pman

    Pman New Member

    Joined:
    Jun 21, 2004
    Messages:
    115
    Likes Received:
    0
    Trophy Points:
    0
    I think the 4.6 drivers perform better. the 4.7 seemed jerky when i would move aroun in bf1942. arnt these drivers sposed to be more for the ''x'' cards instead of r9x00? i get the same framerate in all the games i play exept that when i move it is jerky. mabe i will try em again to see if i did a bad install
     
  10. micron

    micron New Member

    Joined:
    Jan 17, 2004
    Messages:
    186
    Likes Received:
    0
    Trophy Points:
    0
    The problem that I seem to be having, isnt really a problem, but a bummer none the less.
    I remember a day, when I could install Omega drivers, and i would immediately notice a difference in the image quality of my games. There was no doubt about it.
    These days, i cannot tell the difference. I understand that the Omega's come with a lot of useful programs, and soft mod's, but I dont use any of them. All I use, are drivers(with control panel) and Rage Tweak.
    Is there any use in installing these new drivers? what am I to expect?....faster frame rates?... or better image quality?
    I'm not one who seems to be plagued by instability problems, both the standard Cat's, and the Omega's run stable for me. I thinks I'm just looking for something different.
    Thanks for giving me an option in drivers Omega, but if I cant tell a difference visually in my games, then it's not really an option for me at all.
     
  11. DyceFreak

    DyceFreak Whooshinator 2000

    Joined:
    Jun 19, 2004
    Messages:
    50
    Likes Received:
    0
    Trophy Points:
    0
    keep in mind micron that IQ can only get so good, and drivers really dont offer that great of performance improvement because you can only go so far with them, they are still limited by the hardware.
     
  12. Skillz

    Skillz New Member

    Joined:
    Jun 10, 2002
    Messages:
    78
    Likes Received:
    0
    Trophy Points:
    0
    Also having problems with 2.5.58...

    Hi Omega,

    I'm also having problems with this 2.5.58 drivers (and also the 2.5.51 drivers).
    The video also stops and audio keeps playing and when I close the lid of my laptop (screen turns off)
    and open it up again, the screen stays dark :(

    I'm also having a major speed DECREASE with the latest 2 drivers...

    I realize I do have an old mobility card (Mobility Radeon 7500),
    so maybe I'm better off sticking to the older drivers.

    I'm running Omega's 2.5.44 (cat 4.5) right now and everything works.
     
  13. WisMerHill

    WisMerHill New Member

    Joined:
    May 15, 2003
    Messages:
    468
    Likes Received:
    0
    Trophy Points:
    0
    THX Omega, me loves this version, imo it has more speed and better iQ then the 2.5.51 , Well done
     
  14. FR4GGL3

    FR4GGL3 New Member

    Joined:
    Aug 6, 2003
    Messages:
    1
    Likes Received:
    0
    Trophy Points:
    0
    woot, woot omega!
    these drivers rock my sys!
    they are fast, they have a great iq and they are rockstable -> no problems here!
    :cool:

    a big thanx
     
  15. illegal-op

    illegal-op New Member

    Joined:
    Apr 13, 2004
    Messages:
    8
    Likes Received:
    0
    Trophy Points:
    0
    Has anyone else tried these new drivers with Counter-Strike?
     
  16. swatX

    swatX ba|\|\|ed

    Joined:
    May 30, 2004
    Messages:
    618
    Likes Received:
    0
    Trophy Points:
    0
    yea i did! they are pretty nice!! you should try these drivers
     
  17. illegal-op

    illegal-op New Member

    Joined:
    Apr 13, 2004
    Messages:
    8
    Likes Received:
    0
    Trophy Points:
    0
    I have this weird problem where the screen turns red where it should be black. Happens sometimes on map change, sometimes within the map between different textures and also when switches between players in spec view. Anyone else run into this type of problem?
     
  18. Stephonovich

    Stephonovich New Member

    Joined:
    Aug 19, 2003
    Messages:
    8
    Likes Received:
    0
    Trophy Points:
    0
    I'd used Omegas before, and was quite happy, but had some problems with both .44 and .58. Right after I did a fresh format/reload of XP w/ SP1, they refused to install. Kept giving me standard VGA. Then, they'd install, but if you tried taking them past 640x480, it rebooted. Eventually, after doing a full Windows Update, they worked. I recently tried updating to .58, and just installed right over the top, like I always have. Standard VGA only. I used System Restore to go back, used Driver Cleaner, removed everything, tried again. Still nothing. Then, it'd boot and give me an entirely green screen with no cursor for about 10 seconds before rebooting. Later, it went back to letting me boot at 640x480, but going past that caused a reboot.

    I'm back to running .44 by using System Restore, but I'm very confused. Why do Omegas always give me issues?

    For system specs (if neccessary), I'm running a stock XP 2000+ on an MSI K8T, 512MB DDR333, 120GB Western Digital SE HD, Radeon 9800 Pro 128MB.

    (-:Stephonovich:)
     
  19. tenchimato

    tenchimato New Member

    Joined:
    Apr 24, 2004
    Messages:
    7
    Likes Received:
    0
    Trophy Points:
    0
    Hi

    I've a slight problem with the last few releases. It seems that the new releases slow down my games a lot. I don't know if it happened to any of you, but when I play need for speed underground, the game runs in a very jerky fashion. It will go fast for a split second then slow down a lot and go fast again and so on...

    I can see the increase in IQ but I've chosen to run the omega 2.4.96c (cat 3.9) instead because the rendering is much faster and more fluid.

    I hope some of you can shed some light on this particular issue. btw I'm running a 9800 pro....
     
  20. nczkeren

    nczkeren New Member

    Joined:
    Apr 2, 2004
    Messages:
    9
    Likes Received:
    0
    Trophy Points:
    0
    I also have a 9600 mobility, and worried about the video bug and other problems that the latest omegadriver has. my question is, does this happen to the original cats too? (4.7) how about unian drivers? (please dont flame me for asking about other drivers besides omega, even DH made a comparison). does it have the same problem, black screen with video playback n mp3. does it also support mobility cards like omega?? im sure someone in this board tried it too
     

Share This Page

visited