Ramdrive tweaks for network speed boost

Discussion in 'Reviews & Articles Discussion' started by cypher_138, May 6, 2004.

  1. conglacio

    conglacio New Member

    Joined:
    Oct 24, 2005
    Messages:
    8
    Likes Received:
    0
    Trophy Points:
    0
    mm...they should be running...at least, the .sys file is where it is supposed to be....
    give me a sec to swap reg settings and I will check....
     
  2. conglacio

    conglacio New Member

    Joined:
    Oct 24, 2005
    Messages:
    8
    Likes Received:
    0
    Trophy Points:
    0
    Ok, here is what I got...(including 2 commands I ran after that..)
    D:\Documents and Settings\Dave>net start afd
    The requested service has already been started.

    More help is available by typing NET HELPMSG 2182.


    D:\Documents and Settings\Dave>NET HELPMSG 2182

    The requested service has already been started.


    EXPLANATION

    You tried to start a service that is already running.

    ACTION

    To display a list of active services, type:

    NET START



    D:\Documents and Settings\Dave>net start
    These Windows services are started:

    AVG7 Alert Manager Server
    AVG7 Update Service
    COM+ Event System
    Computer Browser
    Cryptographic Services
    DCOM Server Process Launcher
    Distributed Link Tracking Client
    Error Reporting Service
    Event Log
    FAH@D:+Program Files+Folding@Home+FAH502-Console.exe
    Help and Support
    Human Interface Device Access
    Network Connections
    NVIDIA Display Driver Service
    Plug and Play
    Print Spooler
    Protected Storage
    Remote Procedure Call (RPC)
    Remote Procedure Call (RPC) Locator
    Security Center
    Server
    Shell Hardware Detection
    System Event Notification
    System Restore Service
    Task Scheduler
    Terminal Services
    WebClient
    Windows Audio
    Windows Image Acquisition (WIA)
    Windows Management Instrumentation
    Windows Time
    Wireless Zero Configuration
    Workstation

    The command completed successfully.
     
  3. conglacio

    conglacio New Member

    Joined:
    Oct 24, 2005
    Messages:
    8
    Likes Received:
    0
    Trophy Points:
    0
    interestingly enough, as I was booting up with the normal reg settings, so I could post this, I noticed 2 dos boxes coming up for less then a second....I decided to ad a pause to the .bat file that I was using, to see what those boxes said...this is what they say...


    ----box 1----

    D:\>Echo Starting TCP/IP Services
    Starting TCP/IP Services

    D:\>copy D:\WINDOWS\System32\DRIVERS\afd.sys r:\
    1 file(s) copied.

    D:\>copy D:\WINDOWS\System32\DRIVERS\netbt.sys r:\
    The process cannot access the file because it is being used by another process
    0 file(s) copied.

    D:\>copy D:\WINDOWS\System32\DRIVERS\tcpip.sys r:\
    1 file(s) copied.

    D:\>copy D:\WINDOWS\System32\DRIVERS\ipnat.sys r:\
    1 file(s) copied.

    D:\>net start afd
    The requested service has already been started.

    More help is available by typing NET HELPMSG 2182.


    ----box 2----


    D:\>Echo Starting TCP/IP Services
    Starting TCP/IP Services

    D:\>copy D:\WINDOWS\System32\DRIVERS\afd.sys r:\
    1 file(s) copied.

    D:\>copy D:\WINDOWS\System32\DRIVERS\netbt.sys r:\
    1 file(s) copied.

    D:\>copy D:\WINDOWS\System32\DRIVERS\tcpip.sys r:\
    The process cannot access the file because it is being used by another process.
    0 file(s) copied.

    D:\>copy D:\WINDOWS\System32\DRIVERS\ipnat.sys r:\
    The process cannot access the file because it is being used by another process.
    0 file(s) copied.

    D:\>net start afd
    The requested service has already been started.

    More help is available by typing NET HELPMSG 2182.
     
  4. ChoGGi

    ChoGGi Well-Known Member

    Joined:
    Jun 24, 2002
    Messages:
    1,208
    Likes Received:
    1
    Trophy Points:
    48
    going by what i can see you've made it a bit too complicated or maybe its just running a few times? check your startup locations

    edit: could you post the bat file your using?
     
  5. conglacio

    conglacio New Member

    Joined:
    Oct 24, 2005
    Messages:
    8
    Likes Received:
    0
    Trophy Points:
    0
    well, I only remember putting it into the startup folder...I removed the shortcut from there, and found that the file did not run
    with the modded reg settings, the first 2 services did not show as running when I started them up seperatly in the dos box

    the batch file is

    @echo on

    Echo Starting TCP/IP Services

    copy D:\WINDOWS\System32\DRIVERS\afd.sys r:\
    copy D:\WINDOWS\System32\DRIVERS\netbt.sys r:\
    copy D:\WINDOWS\System32\DRIVERS\tcpip.sys r:\
    copy D:\WINDOWS\System32\DRIVERS\ipnat.sys r:\

    net start afd
    net start netbt
    net start tcpip
    net start ipnat
     
  6. ChoGGi

    ChoGGi Well-Known Member

    Joined:
    Jun 24, 2002
    Messages:
    1,208
    Likes Received:
    1
    Trophy Points:
    48
  7. conglacio

    conglacio New Member

    Joined:
    Oct 24, 2005
    Messages:
    8
    Likes Received:
    0
    Trophy Points:
    0
    changed it round, and the first 3 start ok, the last says it is allready running.

    *retiring for night...will be back tomorrow*

    thanks for the help so far!
     
  8. ChoGGi

    ChoGGi Well-Known Member

    Joined:
    Jun 24, 2002
    Messages:
    1,208
    Likes Received:
    1
    Trophy Points:
    48
    check the registry one more time just to make sure you typed in the locations right
     
  9. conglacio

    conglacio New Member

    Joined:
    Oct 24, 2005
    Messages:
    8
    Likes Received:
    0
    Trophy Points:
    0
    ok, just loaded up that reg backup.....

    \??\R:\tcpip.sys

    the other 3 have the same format
     
  10. ChoGGi

    ChoGGi Well-Known Member

    Joined:
    Jun 24, 2002
    Messages:
    1,208
    Likes Received:
    1
    Trophy Points:
    48
    well i only got this working yesterday (had a clean install figured i might as well try it) so i'm basically out of ideas :)
    i have them starting in this order (i dont have netbt there because it doesnt run normally so no sense in me running it)
    tcpip
    afd
    ipnat

    you could try copying the files from elsewhere instead of the driver folder (i have to do that for x64 or else the file redirection crap kicks in), probably wont make a difference though.
     
  11. conglacio

    conglacio New Member

    Joined:
    Oct 24, 2005
    Messages:
    8
    Likes Received:
    0
    Trophy Points:
    0
    I will try that one tonight...
    although, I am worried by the fact that the script does not run until the wall paper is allready loaded...surely that's a bit late to load something that is needed for network drives?
     
  12. ChoGGi

    ChoGGi Well-Known Member

    Joined:
    Jun 24, 2002
    Messages:
    1,208
    Likes Received:
    1
    Trophy Points:
    48
    probably would be
     
  13. edgewise

    edgewise New Member

    Joined:
    Nov 24, 2005
    Messages:
    37
    Likes Received:
    0
    Trophy Points:
    0
    Hello, how do i exactly move the network drivers into the ramdisk? i mean what files do i have to move?
     
  14. ChoGGi

    ChoGGi Well-Known Member

    Joined:
    Jun 24, 2002
    Messages:
    1,208
    Likes Received:
    1
    Trophy Points:
    48
    you need to setup a script that'll copy them over every boot.
    check the first post it shows which.
     
  15. edgewise

    edgewise New Member

    Joined:
    Nov 24, 2005
    Messages:
    37
    Likes Received:
    0
    Trophy Points:
    0
    yeah, but besides those, is there any other network drivers that i may add so it can boost the pc up a bit more?
     
  16. Babalou

    Babalou New Member

    Joined:
    Oct 19, 2003
    Messages:
    132
    Likes Received:
    3
    Trophy Points:
    0
    I gave the tweaks a shot after ghosting my drive.

    It did not work for me, It gave me errors with my anti-virus(avast) and a few other apps, because they could not find the proper ports to connect.

    I did however have connectivity.
     
  17. ChoGGi

    ChoGGi Well-Known Member

    Joined:
    Jun 24, 2002
    Messages:
    1,208
    Likes Received:
    1
    Trophy Points:
    48
    got me about any other drivers. i stuck some startup programs on it seem to work alright.
     
  18. Drft3rX

    Drft3rX New Member

    Joined:
    Aug 28, 2005
    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    0
    I guess I stumbled upon this thread a lil too late. Seems that the links arent working.
     
  19. ChoGGi

    ChoGGi Well-Known Member

    Joined:
    Jun 24, 2002
    Messages:
    1,208
    Likes Received:
    1
    Trophy Points:
    48
  20. Drft3rX

    Drft3rX New Member

    Joined:
    Aug 28, 2005
    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    0
    thx u very much lol
     

Share This Page

visited