resolution for x1550 series

Discussion in 'AMD Graphics Cards' started by moore, Jan 4, 2008.

  1. moore

    moore New Member

    Joined:
    Jan 4, 2008
    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    0
    hi,
    Im pretty new to linux so please bare with me.

    I have just updated my monitor to LG Flatron Wide.
    Optimal resolution is 1680x1050.
    The VGA is radeon x1550

    I have a new installation of Fedora Core 6. - 2.6.18-1.2798.fc6 on AMD x86_64 machine.
    I download the display driver from the AMD site and was then able to use the monitor.
    Driver version is 8.44.3

    However the highest setting on the resolution is 1280x1024

    How can I configure to achieve optimal resolution?

    I did try the following and rebooting but it didnt appear to make a difference

    Code:
    [root]# gtf 1680 1050 60
    
      # 1680x1050 @ 60.00 Hz (GTF) hsync: 65.22 kHz; pclk: 147.14 MHz
      Modeline "1680x1050_60.00"  147.14  1680 1784 1968 2256  1050 1051 1054 1087  -HSync +Vsync
    
    [root]#
    
    and the I put that into the xorg.conf file as follows

    Code:
    # Xorg configuration created by pyxf86config
    
    Section "ServerLayout"
        Identifier     "Default Layout"
        Screen      0  "aticonfig-Screen[0]" 0 0
        InputDevice    "Keyboard0" "CoreKeyboard"
    EndSection
    
    Section "Files"
    EndSection
    
    Section "Module"
    EndSection
    
    Section "InputDevice"
        Identifier  "Keyboard0"
        Driver      "kbd"
        Option        "XkbModel" "pc105"
        Option        "XkbLayout" "gb"
    EndSection
    
    Section "Monitor"
        Identifier   "aticonfig-Monitor[0]"
        Option        "VendorName" "ATI Proprietary Driver"
        Option        "ModelName" "Generic Autodetecting Monitor"
        Option        "DPMS" "true"
            Modeline "1680x1050_60.00"  147.14  1680 1784 1968 2256  1050 1051 1054 1087  -HSync +Vsync
    EndSection
    
    Section "Device"
        Identifier  "Videocard0"
        Driver      "vesa"
    EndSection
    
    Section "Device"
        Identifier  "aticonfig-Device[0]"
        Driver      "fglrx"
    EndSection
    
    Section "Screen"
        Identifier "Screen0"
        Device     "Videocard0"
        DefaultDepth     24
        SubSection "Display"
            Viewport   0 0
            Depth     24
                    Modes "1680x1050_60.00"
        EndSubSection
    EndSection
    
    Section "Screen"
        Identifier "aticonfig-Screen[0]"
        Device     "aticonfig-Device[0]"
        Monitor    "aticonfig-Monitor[0]"
        DefaultDepth     24
        SubSection "Display"
            Viewport   0 0
            Depth     24
                    Modes "1680x1050_60.00"
        EndSubSection
    EndSection
    
    I would appreciate any suggestions/guidance?
    thank you.
     
  2. DarkFoss

    DarkFoss Active Member

    Joined:
    May 29, 2002
    Messages:
    688
    Likes Received:
    1
    Trophy Points:
    28
    The driver is bugged... from the release notes :
    [FONT=Verdana][SIZE=2][FONT=Verdana][SIZE=2][FONT=Verdana][SIZE=2][FONT=Verdana][SIZE=2]Connecting a display device that supports 1680x1050 to a system running Linux may result in a maximum display resolution of 1280x1024 only being available[/SIZE][/FONT][/SIZE][/FONT][/SIZE][/FONT][/SIZE][/FONT]
     
  3. NAZ2222

    NAZ2222 Active Member

    Joined:
    May 15, 2005
    Messages:
    401
    Likes Received:
    2
    Trophy Points:
    28
    Maybe use a older driver version! search in the phoronix forums, it's all about linux there!!
     
  4. moore

    moore New Member

    Joined:
    Jan 4, 2008
    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    0
    Thanks for replies.
    I was able to load an older version and was able to get 1400x1050.
    This will do until bug is resolved.

    Thanks.
     

Share This Page

visited