SB0220 No Rear

Discussion in '3-D Audio' started by Xyphilon, Jun 13, 2004.

  1. Xyphilon

    Xyphilon New Member

    Joined:
    Jun 13, 2004
    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    0
    Hi,

    I read a lot already, finally got me SB0220 (SB Live! 5.1 Player Bulk) to work a little :)
    Now, the REARS don't work. I read about the AC97, and also did as described here:

    http://au.geocities.com/kxcubase

    About this AC97 not being supported or something...
    Does this mean I CAN NEVER use rear speakers?
    So is it the KX that does not support this yet?
    Or does the card itself not (and will never) support this?

    I have a Creative Inspire T5400 box set (5.1)

    Thanks!
     
  2. dj_stick

    dj_stick Apple Fanboy?

    Joined:
    Jun 3, 2003
    Messages:
    17,575
    Likes Received:
    204
    Trophy Points:
    88
    currently more research is needed to support the 6channel ac-97 codec on the newer Live! (sb022x) models
     
  3. Xyphilon

    Xyphilon New Member

    Joined:
    Jun 13, 2004
    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    0
    Thank you for your answer.
    If I get an Audigy card, WILL that support it?
    I'll just get another sound card then if that would help...
     
  4. dj_stick

    dj_stick Apple Fanboy?

    Joined:
    Jun 3, 2003
    Messages:
    17,575
    Likes Received:
    204
    Trophy Points:
    88
    yes audigy will support 5.1, the sb022x series is currently the only set that does not work fully in 5.1. also with the audigy card you get twice the DSP resouces available
     
  5. iryx

    iryx New Member

    Joined:
    Jul 19, 2004
    Messages:
    5
    Likes Received:
    0
    Trophy Points:
    0
    Hi,

    I recently bought a SB Live 5.1 Digital (OEM) because my old one had burned and I couldn't use my nForce AC97 correctly (and i still don't understand why). When I installed the Creative drivers, I could use front and rear channels and so use traktor dj studio. But i wasn't satisfied with the latency. I heard about the kX drivers and thought this could be a great solution as there must be more options to configure and I could finally use it with "real time" reactions.

    I installed it, everything wen't correct but I can't use more than 2 channels, even though i chose "quadriphonic speakers" in the windows speaker configuration and "4.1" in the kX surrounder. Now, I think there's two possibilities:

    - I'm more a newbie than I thought i was :)
    - I may have a sb022x serie card. How could I check that by the way?

    Something "fun" about my problem is that when I disable the surround in the surrounder, I have sound on the front channels and when I swap rear and front I get nothing on the rear channels. And when I enable the surround (on "copy" for example") and swap the rear and front channels, I get sound in both positions, but always on the physical front channels.

    Any ideas? Please help me!

    Thanks in advance!
     
  6. dj_stick

    dj_stick Apple Fanboy?

    Joined:
    Jun 3, 2003
    Messages:
    17,575
    Likes Received:
    204
    Trophy Points:
    88
    in the lower right hand side of the kX mixer it should displasy the card's model number
    also on the card itself the model number is in the top right corner of the card
     
  7. iryx

    iryx New Member

    Joined:
    Jul 19, 2004
    Messages:
    5
    Likes Received:
    0
    Trophy Points:
    0
    Well, I didn't understood about checking in the low-right corner of kX Mixer, only something like a400 is written there. Anyway, I unplugged the card and checked the sticker, the model number is SB0220... So I guessed I'm fucked :( Please help me.

    Do you plan on working for kX drivers to support these card or should I just throw it away and kill myself? (Maybe, instead of throwing it away, I could send it to one of the developper so he can work on it, but I'd still kill myself for buying too recent (!) hardware :))

    Thx in advance for your answer!
     
  8. dj_stick

    dj_stick Apple Fanboy?

    Joined:
    Jun 3, 2003
    Messages:
    17,575
    Likes Received:
    204
    Trophy Points:
    88
    please refrain from swearing in the forums, some people may become offended

    but if you would like to help eugene figure a way of enabling the rear outputs please contact him here
     
  9. pzmt

    pzmt New Member

    Joined:
    Aug 18, 2003
    Messages:
    28
    Likes Received:
    0
    Trophy Points:
    0
    These are links to patches with changes needed to add support for this card to ALSA linux drivers:

    http://sourceforge.net/mailarchive/message.php?msg_id=8437950
    http://sourceforge.net/mailarchive/message.php?msg_id=8437949
    http://sourceforge.net/mailarchive/message.php?msg_id=8437982

    Nothing more was needed.
    But warning: You must set output volumes for STAC9758, except that it was in default state.
    And I think it has swaped center/lfe vs surround DACs in this card.
    And it is complex codec, you can completly change input and output routing.
    I think SB Live cards with this codec can have nearly same mixer as audigy (you can disable route from analog inputs to front speakers).
    Datasheet for STAC9758 is publically available from Sigmatel page.

    I don't know how to help more.
     
  10. dj_stick

    dj_stick Apple Fanboy?

    Joined:
    Jun 3, 2003
    Messages:
    17,575
    Likes Received:
    204
    Trophy Points:
    88
    i'll fwd this on to eugene
     
  11. iryx

    iryx New Member

    Joined:
    Jul 19, 2004
    Messages:
    5
    Likes Received:
    0
    Trophy Points:
    0
    Sorry for the "swearing", it wasn't intended to be offending at all, it's just that I'm totally disappointed.

    Thanks to pzmt for the suggestion, I hope this can help Eugene...

    Now, I know it's a difficult question, but do you have any idea when the SB220x serie cards will be supported? So I know if I have to wait a little or if I trade my card with an older Live 4.1 card.

    I'd like to say something like "Keep up the good work!" but as I can't fully test the driver... ;) Great project anyway, thumbs up!
     
  12. Tiger M

    Tiger M kX user

    Joined:
    Apr 14, 2004
    Messages:
    851
    Likes Received:
    0
    Trophy Points:
    0
    Don't worry, I'm shure Eugene won't notice this:D , and if he does he won't give a dime about it.

    btw, I've always wondered what would happen to someone who swears too much here on the forum,
    will he be thrown out?
     
  13. dj_stick

    dj_stick Apple Fanboy?

    Joined:
    Jun 3, 2003
    Messages:
    17,575
    Likes Received:
    204
    Trophy Points:
    88
    Tiger - yes if it comes to the attention of the admins that osmeone using blatantly swearing often outside the flame warzone - he will be banned
     
  14. Tiger M

    Tiger M kX user

    Joined:
    Apr 14, 2004
    Messages:
    851
    Likes Received:
    0
    Trophy Points:
    0
    Yes, but he can always register again as another user, right?
     
  15. iryx

    iryx New Member

    Joined:
    Jul 19, 2004
    Messages:
    5
    Likes Received:
    0
    Trophy Points:
    0
    I guess so... I often thought of this issue, not that I'm an eternal swearer or something ;)

    So... do I trade my card or not? Anyway, I don't have 5.1 speakers, nor digital ones... I suppose a 4.1 analogic live will do the job for my good old stereo hifi speakers, right?
     
  16. iryx

    iryx New Member

    Joined:
    Jul 19, 2004
    Messages:
    5
    Likes Received:
    0
    Trophy Points:
    0
    I got a pretty funny story for ya :)

    So I trade my card with a friend who bought it some time ago. When I first saw the card, I saw it was a SB0220 too, but I tried it anyway, and guess what, this one works :) Actually, the card design is different, I think there's some more transistors and a few internal outputs too.... And that makes kX driver to recognize it as a SB0222 which is weird, but as long as it works... So this thread is over for me, people with the same problem, try to trade it (basic users won't see the difference) or wait a little.

    I still hope you'll be able to solve the problem,

    Now that I'm ready to use kX drivers, I'm gonna make some others posts about problems which will probably be easier to deal with :) Traktor now works, I can use 7 ms latency, but there's still some skips, maybe because I use DS, I'll try ASIO...

    Keep up the good work! ;)
     
  17. MechanimaL

    MechanimaL New Member

    Joined:
    Sep 28, 2003
    Messages:
    26
    Likes Received:
    0
    Trophy Points:
    0
    please help me!

    i have the audigy card and newest kx drivers. i am using eax in a game together with my headphones.

    and i have enabled the function, where the subwoofer output is used as headphones output.


    it works, except the sound straight behind me !!

    i checked the routing and saw that from the surrounder section no connection goes out from the centerSurround, is this why i have no sound from the rear center?

    i know eax is working coz if someone is slightly a bit more left (but still behind me), i hear him and i hear he s in the back and not in front of me.

    how do i get to hear the sound from exactly behind me as well ?? what can i do ?
     
  18. dj_stick

    dj_stick Apple Fanboy?

    Joined:
    Jun 3, 2003
    Messages:
    17,575
    Likes Received:
    204
    Trophy Points:
    88
    EAX does not work with kX
    what you are hearing is 3D audio, something totally different
    to hear sound directly behind you, choose kXwave 4/5 as the default soundcard in the windows sound control panel, this will route all game sounds to two channels
     
  19. MechanimaL

    MechanimaL New Member

    Joined:
    Sep 28, 2003
    Messages:
    26
    Likes Received:
    0
    Trophy Points:
    0
    mh.. i tried a bit around with the routing and i crossfaded surround center and normal center sound into the center input of the downmix 5.1 to 2.0 plugin and then into the headphone input epilog..

    it worked.

    but after all i m not totally satisfied with the sound then... the best eax sound i had with sb4.1 and win98...


    didnt get it working under xp (with audigy and creative drivers) like it worked those times ... the eax/surround whatever of the kx system was workin better with a slide touch of eax (sound from front differs from the one from the back..)

    now i installed newest soundblaster driver s again, as im not doing any recording anymore with the card..


    i have at least one (off topic) question left: is there a way to use headphones and stereo output by standard drivers, like the option in the kx drivers ??

    thx
     
    Last edited: Jul 28, 2004
  20. EvilPhish

    EvilPhish New Member

    Joined:
    Aug 4, 2004
    Messages:
    1
    Likes Received:
    0
    Trophy Points:
    0
    I would also love to have the rear speakers working. I got a SB0220 OEM card (listed as a Digital Entertainment SE on the site i got it from) as it was the cheapest card with 5.1 sound.

    I origionally brought a pair of 5.1 channel headphones however my onboard sound card (nforce2 based one) made it very anoying to use as I had to change the mic in port to the rear or centre speakers and my tv tuner card uses this for the tv sound. It ws also getting alot of background static.

    I got the SB0220 and it worked fine for a while however after a few months of use there was a echo effect being applied to all sound, very anoying and I couldn't get into the AudioHQ (crashed on running). The reverb was probally being caused by nforce drivers taking over the sb ones or somthing. I decided to try reinstalling the creative ones however i had lost the cd that came with the card origionally. I snagged the drivers from creatives site however I got a message saying that it could not detect a sound blaster card :(

    I tried to snag the install files that where extracted from the setup file but couldn't figure out where they where hiding other than setup.exe that was giving me a access denied error whenever I tried to do anything to it. Creative seem to have very crappy support :mad:

    And now i'm onto kx which is running great appart from the rear speaker thing and EAX (although i hate EAX so thats not such a problem)
    Anyone know of a way to force the creative drivers to install?
     

Share This Page

visited