Shutdown issue.

Discussion in 'Hardware Discussion & Support' started by peate, Sep 2, 2021.

  1. peate

    peate Active Member

    Joined:
    Oct 31, 2003
    Messages:
    513
    Likes Received:
    18
    Trophy Points:
    28
    Hi folks. I usually post in the kX section but since it's been rather quiet over there, I thought 'd try here.

    I use the latest kX drivers with Windows 10 and an Audigy RX PCIE card. It works great but when I shut down, 9 times out of 10, I get this pop up error. upload_2021-9-2_15-25-53.png full]6427[/ATTACH]

    It started happening many months after I installed it. It seems somehow related to time, if I shut down after less than 20 minutes or so, I don't get the error. Also, I was trying Windows 11 on a separate partition, and I never got the error.

    Any clue what the cause is? I've reinstalled Windows and all the drivers.
     
  2. Trusteft

    Trusteft HH's Asteroids' Dominator

    Joined:
    Nov 2, 2004
    Messages:
    23,727
    Likes Received:
    3,502
    Trophy Points:
    153
    I know nothing about the drivers, but if the issue appeared after the latest patches for Windows 10 then I would assume that's the culprit.
     
  3. peate

    peate Active Member

    Joined:
    Oct 31, 2003
    Messages:
    513
    Likes Received:
    18
    Trophy Points:
    28
    Didn't find the cause but, I found a solution. Just run this registry patch and reboot. This will kill any app or process that prevents Shutdown. Make sure you don't have unsaved work or you'll lose it.
     

    Attached Files:

    Calliers likes this.
  4. GigaWatt

    GigaWatt Now In Color :D

    Joined:
    Sep 8, 2008
    Messages:
    2,171
    Likes Received:
    148
    Trophy Points:
    73
    Some of the reg settings are good but some of them are bad... wouldn't merge this with the registry...

    For example, these settings.
    Code:
    [HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer]
    "NoLowDiskSpaceChecks"=dword:00000001
    
    [HKEY_CURRENT_USER\Control Panel\Desktop]
    "AutoEndTasks"="1"
    "HungAppTimeout"="1000"
    "WaitToKillAppTimeout"="2000"
    "LowLevelHooksTimeout"="1000"
    
    [HKEY_LOCAL_MACHINE\SYSTEM\ControlSet002\Control]
    "WaitToKillServiceTimeout"="1000"
    
    [HKEY_LOCAL_MACHINE\SYSTEM\ControlSet001\Control]
    "WaitToKillServiceTimeout"="1000"
    
    [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control]
    "WaitToKillServiceTimeout"="1000"
    AutoEndTasks should (almost) never be set to 1, especially not on a desktop. As for the other settings, 1000 to 2000ms is a ridiculously low setting for a program, task or a service to respond, if it's hung.

    My advice, look into the event tracker, that should give you and idea what is hanging the rig when shutting down.

    And disable hybrid shutdown all together... that thing is an abomination and the code for it should be launched straight for the sun.
     
    Calliers and IvanV like this.

Share This Page

visited