Stretching Direct3D games display problem

Discussion in 'AMD Graphics Cards' started by Castaa, Jun 6, 2003.

  1. Castaa

    Castaa New Member

    Joined:
    Jun 5, 2003
    Messages:
    20
    Likes Received:
    0
    Trophy Points:
    0
    Hi,

    I purchased a Sapphire Radeon 9700 Pro to replace my Geforce3. I am running the most recent ATI drivers.

    However, I cannot turn off the stretching (of EVE Online in full screen mode) to native resolution of my LCD Samsung 240T which is 1920x1200. The game is rendering 1280x1024 but the card/display is pixel stretching the display to a somewhat blurry 1920x1200. (Running EVE through my Geforce, displayed the game unstretched so I know it is possible to do this with my LCD monitor.)

    The stretching setting for LCD displays in the ATI control panel is turned off. My desktop is running at a native DVI 1920x1200x32 @ 60Hz.

    Is there a setting I'm over looking or a way to turn off this stretching problem in Direct3D games? My goal is to display the screen centered and not stretched if the game is running at a resolution below 1920x1200. I am using DVI (digital) and not analog.

    I have an additional problem of EVE Online not being able to render at 1600x1200x32 with my current LCD/Radeon setup. When I set it to this resolution the game comes up in tiny window that is ~400x300 or something like that.

    I know the game ran fine at 1600x1200x32 with my Geforce3 and my old CRT monitor. These two things could be related.

    Thanks for any help.

    Jon
     
  2. craig588

    craig588 Banned

    Joined:
    Nov 11, 2002
    Messages:
    3,510
    Likes Received:
    0
    Trophy Points:
    0
    Its because you switched to an LCD, they only work well than their native resouloution.
     
  3. Castaa

    Castaa New Member

    Joined:
    Jun 5, 2003
    Messages:
    20
    Likes Received:
    0
    Trophy Points:
    0
    I understand the draw backs to an LCD monitor. I am not having issues with those drawbacks.

    My first problem is with scaling and turning it off, which should be possible. (I know this is possible with a Geforce3 and the same monitor) The ATI control panel setting doesn't seem work with Direct3D it appears. I am asking: Is there another way or am I missing a setting?

    My second question is that also there appears to be a bug in either EVE or with the drivers in Direct3D 1600x1200 mode, namely EVE doesn't seem to work with the Radeon 9700 and the new monitor and there is no obvious reason why it fails. (Again my Geforce3 with a CRT ran EVE albeit a little slowly at 1600x1200 with my old CRT monitor) So I know EVE should be able to do this. I am trying determine if it's a driver bug or a game bug. And a possible work around or hack to get it working.

    Thanks.
     

Share This Page

visited