Titanium HD win 8 troubles

Discussion in 'PAX Download - PCIe X-Fi Series' started by Stanu, Mar 10, 2013.

  1. Stanu

    Stanu New Member

    Joined:
    Feb 24, 2013
    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    0
    Good day sirs!
    Maybe you can help me!
    I installed Win 8 64 and official drivers for creative from CD and i have updated them to the latest version. They worked for some period and then suddenly sound dissapears and i have BSOD, then it can't load window because of permanent BSOD, except safe mode. Only extracting card helps. Reinstall doesn't help. In safe mode i delete from device manager Creative, then restart and sound works but device is called high definition audio from microsoft.

    Thank you in advance.
     
  2. Robert McClelland

    Robert McClelland I'm An Uncle for 2nd time Staff Member

    Joined:
    Jun 25, 2002
    Messages:
    15,327
    Likes Received:
    254
    Trophy Points:
    108
    Did you try the T HD 2013 v1.00? Make sure the driver sign is disable also run crap cleaner too.
     
  3. Stanu

    Stanu New Member

    Joined:
    Feb 24, 2013
    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    0
    I've tried your February release but it didn't help
     
  4. Robert McClelland

    Robert McClelland I'm An Uncle for 2nd time Staff Member

    Joined:
    Jun 25, 2002
    Messages:
    15,327
    Likes Received:
    254
    Trophy Points:
    108
    Try march 10 2013 brand new release :) I rebuild base from Titanium build. just have T HD drivers inside of it.
     
  5. Stanu

    Stanu New Member

    Joined:
    Feb 24, 2013
    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    0
    T HD drivers 3.00.2004 ?
     
  6. Robert McClelland

    Robert McClelland I'm An Uncle for 2nd time Staff Member

    Joined:
    Jun 25, 2002
    Messages:
    15,327
    Likes Received:
    254
    Trophy Points:
    108

Share This Page

visited