"Use my display's built-in scaling" on ATI

Discussion in 'AMD Graphics Cards' started by Reecek, Feb 12, 2009.

  1. Reecek

    Reecek New Member

    Joined:
    Oct 18, 2008
    Messages:
    11
    Likes Received:
    0
    Trophy Points:
    0
    Hi, I have tried many apps and drivers, CCC & ATT don't work, to try and get a feature of nvidia drivers "Use my display's built-in scaling" to work with ATI cards, I have an ATI HD 4850 512 in XP.
    What is happening is that some games instead of showing a wide screen sort of zoom in instead, many were saying how it's ok on their machines but later narrowed it down to them having nvidia with the above mentioned setting.
    Does anyone know of a tool or a fix for this problem?:confused:

    Any advice is most welcome.:)

    Many thanks,
    Reece.
     
  2. kn00tcn

    kn00tcn New Member

    Joined:
    Jun 14, 2006
    Messages:
    647
    Likes Received:
    1
    Trophy Points:
    0
    are you talking about this??

    [​IMG]

    what do you mean zoom, can you take a photo or video or show examples? maybe even draw it
     
  3. Reecek

    Reecek New Member

    Joined:
    Oct 18, 2008
    Messages:
    11
    Likes Received:
    0
    Trophy Points:
    0
    Thanks for responding, a widescreen fix for SH3 has been done that should show like this:
    http://img242.imageshack.us/img242/9518/interior1lm6.jpg
    This is what it looks like normally without the fix:
    http://img174.imageshack.us/img174/4209/interior1strdk8.jpg
    But this is what happens to ATI users:
    Normal view (different shot):
    http://i66.photobucket.com/albums/h244/Reecehk/WithoutWS.jpg
    After the widescreen fix has been applied:
    http://i66.photobucket.com/albums/h244/Reecehk/WithWS.jpg
    As you can see it just zooms in, nvidia users can get it to go correctly but they have this setting:
    http://i291.photobucket.com/albums/ll293/fubar2niner/NvidiaControlPanel.jpg
    The CCC page that you have displayed I have tried all possible 6 combinations but none work, other ATI users have the same problem.
    This is not the first time this type of problem has emerged from other games, I hope I have explained a little better.:rolleyes:
    Note that all images are the same resolution, just changed to fit better within the forum post.:)
    Thanks.
     
  4. Judas

    Judas Obvious Closet Brony Pony

    Joined:
    May 13, 2002
    Messages:
    39,694
    Likes Received:
    1,540
    Trophy Points:
    138
    if you disable the "enable GPU scaling" it'll force the monitor to do it's own scaling
     
  5. Reecek

    Reecek New Member

    Joined:
    Oct 18, 2008
    Messages:
    11
    Likes Received:
    0
    Trophy Points:
    0
    I tried the 3 settings with the "enable GPU scaling" ticked & unticked, that was the 6 combinations but no go, must be something that the mods work on nvidia cards but not ATI, just have to leave it as "can't be done"!:(
    Thanks.
     
  6. kn00tcn

    kn00tcn New Member

    Joined:
    Jun 14, 2006
    Messages:
    647
    Likes Received:
    1
    Trophy Points:
    0
    so does this happen only in SH3 or other games?

    silent hunter 3 widescreen - Google Search

    if it's just SH3, i think it's the fix's problem, not applying vertical FOV (field of view) correctly

    seems to be most ubi games are not supporting widescreen properly, & if they let you change the rez to a widescreen rez, it ends up dropping vertical FOV instead of increasing horizontal FOV (at least farcry2 got an option for it after a patch)
     
  7. Reecek

    Reecek New Member

    Joined:
    Oct 18, 2008
    Messages:
    11
    Likes Received:
    0
    Trophy Points:
    0
    The fix was by one of the modders, but like I said it works with nvidia but not ATI, a shame but I might just have to live without it, out of curiosity I might check the google links out.:rolleyes:
    Thanks for your help.:)
     

Share This Page

visited