Vista Networking/Sharing Problems/Solutions

Discussion in 'Windows & Other OS Discussion & Support' started by Judas, Mar 12, 2007.

  1. Judas

    Judas Obvious Closet Brony Pony

    Joined:
    May 13, 2002
    Messages:
    39,737
    Likes Received:
    1,599
    Trophy Points:
    138
    OK, this is getting quite tiring trying to resolve.

    Thought i had it, did have it, lost it.

    Long story short, i KNOW i'm not alone with this freaking stuborn issue.


    Heres the deal:

    Everything should as easy as setting both machines up under the same workgroup name.

    Example for me is the workgroup name for both machines being "JUDAS"

    ok that's simple.

    Next both machines are named differently, for example:

    Main machine ~> "Client-JUDAS"
    Other Machine ~> "Client-JUDASH"

    Ok that sounds great.... doing fine now.

    Next open up the Network center.

    Disable Passwords

    Enable File Sharing, And in the case of printers, enable Printer Sharing, AND Network Discovery set to on as well.

    Great.. now last task:

    Right click the Partition/drive/folder/whatever and click SHARE, enable sharing and allow permissions for whatever the task is. So in my case, i set the permisions for EVERYONE to CREATE/MODIFY/READ.

    Ok that should have covered it all correct?

    but if i go over to the other machine and load everything up, go to networks, find the my client with the shared drive, find the shared drive, try to access it and get a huge freaking "DENIED".

    now someone, anyone, wtf am i missing here?

    Tried doing it the other way around, no dice.


    When i get this fixed, i'm going to edit this freaking post with the full discription and solution, and dammit, pin it! (lol)
     
  2. Judas

    Judas Obvious Closet Brony Pony

    Joined:
    May 13, 2002
    Messages:
    39,737
    Likes Received:
    1,599
    Trophy Points:
    138
    image for reference... can you find the missed options?

    [​IMG]
     
  3. Monkeyboy

    Monkeyboy New Member

    Joined:
    Aug 18, 2002
    Messages:
    113
    Likes Received:
    1
    Trophy Points:
    0
    Did you set the Guest account to have access privilidges to your share?
     
  4. dipstick

    dipstick New Member

    Joined:
    May 29, 2002
    Messages:
    3,609
    Likes Received:
    16
    Trophy Points:
    0
    Edit- Oops, passwords are disabled:)
     
  5. Judas

    Judas Obvious Closet Brony Pony

    Joined:
    May 13, 2002
    Messages:
    39,737
    Likes Received:
    1,599
    Trophy Points:
    138
    They both have full admin rights, there are no guests....
     
  6. technonerd

    technonerd New Member

    Joined:
    Jul 18, 2003
    Messages:
    594
    Likes Received:
    6
    Trophy Points:
    0
    Ah I see the problem ....


















    Vista.
     
  7. Monkeyboy

    Monkeyboy New Member

    Joined:
    Aug 18, 2002
    Messages:
    113
    Likes Received:
    1
    Trophy Points:
    0
    Unless you're running a Windows server, I'm pretty sure that one PC will connect to another other with guest rights. Therefore you need to enable the guest account on the PC that is sharing and give it at least read privilidges to your shared folder.
     
  8. Judas

    Judas Obvious Closet Brony Pony

    Joined:
    May 13, 2002
    Messages:
    39,737
    Likes Received:
    1,599
    Trophy Points:
    138
    ?

    why?

    I should be able to set both computers, logged in as admins.... to work without passwords on, set the folders/drives i wish to share up for everyone, and then use it as such..... but it's like windows isn't working properly at all.
     
  9. scorp64

    scorp64 New Member

    Joined:
    May 4, 2004
    Messages:
    8
    Likes Received:
    0
    Trophy Points:
    0
    Check the firewall settings on both systems and make sure that's not blocking things.

    By the way I've seen similar issues between XP boxes in a workgroup configuration.
     
  10. Judas

    Judas Obvious Closet Brony Pony

    Joined:
    May 13, 2002
    Messages:
    39,737
    Likes Received:
    1,599
    Trophy Points:
    138
    I've never had an issue with windows XP pro.... home yes.... but not pro..

    and vista, the firewall settings are allowing it.. however, both machines are acting like they don't have the privilages to access each other.. like the passwords are required yet. (same damn message, it's like turning passwords off had no effect)
     
  11. Monkeyboy

    Monkeyboy New Member

    Joined:
    Aug 18, 2002
    Messages:
    113
    Likes Received:
    1
    Trophy Points:
    0
    In order to improve security, accounts are more sophisticated on Vista than they were on XP. An account created on one PC will have no meaning on another (unless you set them both the same with the same passwords. or you're running one of the Windows server products of course in which case you can set up a domain and the account will be recognised on every machine). Therefore you need to assign the guest account 'read' priviledges at least so that you can access your files from another PC.

    I'm sure that's the way it works - unless you have a server installed, in which case you can set up accounts which will be valid domain-wide.

    This was very frustrating for me too until I set my system like this. Since then I have no problems accessing and using files shared on my other machines.

    I hope you get it resolved soon - try it and let me know how you get on. :)

    Edited to add:

    I did some digging, here you go:

    "When you disable password protected sharing, the computer sharing the folder does not require a user account or password. Anyone on your network can access the shared folders of the computer (provided the folder was shared for the Guest or Everyone account). This behavior is equivalent to simple file sharing in Windows XP."

    There are other ways of setting up sharing, as described in this MS document (from which the above quote is taken) -

    http://www.microsoft.com/technet/network/evaluate/vista_fp.mspx
     
    Last edited: Mar 13, 2007
  12. Judas

    Judas Obvious Closet Brony Pony

    Joined:
    May 13, 2002
    Messages:
    39,737
    Likes Received:
    1,599
    Trophy Points:
    138
    ok reading through that all.. i should be able to click the SHARE button in sharing, but that isn't available (greyed out).... however advanced sharing is available, and clicking SHARE FOLDER is an option.... which i've done..

    wtf?

    I can't seem to find anything in relation as to why the normal ol SHARE button is greyed out.
     
  13. Judas

    Judas Obvious Closet Brony Pony

    Joined:
    May 13, 2002
    Messages:
    39,737
    Likes Received:
    1,599
    Trophy Points:
    138
    OK, this is imo, kinda stupid...

    why would microsoft disallow anyone from sharing a single Partition/drive/whatever, however allow you to create a folder within that drive, and then share that with everyone? IMO that's beyond stupid.

    I don't want to share a bloody folder.. i want the entire drive
     
  14. Monkeyboy

    Monkeyboy New Member

    Joined:
    Aug 18, 2002
    Messages:
    113
    Likes Received:
    1
    Trophy Points:
    0
    Is it already shared, by any chance?
     
  15. Judas

    Judas Obvious Closet Brony Pony

    Joined:
    May 13, 2002
    Messages:
    39,737
    Likes Received:
    1,599
    Trophy Points:
    138
  16. ykill

    ykill New Member

    Joined:
    Dec 19, 2005
    Messages:
    16
    Likes Received:
    0
    Trophy Points:
    0
    try enabling UPnP, I had a similar problem and it worked
     
  17. Monkeyboy

    Monkeyboy New Member

    Joined:
    Aug 18, 2002
    Messages:
    113
    Likes Received:
    1
    Trophy Points:
    0
    Yeah, it is.... :)

    The root of each hard drive is shared by default under Vista (as it was under XP, 2000, NT and LanMan which all came before it). MS networks automatically share the root as a hidden, admin share (i.e. C$ for the C drive, D$ for the D drive etc) which is why it won't allow you to share the drive "again" using the ordinary sharing option... but you can, as you already said, go into advanced sharing and make another share of the same drive.

    It's just the way that MS networking has always worked - pretty confusing to some especially if you're used to Netware, but we get used to the idiosyncracies of MS eventually. ;)
     
  18. Judas

    Judas Obvious Closet Brony Pony

    Joined:
    May 13, 2002
    Messages:
    39,737
    Likes Received:
    1,599
    Trophy Points:
    138
    Er?

    if i don't have anything at all shared on the drive from the start.... then the drive isn't shared itself at all is it?

    And i'm doing nothing different then what i've done with every version of windows. right click the drive i wish to share in full, and hit share.. but the option is greyed out...
     
  19. Monkeyboy

    Monkeyboy New Member

    Joined:
    Aug 18, 2002
    Messages:
    113
    Likes Received:
    1
    Trophy Points:
    0
    Regardless of whether you have any data on the drive, it is still shared out by default by the system.

    From the MS document I linked to above:

    "Sharing the Root of a Drive..

    Windows XP by default created administrative shares for the root folders of the fixed drives of the computer. For example, for the root of the C: drive on the computer named BobPC, Windows XP automatically shared \\bobpc\c$. The “$” at the end of the share name means that the share name will not appear in the list of shares. For computers running Windows Vista that are members of a workgroup, these adminstrative shares exist but are blocked for network access for security reasons. You can create your own shares to share your drives from the root of the drive, but Microsoft highly recommends that you share only the folders that you need to, rather than the entire drive.
    To share the root of a drive, right-click the drive in the Computer window, and then click Share. Windows Vista displays the properties for the drive with the Sharing tab selected. The Share button and the File Sharing dialog box are not available. However, you can click Advanced Sharing. In the Advanced Sharing dialog box, click Share this folder and specify the share name, permissions, and other settings as needed. When complete, click OK, and then click Close."
     
    IvanV likes this.
  20. shadowfield

    shadowfield New Member

    Joined:
    May 23, 2003
    Messages:
    117
    Likes Received:
    0
    Trophy Points:
    0
    NTFS permissions stack with share permissions, so if NTFS permissions are super strict, it will effect share permissions.

    So what im saying is that you need to change the NTFS permissions along with share permissions.
     

Share This Page

visited