Windows 10 and KX-3552 (new fix)

Discussion in 'Bug Reports' started by mole2old, Jun 9, 2015.

  1. APS-Forever

    APS-Forever New Member

    Joined:
    Feb 13, 2016
    Messages:
    1
    Likes Received:
    0
    Trophy Points:
    1
    Just wanted to report a successful installation on a clean install of Windows 10 Pro. I have my faithful E-mu APS, and used mole2old's install package. I went through several reboots and kept receiving "kX device not found. Reinstall the drivers.
    error initializing WinMM subsystem" errors. Using thomasabarnes's technique of manually registering the kxasio.dll, running my DAW in Win7 compatibility mode, and Toffs suggestion of running the kxmixer as administrator once to make the KXASIO control panel show up, everything seems to be working. My DAW is Reaper, which is so light and efficient I have noticed no sluggish performance running in Win7 compatibility mode. This is my first time using KXASIO. I used ASIO4ALL before, and had a few projects which crackled up often. Once I get the rest of my stuff installed, I'll test this out. I'm hoping this will run much smoother.

    Thanks to the devs and users for all your efforts and guidance!
     
    Last edited: Feb 14, 2016
  2. loopdokter

    loopdokter 2 Release Wonder

    Joined:
    Jul 11, 2003
    Messages:
    33
    Likes Received:
    0
    Trophy Points:
    6
    Since you're basically the only APS user I've encountered on the Internet other than myself in at least 10 years that uses kX, I'm curious if you'd be willing to share your routing in the DSP with me? What do you have set up, if anything? Also, are you using the newly skinned mixer that was created by the Chinese coder who originally uploaded the stuff to Github? If so, I'd love to see how that looks using an APS and how you got it working.
     
  3. mole2old

    mole2old Thinking sucks, let’s go break something ...

    Joined:
    Jul 14, 2013
    Messages:
    27
    Likes Received:
    15
    Trophy Points:
    3
  4. thomasabarnes

    thomasabarnes Long Time ***** Friend

    Joined:
    Jan 7, 2003
    Messages:
    1,404
    Likes Received:
    13
    Trophy Points:
    48
    mole2old:

    Great job on the newest fix ([30.04.2016]_mole_hotfix_kx-3552)!

    Thanks for your work and for helping us kX users.

    I got around to trying this newest fix in Windows 10 x64 and it works great with no more error messages on startup of Windows! Can even right-click on the kX Mixer icon in the taskbar and select Settings>ASIO Control Panel without any problems! Playback setup buffer size is already set to 8 ms and everything! Great work mole2old! :)

    kX users who like to use Max M's UFX plugins and LeMury's ProFX plug ins, will just have to quit the 64Bit kX Mixer and start the 32Bit kX Mixer.

    This new fix makes it so that the 64Bit kX Mixer starts when Windows starts up. After that, per the instructions in the ReadMe file for the fix, all one needs to do is set kX WaveOut 2/3 as the playback device in the Windows Sound Control Panel. So to sum it up below:

    1) Do a clean install of the kX 3552 driver
    2) restart PC OK any kX popups that may pop up.
    3) Run [30.04.2016]_mole_hotfix_kx-3552 as admin and restart when it says to restart the PC
    4) OK any kX related pop ups that may pop up when Windows loads up.
    5) Set kX WaveOut 2/3 as default playback device in the Windows Sound Control Panel

    No kX Mixer startup errors and no non registered kX ASIO Driver problems!
    Thanks mole2old! This neweset fix works great!!!!!!

    Also, the kX 3552 ASIO Driver helps my kX compatible card perform excellently. I'm using Cakewalk SONAR Platinum, and I am running heavy projects ( 44 audio tracks, 32 FXs, and 4 SoftSynths, for example) at 24/44.1 (for mixing purposes) and 8.7 ms Total RoundTrip latency setting with no pops or clicks. My kX compatible card is an Audigy 2 ZS Platinum Pro.
     
    Last edited: May 28, 2016
    mole2old likes this.
  5. mole2old

    mole2old Thinking sucks, let’s go break something ...

    Joined:
    Jul 14, 2013
    Messages:
    27
    Likes Received:
    15
    Trophy Points:
    3
    thomasabarnes:
    Thank you very much for your thorough report!

    You describe at least two very important points:
    1. kX users who like to use Max M UFX plugins and LeMury's ProFX plug ins, will just have to quit the 64Bit kX Mixer and start the 32Bit kX Mixer.
    2. Heavy projects ( 44 audio tracks, 32 FXs, and 4 SoftSynths, for example) at 24/44.1 (for mixing purposes) and 8.7 ms Total RoundTrip latency setting (kX ASIO panel) with NO pops or clicks.
     
    thomasabarnes likes this.
  6. thomasabarnes

    thomasabarnes Long Time ***** Friend

    Joined:
    Jan 7, 2003
    Messages:
    1,404
    Likes Received:
    13
    Trophy Points:
    48
    Let me make a report on an observation I've made since using the new fix by mole2old.

    When I did the clean install of kx 3552 and used mole2old's newest fix ([30.04.2016]_mole_hotfix_kx-3552), audio worked right after I restarted after running the fix. But I usually have my PC on 24 hours a day at times. This was one of those times. Since I ran the fix, I've shut down and restarted the PC, and I noticed that I wasn't getting any audio after Windows loads. All it was is that I have to re-initialize the kX DSP, after a poweron or after I restart of the PC.

    Is it possible to get this done automatically when Windows loads, in some kind of auto run script or something? It's no big deal just to open the kX DSP, right-click in it and select ReInitialize DSP, but I just was wondering if something could be done so that audio is working without a required action from the user every time Windows loads up. If any of you smart kX users can provide some better solution to have audio available in Windows other than the user having to reinitilize the kX DSP, please share with us?
     
  7. mole2old

    mole2old Thinking sucks, let’s go break something ...

    Joined:
    Jul 14, 2013
    Messages:
    27
    Likes Received:
    15
    Trophy Points:
    3
    Clean install mean:
    1. Uninstall any KX-Drivers + restart PC
    2. Install KX-3552 + restart PC + fix + restart PC
    Note: All of these steps are required, not only point 2
    No any sounds at all? Hmmm...
    You can try once again:
    0) Uninstall any KX-Drivers + restart PC
    1) Do a clean install of the kX 3552 driver + restart PC
    2) OK any kX popups that may pop up.
    3) Run [30.04.2016]_mole_hotfix_kx-3552 as admin and restart when it says to restart the PC
    4) OK any kX related pop ups that may pop up when you restart
    5) Set kX WaveOut 2/3 as default playback device in the Windows Sound Control Panel
    Don't change default KX-Mixer skin, don't touch KX DSP etc
    Try poweroff/poweron PC, try restart PC.
    If still no audio (don't re-initialize the kX DSP!) - export "HKCU\Software\kX" to .reg file and give me download link of it.
    Also, you can make shortcut to the .kx file:
    Code:
    "%programfiles%\kxmixer.exe" --shell --load-settings my_saved_dsp_settings.kx
    where "my_saved_dsp_settings.kx" is exported DSP settings.
    [​IMG]
     
    Last edited: May 20, 2016
    tml3nr likes this.
  8. thomasabarnes

    thomasabarnes Long Time ***** Friend

    Joined:
    Jan 7, 2003
    Messages:
    1,404
    Likes Received:
    13
    Trophy Points:
    48
    Hi mole2old:

    Thank you for your prompt reply!

    I have isolated what the cause of the problem is on my system.

    Audio works well after using your fix, restart after restart. The need to reinitialize the kX DSP to get audio after Windows loads occurs after installing Plug Ins in Uniform pack ufxsetup.52.

    After doing a clean install, in accordance to your last post above, and using your most recent fix, I have audio restart after restart when Windows completes loading up. After two clean installs of the kX 3552 driver and using your fix, I have audio after Windows loads up until I install the UFX pack (ufxsetup.52). As I have read around here, ufxsetup.52 is the version of Max's UFX pack that was provided to work with Windows 7 operating systems, but was reported to also work with Windows 10. That is why I've been installing that pack to use with the kX driver 3552 on my Windows 10 Professional x64 system.

    It's really a simple thing to just reinitialize the kX DSP in order to get audio after Windows load. I would be missing out on Max M's high end plug ins, if I decided not to install the UFX pack just because I have to reinitialize the kX DSP to get audio to sound after Windows starts up. And not to install Max M's high end plug ins, just because of such a minor matter would be a poor decision, in my opinion.

    mole2old, your direction for me to try a clean re-install and use your fix again, resulted in my isolating what the cause of the problem is on my system. Thanks for the help!

    I wonder if any other users who install ufxsetup.52 in Windows 10 x64 are experiencing the same issue as I (Meaning that a user has to reinitialize the kX DSP after Windows loads up in order to get audio).

    Thanks for everything, mole2old. :)
     
    Last edited: May 28, 2016
  9. mole2old

    mole2old Thinking sucks, let’s go break something ...

    Joined:
    Jul 14, 2013
    Messages:
    27
    Likes Received:
    15
    Trophy Points:
    3
    You're welcome!
    p.s Is it a good idea to use any plugins directly with kx-DSP? Imho no. Native Instruments, Nomad Factory, and other famous VST/VSTi plugins/instruments + DAW (Cakewalk, Samplitude, etc) = only one right direction. ;)
    Good luck!
     
    thomasabarnes likes this.
  10. Irwin Mainway

    Irwin Mainway New Member

    Joined:
    May 25, 2016
    Messages:
    1
    Likes Received:
    0
    Trophy Points:
    1
    I finally have audio restored from my trusty SB0090 Creative Audigy 2 FW card after installing Windows 10 32 bit.
    Even with no onboard audio - so no conflicts - this was a huge pain until I found the latest kX project version 3552 and hotfix here.
    Verified audio working before restart after select "OK".
    (I did first update the multimedia device drivers in Device Manager using the loaded 3552 driver package.)

    After restart, get this error message
    "kX devices not found. Reinstall the drivers"
    kX error initializing WinMM subsystem"

    Instead I continued to [30.04.2014]_mole-hotfix-kx-3552.exe
    kX Manager icon appears in taskbar with myriad of options.
    After second restart kX Mixer now works, however "Failed to create sound" accompanies the test tones out of the speakers - fine by me.

    Analog audio - via Wave Out 4/5 to green output jack.

    THANKS - maybe after a year of complaining to Microsoft they would issue a patch for their Windows 10 driver selected from 2006.
     
    Last edited: May 25, 2016
  11. Tyrsonswood

    Tyrsonswood HH's curmudgeon

    Joined:
    Mar 7, 2008
    Messages:
    13,644
    Likes Received:
    1,383
    Trophy Points:
    138

    Speaker test function hasn't worked since Vista...
     
  12. spacelordjoe

    spacelordjoe New Member

    Joined:
    Jun 5, 2013
    Messages:
    13
    Likes Received:
    0
    Trophy Points:
    1
    can somebody share the ufxsetup.52 again? all the links are dead. That would be great!
     
  13. jord

    jord New Member

    Joined:
    Jun 17, 2016
    Messages:
    1
    Likes Received:
    0
    Trophy Points:
    1
    Hello, I have a audigy 2zs in windows 7 64bit working well with drivers 3550, with 3552 I had some issues

    now that I put windows 10, follow your directives by placing them necessarily 3552 and the new fix, the screen looks all properly but no sound from any exit (I have six speakers)

    If you modify the fix to work with the drivers in 3550 64bit, will work for me? Thanks
     
  14. spacelordjoe

    spacelordjoe New Member

    Joined:
    Jun 5, 2013
    Messages:
    13
    Likes Received:
    0
    Trophy Points:
    1
    Has somebody any issues using plugins? Some of them cannot be installed, some Do, but calling their ui the mixer crashes
     
  15. spacelordjoe

    spacelordjoe New Member

    Joined:
    Jun 5, 2013
    Messages:
    13
    Likes Received:
    0
    Trophy Points:
    1
    Hey, try to use different output. I had luck with Wave2/3
    I had no luck with 3550, even on 32bit Win10. It has the same issues
     
  16. mole2old

    mole2old Thinking sucks, let’s go break something ...

    Joined:
    Jul 14, 2013
    Messages:
    27
    Likes Received:
    15
    Trophy Points:
    3
    IMHO
     
  17. spacelordjoe

    spacelordjoe New Member

    Joined:
    Jun 5, 2013
    Messages:
    13
    Likes Received:
    0
    Trophy Points:
    1
    Hi mole2old, I'm using kx as a 8 channel car DSP for a full active system with no passive filtering. No recording, no mixing. Just equalizer/filter/delays. Using KX only was just easy, reliable and secure.
     
    Last edited: Jul 1, 2016
  18. spacelordjoe

    spacelordjoe New Member

    Joined:
    Jun 5, 2013
    Messages:
    13
    Likes Received:
    0
    Trophy Points:
    1
    I still need some help on getting plugins to work. Even if I go for VST and other software I need somehow to control master volume. How do you control this?
    When I use ProFX I need MasterVolume.kxl. Its last version was working great with 3550 on XP but for 3552 64 bit or 32 bit I get error message "invalid library"
     
  19. mole2old

    mole2old Thinking sucks, let’s go break something ...

    Joined:
    Jul 14, 2013
    Messages:
    27
    Likes Received:
    15
    Trophy Points:
    3
    I suggest you to try "Magix_Samplitude_Professional_7.22", Wavelab_5.* or 6.* on Windows XP/7 and well-known VST from most popular VST bundles. Dont use KX-355* and my fix on WinXP, i think what the best choice is kx-3538(48) in this case. Also, insert any plugins directly to KX-DSP == bad idea. You can receive good results only with professional DAW and plugins/instruments. Of course, you can try DAW Reaper for free.
     
  20. spacelordjoe

    spacelordjoe New Member

    Joined:
    Jun 5, 2013
    Messages:
    13
    Likes Received:
    0
    Trophy Points:
    1
    Currently i'm using KX3550 with XP which is working pretty fine but I'd like to switch to WIN10 and try dephonica or any other software DSP. The major problem with the software DSPs is that you have somehow control the analog output level. Nikitins RG is an option, but I'm not very good in hardware design and it would take some time to get it work.

    BTW, I could partly compile kx and even develop my own plugin for 3550. A 1ch 24db crossover which is working pretty good.
     

Share This Page

visited