XPVistaWin 7 Driver Support for AudigyXFIXtreme AudioUSBPCI E Support Cards

Discussion in 'PAX Drivers' started by Robert McClelland, Nov 20, 2007.

  1. Robert McClelland

    Robert McClelland I'm An Uncle for 2nd time Staff Member

    Joined:
    Jun 25, 2002
    Messages:
    15,327
    Likes Received:
    255
    Trophy Points:
    108
  2. flowwolf

    flowwolf New Member

    Joined:
    Apr 12, 2011
    Messages:
    20
    Likes Received:
    0
    Trophy Points:
    0
    Hi Robert!
    Certain people have problems when they try to use the 64-bit OpenAL library on 64-bit operating systems like XP 64-bit or Win7 64-bit. OpenAL definitely supports a 32-bit OpenAL32.dll and a 64-bit OpenAL64.dll; however, when someone installs the PAX (or either the base Creative) X-Fi driver, the 64-bit ct_oal.dll won't be copied to the \Windows\System32 directory

    Instead of, the 32-bit ct_oal.dll is copied to the \Windows\System32 and it should be in the \Windows\SysWow64 dir

    Could you fix this little problem in the PAX driver? There are people who would like to run 64-bit applications with OpenAL

    Best Regards, Akos
     
  3. Robert McClelland

    Robert McClelland I'm An Uncle for 2nd time Staff Member

    Joined:
    Jun 25, 2002
    Messages:
    15,327
    Likes Received:
    255
    Trophy Points:
    108
    I will look into this issue :). I don't think it be that hard to change paths I will PM you Test set you can tell me if works :) If works I redo others sets hehe. Set be v4.55 :). That's for idea :).
     
    Last edited: Jun 21, 2011
  4. Robert McClelland

    Robert McClelland I'm An Uncle for 2nd time Staff Member

    Joined:
    Jun 25, 2002
    Messages:
    15,327
    Likes Received:
    255
    Trophy Points:
    108
    It work wahoooo ct_oal.dll is in correct spot :D.
     
  5. Robert McClelland

    Robert McClelland I'm An Uncle for 2nd time Staff Member

    Joined:
    Jun 25, 2002
    Messages:
    15,327
    Likes Received:
    255
    Trophy Points:
    108
  6. flowwolf

    flowwolf New Member

    Joined:
    Apr 12, 2011
    Messages:
    20
    Likes Received:
    0
    Trophy Points:
    0
    What about the pcie Titanium series :) btw. thanks for fixing!
     
  7. Robert McClelland

    Robert McClelland I'm An Uncle for 2nd time Staff Member

    Joined:
    Jun 25, 2002
    Messages:
    15,327
    Likes Received:
    255
    Trophy Points:
    108
    I will be posting test sets other thread few mins
     
  8. cyberloner

    cyberloner New Member

    Joined:
    Aug 3, 2010
    Messages:
    4
    Likes Received:
    0
    Trophy Points:
    0
    this error is happening to version 0007 0008 and having issue the mod version as well ( happen when creative added the voice changing toy i think)
    i always using recording while playing in camfrog and broadcast song...
    the best way to fix the issue is change to older version driver 0006

    Hope this help.
    By the way i am using SB0880 , This have nothing to do with all hardware, ram, what so ever. I format windows a few times to try this error.
    Answer is using older driver.
     
  9. Robert McClelland

    Robert McClelland I'm An Uncle for 2nd time Staff Member

    Joined:
    Jun 25, 2002
    Messages:
    15,327
    Likes Received:
    255
    Trophy Points:
    108
    if your talking about HD one friend of mine working on a fix he had T HD same issue he can't installed new beta with my tweaks so far so good.
     
  10. cyberloner

    cyberloner New Member

    Joined:
    Aug 3, 2010
    Messages:
    4
    Likes Received:
    0
    Trophy Points:
    0
    just for your info mine X-FI Titanium 16MB X-ram version non HD
    still using winxp...

    still not going win 7 since have a lot issue with video software
     
  11. Robert McClelland

    Robert McClelland I'm An Uncle for 2nd time Staff Member

    Joined:
    Jun 25, 2002
    Messages:
    15,327
    Likes Received:
    255
    Trophy Points:
    108
    IF I redo T 3.55 are you willing test asp in PM? I need to know by 7pm tongiht :p. well remember it's only for vista and 7 still there no xp drivers for that card I think
     
  12. Stryder1999

    Stryder1999 New Member

    Joined:
    Jul 16, 2011
    Messages:
    1
    Likes Received:
    0
    Trophy Points:
    0
    I would like first to thank you for your contribution to the “Sound Blaster” community. If, not for your efforts, many Windows7 adoptees would be out of luck considering the indifference of the CL staff. I would like to bring one to your attention that I don’t think you can be aware of. After much searching, reading forums, downloading drivers etc., I found references to “PAX” drivers as being the answer. Finally deciding that “PAX-PCI-XFI-ALL-OS-DriverV4.55” was what I needed, I found it on the “Hardwareheaven” site under in one of your posts. It seems as though when I downloaded, the request went to download.guru3d.com. What downloaded was “PAX-PCI-XFI-ALL-OS-DriverV4.55-[guru3d.com].exe. This installed the 7z archiver and extracted the file “PAX-PCI-XFI-ALL-OS-DriverV4.55.7z. The driver installed easily and all the functions of the card were working beautifully, Thanks again!!! After some time internet functions (primarily with Foxfire) began acting strangely. I purchased and installed Stopzilla and after the scan it found in instance of the "Backdoor Turkojan" Trojan in the 7z uninstall.exe. There was also an instance of the Vundo Trojan but I don’t know if they were related. I just wanted to caution you to maybe screen the sites that you allow to distribute your efforts. Again Thanks for all your hard work.
     
  13. Robert McClelland

    Robert McClelland I'm An Uncle for 2nd time Staff Member

    Joined:
    Jun 25, 2002
    Messages:
    15,327
    Likes Received:
    255
    Trophy Points:
    108
    wait for v4.60 drivers tomorrow :p. it be after dinner. There way promo in nhl 11 in the hut on ps3 :p. busy rebuilding my team lol
     
  14. cyberloner

    cyberloner New Member

    Joined:
    Aug 3, 2010
    Messages:
    4
    Likes Received:
    0
    Trophy Points:
    0
    Last edited: Jul 17, 2011
  15. Robert McClelland

    Robert McClelland I'm An Uncle for 2nd time Staff Member

    Joined:
    Jun 25, 2002
    Messages:
    15,327
    Likes Received:
    255
    Trophy Points:
    108
    They are base on lastest beta drivers ;)
     
  16. Oak Yolk

    Oak Yolk New Member

    Joined:
    Jul 22, 2011
    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    0
    I tried to solve my problem using the forum-search but wasn't really successful.

    I'm using Windows 7 32bit and Audigy 2ZS.
    Installed PAX PCI Audigy All-OS-Driver V2.50 and PAX MASTER Suite V2.05.

    Driver works fine for me but Suite won't work - only Volume control window.
    When I try to start Creative Console for example I get 'selected audio device not supported by programm - do you want to select a different device?'. When I click on yes there's only the option to click on 'Audigy 2ZS (WDM)'.

    I did uninstall all drivers before I installed your drivers & the suite.

    Really no idea how to fix that. I need the suite to activate my subwoofer via 'Bass-redirection'.

    As I guess this is a common issue and I hope you've got a solution to my problem.
    Sorry for not being able to find anything using the forum-serach.
     
  17. Robert McClelland

    Robert McClelland I'm An Uncle for 2nd time Staff Member

    Joined:
    Jun 25, 2002
    Messages:
    15,327
    Likes Received:
    255
    Trophy Points:
    108
    Master suite not for audigy cards :p. Please used audigy 4 pro software. New audigy release driver soon :).
     
  18. battynatty2003

    battynatty2003 New Member

    Joined:
    Jul 27, 2011
    Messages:
    1
    Likes Received:
    0
    Trophy Points:
    0
    hi i am having serious problems trying to get sound on my computer..... all i know is my pci device is:-

    PCI\VEN_1002&DEV_437B&SUBSYS2A31103C&REV_01\3&267A616A&0&A2

    seem to be having problems with drivers for SM BUS CONTROLLER too but i have no idea what that is where as i know the pci device is high defition audio. im not a computer person so please please please can someone help me!!!! my OS is windows XP. i need sound!!! :tears::confused:
     
  19. Robert McClelland

    Robert McClelland I'm An Uncle for 2nd time Staff Member

    Joined:
    Jun 25, 2002
    Messages:
    15,327
    Likes Received:
    255
    Trophy Points:
    108
    Looks like On board audio.
     
  20. drew1

    drew1 New Member

    Joined:
    Jul 28, 2011
    Messages:
    1
    Likes Received:
    0
    Trophy Points:
    0
    hello, i will be guying an Sound Blaster Audigy SE for a new rig and most of your posts on upgrading the Sound Blaster Audigy SE card to xi-fi extreme series is gibberish to me..... mostly:confused:, could you post a driver download link for windows 7 64 bit for me? im getting this sound card with a pair of sennheiser pc151 for gaming
     

Share This Page

visited